1 Reply Latest reply: Oct 17, 2011 11:45 AM by ApexBine RSS

    SkillBuilders Modal Page... closes immediately after loading

      I would like to use the Modal Page plug-in from http://www.skillbuilders.com .*
      I installed the two sample applications from their web site with different results:
      The employee example works fine.
      The example with the modal feedback worked fine yesterday, but today it shrinks (after loading normally) so that I can't see anything but the bar with the window name and the close button.

      In my own application it's even worse:
      I have links in a table which should open a modal window on click.
      I tried several settings, but the only thing that's happening is that the window closes immediately after loading and showing the page for a half a second (or not at all).
      Leaving the "Auto-close On Element Selector" empty did not work. The default value "div#success-message" kept coming back until I replaced it with "null". But still no effect.

      Does anyone have any idea what could cause this behaviour?

      Best regards,

      The Security Settings for all three applications:
      Cache: Enabled
      Embed in Frames: Allow
        • 1. Re: SkillBuilders Modal Page... closes immediately after loading
          In the meantime I had the problem that the window didn't close at all, but I think I figured it out.
          So if the Modal Plug In does not work properly, check the following:
          <li>Does every process that should close the window have a 'Success Message' defined?
          <li>In the unconditional branch, is "include process success message" checked?
          <li>In the dynamic action, is "Auto-close On Element Selector" set to "div.t1success" in the true action?

          BTW: The "shrinking problem" described in the first post still exists - in IE. In Firefox, it works fine.

          Best regards,