0 Replies Latest reply: Sep 29, 2011 6:50 AM by 887817 RSS

    Deployment of oms.ear showing failed.

    887817
      Hi,

      I tried to deploy a cartridge in which some automations where defined. In the weblogic server it started showing nested errors like an infinite loop. So i stopped the server and restarted it.
      Now its showing error. Its showing deployment of oms.ear failed in the WL console. The error given is :<Unable to set the activation state to true for the application 'oms'.java.lang.NoSuchFieldError: a
      at com.mslv.oms.automation.AutomationDispatcher.<clinit>(Unknown Source)
      at com.mslv.oms.j2ee.LifecycleListener.postStart(Unknown Source)
      at weblogic.application.internal.flow.BaseLifecycleFlow$PostStartAction.run(BaseLifecycleFlow.java:292)
      at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
      at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
      Truncated. see log file for complete stacktrace
      java.lang.NoSuchFieldError: a
      at com.mslv.oms.automation.AutomationDispatcher.<clinit>(Unknown Source)
      at com.mslv.oms.j2ee.LifecycleListener.postStart(Unknown Source)
      at weblogic.application.internal.flow.BaseLifecycleFlow$PostStartAction.run(BaseLifecycleFlow.java:292)
      at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
      at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
      Truncated. see log file for complete stacktrace.

      How can i solve this problem?

      Edited by: 884814 on Sep 29, 2011 4:49 AM