0 Replies Latest reply: Sep 29, 2011 7:31 AM by 523150 RSS

    Custom DB authentication to an application from Oracle Portal not working.

    523150
      Hi All,

      We have a Portal customized and integrated to LDAP for SSO.

      From the portal, we have a link that takes to another custom application that requires another level of authentication. We have implemented this authentication as custom Database based authentication.

      When user login to the portal and access this link, he will be directed for authentication again. This custom application has been installed on a different OC4J instance while Oracle Portal is running in a different OC4J instance.

      Issue is though user details are being propagated to the custom application page, we are receiving an error saying authentication failed.

      In the OC4J instance specific for this custom application, we have configured jazn.xml to use custom authentication.

      Below is the code:

      <?xml version = '1.0' encoding = 'UTF-8' standalone = 'yes'?>
      <!DOCTYPE jazn PUBLIC "JAZN Config" "http://xmlns.oracle.com/ias/dtds/jazn-9_04.dtd">
      <jazn provider="XML" location="./jazn-data.xml" default-realm="jazn.com">
      <property name="role.mapping.dynamic" value="true"/>
      <property name="custom.loginmodule.provider" value="true"/>
      </jazn>

      and in jazn-data.xml, we gave the role mapping.

      But the problem is when the link to the custom application is accessed, it seems like the custom autentication mechanism is not working.

      Can anyone throw light on this?

      Do we need to give the same configuration in the j2ee/home/config directory files also?

      Can we use both LDAP and custom DB authentication with in the same OAS setup. Remember as of now, Portal and custom application are running in different OC4J instances but within the same OAS.

      Any help in this regard will be highely appreciated.

      Thanks,
      Sasi Bhushan