This discussion is archived
9 Replies Latest reply: Oct 9, 2011 5:39 AM by 892560 RSS

ss7000 enabling jumbo frames on aggregation crashes

892560 Newbie
Currently Being Moderated
Hello,

I have a Sun Storage 7110 with the latest update patch. I am trying to configure an aggregation with 2 NICs with jumbo frames. when i apply the settings the devices disappear as if they are not plumbed at all.
I reboot the machine and it seems that the devices are up and everything is configured but in the shell console when i type ifconfig i see that the aggr still has 1500 mtu and i cannot change it. the error i get:
ifconfig aggr2 mtu 9000
ifconfig: setifmtu: SIOCSLIFMTU: aggr2: Invalid argument

I'll be happy for some advice/help
thanks,
Michael.
  • 1. Re: ss7000 enabling jumbo frames on aggregation crashes
    Nik Expert
    Currently Being Moderated
    Hi.
    Please show results from СLI 7110:


    configuration net datalinks select aggr2 show
    configuration net datalinks show
    maintenance system updates show

    Regards.
  • 2. Re: ss7000 enabling jumbo frames on aggregation crashes
    892560 Newbie
    Currently Being Moderated
    here:

    configuration net datalinks select aggr2 show
    Properties:
    class = aggregation
    label = Aggr2
    mac = 0:21:28:0:95:d6
    links = nge0,nge3
    jumbo = true
    policy = L3
    mode = active
    timer = short
    uaddr =
    key = 2


    configuration net datalinks show
    Datalinks:

    DATALINK CLASS LINKS STATE LABEL
    aggr1 aggregation nge2 up Aggr1-Data
    nge1
    aggr2 aggregation nge0 unknown Aggr2
    nge3


    maintenance system updates show
    Updates:

    UPDATE DATE STATUS
    ak-nas@2010.08.17.2.0,1-1.18 2010-12-9 18:33:56 previous
    ak-nas@2010.08.17.2.1,1-1.21 2011-3-10 23:49:47 previous
    ak-nas@2010.08.17.3.1,1-1.28 2011-5-25 15:04:11 previous
    ak-nas@2010.08.17.4.0,1-1.31 2011-7-14 14:28:23 previous
    ak-nas@2010.08.17.4.1,1-1.35 2011-9-2 00:04:08 current
  • 3. Re: ss7000 enabling jumbo frames on aggregation crashes
    Nik Expert
    Currently Being Moderated
    It's look like ok.

    I try teston our system:

    configuration net datalinks select aggr1 set jumbo=false
    configuration net datalinks select aggr1 commit
    Automaticaly set MTU to 1500.

    configuration net datalinks select aggr2 set jumbo=true
    configuration net datalinks select aggr2 commit
    Automaticaly set MTU to 9000.


    Can you try again and show logs/errors.


    Regards.
  • 4. Re: ss7000 enabling jumbo frames on aggregation crashes
    892560 Newbie
    Currently Being Moderated
    "Automaticaly set MTU to 9000" is this a command?

    i did every thing else that u said and there are no error logs...
    what log exactly should i post?
  • 5. Re: ss7000 enabling jumbo frames on aggregation crashes
    Nik Expert
    Currently Being Moderated
    Hi.

    Commands results from test system:
    ZFS-7120:> configuration net datalinks select aggr1 set jumbo=false
                             jumbo = false
    ZFS-7120:> configuration net datalinks select aggr1 commit
    ZFS-7120:> configuration net datalinks select aggr1 show
    Properties:
                             class = aggregation
                             label = Untitled Datalink
                               mac = 0:21:28:c0:94:72
                             links = igb2,igb3
                             jumbo = false
                            policy = L3
                              mode = active
                             timer = short
                             uaddr =
                               key = 1
    
    ZFS-7120:> shell
    ....
    ZFS-7120# ifconfig aggr1
    aggr1: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 8
            inet 192.168.100.100 netmask ffffff00 broadcast 192.168.100.255
            ether 0:21:28:c0:94:72
    ZFS-7120# exit
    logout
    ZFS-7120:> configuration net datalinks select aggr1 set jumbo=true
                             jumbo = true
    ZFS-7120:> configuration net datalinks select aggr1 commit
    ZFS-7120:> configuration net datalinks select aggr1 show
    Properties:
                             class = aggregation
                             label = Untitled Datalink
                               mac = 0:21:28:c0:94:72
                             links = igb2,igb3
                             jumbo = true
                            policy = L3
                              mode = active
                             timer = short
                             uaddr =
                               key = 1
    
    ZFS-7120:> shell
    .....
    ZFS-7120# ifconfig aggr1
    aggr1: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 9000 index 9
            inet 192.168.100.100 netmask ffffff00 broadcast 192.168.100.255
            ether 0:21:28:c0:94:72
    ZFS-7120# exit
    logout
    ZFS-7120:>
    So it's look like that you not need manualy set MTU. It should corrected automaticaly, but not work on your system.

    You can try again disable and reenable jumbo frames.

    Check output for all commands.

    List availabel logs:
    maintenance logs list

    Сheck:
    maintenance logs select alert show
    maintenance logs select system show
    maintenance logs select fltlog show


    Regards.
  • 6. Re: ss7000 enabling jumbo frames on aggregation crashes
    892560 Newbie
    Currently Being Moderated
    this is what i get after committing the configuration:

    The committed network configuration refers to device nge3, but the device is either missing or malfunctioning.
    Accordingly, references to nge3 have been removed from all displayed datalinks and interfaces.

    Objects no longer associated with any device must be deleted or updated to use another device before further networking changes can be committed.

    for nge0 it is the same alert


    in the shell i can see the aggregation:

    #ifconfig -a
    lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
    inet 127.0.0.1 netmask ff000000
    aggr1: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
    inet 192.168.1.104 netmask ffffff00 broadcast 192.168.1.255
    ether 0:21:28:0:95:d8
    aggr2: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 9000 index 5
    inet 192.168.3.101 netmask ffffff00 broadcast 192.168.3.255
    ether 0:21:28:0:95:d6
    lo0: flags=2002000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6,VIRTUAL> mtu 8252 index

    but i get this:

    #dladm show-phys
    LINK MEDIA STATE SPEED DUPLEX DEVICE
    nge2 Ethernet up 1000 full nge2
    nge0 Ethernet down 0 unknown nge0
    nge1 Ethernet up 1000 full nge1
    nge3 Ethernet up 1000 full nge3

    configuration net devices show
    Devices:

    DEVICE UP SPEED MAC
    nge1 true 1000 Mbit/s 0:21:28:0:95:d7
    nge2 true 1000 Mbit/s 0:21:28:0:95:d8




    regards.
  • 7. Re: ss7000 enabling jumbo frames on aggregation crashes
    892560 Newbie
    Currently Being Moderated
    i tried to set from scratch and i gwet this error in the alert tab:



    Description     The service 'appliance/kit/network/datalink:aggr2' failed and could not be restarted.
    Type     Major Defect
    Impact     The service is unavailable.
    Automated response     The service has been placed into the maintenance state.
    Recommended action     If the service corresponds to one of the configurable services on the appliance, check the service configuration and log files for any errors. Correct the errors and restart the service. If the service is an internal appliance service, mark the fault repaired. If the problem persists, contact your service provider.
    Event time     2011-10-6 11:46:30
    Unique Identifier     fbdad9f6-e99b-c83e-8bc9-9df607903c05
    Status     This alert is associated with an active problem on the system. For more information specific to this alert, see the Active Problems page.

    regards
  • 8. Re: ss7000 enabling jumbo frames on aggregation crashes
    Nik Expert
    Currently Being Moderated
    Hi.
    Try remove aggr2.

    Check that all network interfaces available.
    Try recreate agregate.


    Regards.
  • 9. Re: ss7000 enabling jumbo frames on aggregation crashes
    892560 Newbie
    Currently Being Moderated
    Thanks,

    It resolved the problem,

    regards.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points