This discussion is archived
4 Replies Latest reply: Oct 27, 2011 7:38 AM by 813136 RSS

AutoVue WebService Error

813136 Newbie
Currently Being Moderated
Hello,

I am trying out AutoVue Web services, There is no DMS just with AutoVue Server Installation

I keep getting "Cannot connect to jvueserver: http://localhost:8080/VueServlet/servlet/VueServlet", when calling any method on Web-Service other than Ping method, VueServlet and Test Applet pages are working fine,

I can also see the WSDL when I browse to http://localhost:8080/AutoVueWS/VueBeanWS?wsdl, I can also call the Ping method and it returns following result:

*[Ping]*
Server Date/Time:Tue Oct 18 11:19:04 BST 2011Pool, Size: 1
Max waiting time: 7200
Pool, # of active: 0
Pool, # of idle: 0
AutoVue Client Build Number:7910
AutoVue Client Build Date:2011-08-29
initialJVueServer: http://localhost:8080/VueServlet/servlet/VueServlet
vuelink Protocol(s): null
vuelink PropsDir: C:/Oracle/AutoVueWS/autovue_webservices/sample_config/
destination DIR: C:/temp
log4j config file: C:/Oracle/AutoVueWS/autovue_webservices/sample_config/log4j.properties
*[Ping]*

Here is the sample code (C#)
VueBeanWS ws = new VueBeanWS();
string ping = ws.ping("");
searchText[] text = ws.getText("http://localhost/sample.pdf", null);


I also tried testing the Web-service with SoapUI but got the same error, here is the out-put

<S:Envelope xmlns:S="http://schemas.xmlsoap.org/soap/envelope/">
<S:Body>
<S:Fault xmlns:ns4="http://www.w3.org/2003/05/soap-envelope">
<faultcode>S:Server</faultcode>
<faultstring>java.net.ConnectException: Cannot connect to jvueserver: http://localhost:8080/VueServlet/servlet/VueServlet</faultstring>
</S:Fault>
</S:Body>
</S:Envelope>

My Environment Details:

Windows 2008 R2 64 Bit, GlassFish (OpenSource Version) Server and AutoVue (No DMS), everything is running under Admin account and I am logged in as Admin

Am I missing something?

Thanks
  • 1. Re: AutoVue WebService Error
    626821 Newbie
    Currently Being Moderated
    First please replace the localhost with the correct machine name.
    Second post configuration file web.xml, so we can exam it.

    Thanks,
    Song
  • 2. Re: AutoVue WebService Error
    813136 Newbie
    Currently Being Moderated
    Hi Song

    Thanks for reply, I have replaced localhost with the machine name every where, but still get the same error,

    here are the content of web.xml

    <?xml version="1.0" encoding="UTF-8"?>
    <web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://java.sun.com/xml/ns/javaee" xmlns:web="http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd" id="WebApp_ID" version="2.5">
    <display-name>AutoVue WebService</display-name>
    <welcome-file-list>
    <welcome-file>index.jsp</welcome-file>
    </welcome-file-list>

    <!-- If the VueServlet is being deployed in the same context as AutoVue Web Services, use this section to enable the VueServlet. Note it is recommended to deploy it on a separate server.
    <servlet id="csi_servlet">
    <description>update hostname and port number of AutoVue(JVueServer) here, default is: localhost:5099</description>
    <servlet-name>VueServlet</servlet-name>
         <servlet-class>com.cimmetry.servlet.VueServlet</servlet-class>
         <init-param>
              <param-name>JVueServer</param-name>
              <param-value>localhost:5099</param-value>
         </init-param>
         </servlet>
         
    <servlet-mapping id="csi_servletMapping">
         <servlet-name>VueServlet</servlet-name>
         <url-pattern>/servlet/VueServlet</url-pattern>
    </servlet-mapping>
    -->
    <env-entry>
    <description>enter the initial maximum size of jvue pool. Default is 1 (to accommodate large files)</description>
    <env-entry-name>maxPoolSize</env-entry-name>
    <env-entry-type>java.lang.String</env-entry-type>
    <env-entry-value>1</env-entry-value>
    <injection-target>
    <injection-target-class>com.oracle.autovue.services.VueBeanWS</injection-target-class>
    <injection-target-name>maxPoolSize</injection-target-name>
    </injection-target>
    </env-entry>

    <env-entry>
    <description>
    maximum timeout (in seconds) while waiting to borrow from VueBean pool ( default : 7200 seconds)
    Make sure the thread timeout in the app server is at least the same as this number. (e.g. the Stuck Thread Max Time in the Weblogic.)
    </description>
    <env-entry-name>maxWait</env-entry-name>
    <env-entry-type>java.lang.String</env-entry-type>
    <env-entry-value>7200</env-entry-value>
    <injection-target>
    <injection-target-class>com.oracle.autovue.services.VueBeanWS</injection-target-class>
    <injection-target-name>maxWait</injection-target-name>
    </injection-target>
    </env-entry>

    <env-entry>
    <description>enter the maximum allowed number of parallel print jobs per printer (default : 1) </description>
    <env-entry-name>maxParallelPrintJob</env-entry-name>
    <env-entry-type>java.lang.String</env-entry-type>
    <env-entry-value>1</env-entry-value>
    <injection-target>
    <injection-target-class>com.oracle.autovue.services.VueBeanWS</injection-target-class>
    <injection-target-name>maxParallelPrintJob</injection-target-name>
    </injection-target>
    </env-entry>

    <env-entry>
    <description>enter the maximum allowed number of jobs in the buffer per printer (default : 5) </description>
    <env-entry-name>maxPrinterJobBuffer</env-entry-name>
    <env-entry-type>java.lang.String</env-entry-type>
    <env-entry-value>5</env-entry-value>
    <injection-target>
    <injection-target-class>com.oracle.autovue.services.VueBeanWS</injection-target-class>
    <injection-target-name>maxPrinterJobBuffer</injection-target-name>
    </injection-target>
    </env-entry>

    <env-entry>
    <description>Minimum memory should be available in order to borrow VueBean (default : 128)</description>
    <env-entry-name>minMemory</env-entry-name>
    <env-entry-type>java.lang.String</env-entry-type>
    <env-entry-value>128</env-entry-value>
    <injection-target>
    <injection-target-class>com.oracle.autovue.services.VueBeanWS</injection-target-class>
    <injection-target-name>minMemory</injection-target-name>
    </injection-target>
    </env-entry>

    <env-entry>
    <description>put full local path to log4j properties file</description>
    <env-entry-name>log4jPathFileName</env-entry-name>
    <env-entry-type>java.lang.String</env-entry-type>
    <env-entry-value>C:/Oracle/AutoVueWS/autovue_webservices/sample_config/log4j.properties</env-entry-value>
    <injection-target>
    <injection-target-class>com.oracle.autovue.services.VueBeanWS</injection-target-class>
    <injection-target-name>log4j</injection-target-name>
    </injection-target>
    </env-entry>


    <env-entry>
    <description>put a semicolon (;) separated list of vuelink protocols , if any .otherwise leave this empty</description>
    <!-- for example: <env-entry-value>vuelinkUCM;vuelinkSharePoint;vuelinkDCMT</env-entry-value> -->
    <env-entry-name>vuelinkProtocol</env-entry-name>
    <env-entry-type>java.lang.String</env-entry-type>
    <env-entry-value></env-entry-value>
    <injection-target>
    <injection-target-class>com.oracle.autovue.services.VueBeanWS</injection-target-class>
    <injection-target-name>vuelinkProtocol</injection-target-name>
    </injection-target>
    </env-entry>


    <env-entry>
    <description>
    local full path to directory that contains vuelinks connection properties. please note
    that each protocol defined in 'vuelinkProtocol' section must have a file with the same name in this folder
    e.g. vuelinkUCM.properties , vuelinkSharePoint.properties , vuelinkDCMT.properties should be present for above example.
    </description>
    <env-entry-name>vuelinkPropsDir</env-entry-name>
    <env-entry-type>java.lang.String</env-entry-type>
    <env-entry-value>C:/Oracle/AutoVueWS/autovue_webservices/sample_config/</env-entry-value>
    <injection-target>
    <injection-target-class>com.oracle.autovue.services.VueBeanWS</injection-target-class>
    <injection-target-name>vuelinkPropsDir</injection-target-name>
    </injection-target>
    </env-entry>


    <env-entry>
    <description>enter local directory for convert operation. web services package will output the convert result into this location (e.g. c:/output)</description>
    <env-entry-name>destinationDIR</env-entry-name>
    <env-entry-type>java.lang.String</env-entry-type>
    <env-entry-value>C:/temp</env-entry-value>
    <injection-target>
    <injection-target-class>com.oracle.autovue.services.VueBeanWS</injection-target-class>
    <injection-target-name>destinationDIR</injection-target-name>
    </injection-target>
    </env-entry>


    <env-entry>
    <description>
    enter the AutoVue Web Services deployment information. replace hostname, port number, and context with proper values
    e.g. http://localhost:7003/VueServlet/servlet/VueServlet
    </description>
    <env-entry-name>initialJVueServer</env-entry-name>
    <env-entry-type>java.lang.String</env-entry-type>
    <env-entry-value>http://win2k8-7:8080/VueServlet/servlet/VueServlet</env-entry-value>
    <injection-target>
    <injection-target-class>com.oracle.autovue.services.VueBeanWS</injection-target-class>
    <injection-target-name>initialJVueServer</injection-target-name>
    </injection-target>
    </env-entry>

    <env-entry>
    <description>enable/disable upload protocol (default: false)</description>
    <env-entry-name>isUploadProtocolEnabled</env-entry-name>
    <env-entry-type>java.lang.String</env-entry-type>
    <env-entry-value>true</env-entry-value>
    <injection-target>
    <injection-target-class>com.oracle.autovue.services.VueBeanWS</injection-target-class>
    <injection-target-name>isUploadProtocolEnabled</injection-target-name>
    </injection-target>
    </env-entry>

    </web-app>
  • 3. Re: AutoVue WebService Error
    Daniel Gariepy Journeyer
    Currently Being Moderated
    Hi Pateketu,

    I was performing tests using Glassfish 3.1.1 and got the same problem you are having. Feedback from our development side was to use a Java EE 5 app server and Glassfish 3.1.1 is EE6. I would recommand you test using Glassfish 2.1 and see if the issue still occurs.

    Thanks,
    Dan
  • 4. Re: AutoVue WebService Error
    813136 Newbie
    Currently Being Moderated
    Thanks Daniel

    Using Glassfish 2.1 worked, only thing is the PDFs that are generated by convert method can be opened up in AutoVue but could not open it in Acrobat Reader, it is showing not supported or damaged file error message

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points