1 Reply Latest reply: Nov 11, 2011 10:55 AM by crogers RSS

    Unable to fetch the headers in the response of a service through java code

    899626
      Hi All,

      Im working with the IDE eclipse-jee-galileo-SR2-win32.In my code Im sending the request to a service using ServiceClient.sendReceive() method. The response from the service is an empty text in the soap Body but with a http status:200 OK . The reponse is as below when testing the service directly:

      Response:

      HTTP/1.1 200 OK
      Server: --
      Content-Type : text/xml
      Content-length : 141
      Date : --

      <SOAP-ENV: Envelope xmlns:SOAP-ENV:"http://schemas.xmlsoap.org/soap/envelope">
      <SOAP-Env:Body/>
      </SOAP-ENV : Envelope>

      Please let me know your inputs to fetch the http response from the service using ServiceClient or Options. Any help is greatly appreciated.

      Thanks,
      Vyshnavi
        • 1. Re: Unable to fetch the headers in the response of a service through java code
          crogers
          Hi Vyshnavi,

          This post is probably more appropriate for the Web Services forum on OTN. This forum is intended to help with questions about Oracle Enterprise Pack for Eclipse and the tooling it provides.

          Here's a good reference for working with ServiceClient. It includes a detailed example.
          http://today.java.net/pub/a/today/2006/12/13/invoking-web-services-using-apache-axis2.html#working-with-serviceclient

          If you're still having issues with your client code, try the "Java Technologies for Web Services" forum on OTN...
          Java Technologies for Web Services
          Your post to the Web Services forum should also state whether the issue is specific to the particular service or if you're unable to get any WS clients running in your development environment. Also include a code snippet.

          Kind regards,
          Carlin