1 Reply Latest reply: Jan 26, 2012 6:01 AM by 842888 RSS

    Solaris 11 halts with NMI received

    900070
      After upgrading from Solaris 11 Express (snv_151a) to Solaris 11 (snv_175), snv_175 fails to boot. Within seconds of loading the kernel, the console displays "NMI received" and the system hangs. Sometimes I get a core-dump, but this is irregular.

      The hardware is a Dell Precision T5400, 4 core Xeon (X5450) @ 3.00GHz, 16 GB DDR2.

      I have reverted to the old snv_151a boot environment, which runs perfectly fine. As of yet I have not yet had the time to run with the kernel debugger, but I was wondering if anyone else has run into the same problem.


      More information available now, after booting the kernel with "-k"

      After the NMI received appears, the system seems stalled for about a minute then the following messages appear:

      WARNING: /pci@0,0/pci1028,21e@1f,2/disk@0,0 (sd1):
      SYNCHRONIZE CACHE command failed (5)


      WARNING: /pci@0,0/pci1028,21e@1f,2/disk@0,0 (sd1):
      drive offline


      WARNING: /pci@0,0/pci1028,21e@1f,2/disk@0,0 (sd1):
      drive offline

      NOTICE: zfs_parse_bootfs: error 6
      Cannot mount root on rpool/251 fstype zfs


      panic[cpu0]/thread=fffffffffbc36de0: vfs_mountroot: cannot mount root

      Warning - stack not written to the dump buffer
      fffffffffbc7fa30 genunix:vfs_mountroot+33a ()
      fffffffffbc7fa30 genunix:main+171 ()
      fffffffffbc7fa30 unix:_locore_start+90 ()

      panic: entering debugger (no dump device, continue to reboot)

      Welcome to kmdb
      Loaded modules [<list >]

      [0]>


      (I skipped the kmdb list, since I am typing this from my console)

      What's next? Any suggestions on what kmdb commands are most useful now to debug this issue? I will be searching for any possible solutions regarding the vfs_mountroot.



      Booting with -asv leads to limited information,

      After asking for the name of the system file (I hit enter), the kernel seems to boot, dumps a whole list of x86_features. At the question of the Retire Store, the process hangs, ie, no characters are echoed and the system is unresponsive.



      Edited by: user7778697 on Nov 14, 2011 7:01 AM

      Edited by: Bones on Nov 14, 2011 7:27 AM
        • 1. Re: Solaris 11 halts with NMI received
          842888
          I have the exact same problem with the exact same system.

          I also tried installing clean with with an 11/11 live install cd. When I boot live and start the install (on an empty drive), it fails with a "unable to resolve install target".
          next i try to run "live" gparted before I try to install. this is where it gets weird. gparted recognizes the target drive but when I try to make a partition the only format options available is NTFS and blank with the rest of the options greyed out. When I try to make a blank partition i get an error with no message and the target drive no longer appears in the list.

          lastly if i install solaris 11x and vmbox solaris 11/11 installs fine.