5 Replies Latest reply on Sep 6, 2013 3:53 PM by ed95a4fe-3ba2-414f-9835-f0eb187d80ff

    AME APEXP Workflow Issue

      Hi All,

      In R12 I have issue in APEXP (Expenses) Workflow.

      User has created expense report and the workflow has started.

      It went through AME process where it has find the approver for the expense and then notification went to the approver.

      After this we have a block acitivity which waits untill the approver apporves or rejects.

      The problem here is though the approver says that he is approved the expense sheet , the work flow status is not moving beynod the block activity in the AME process.

      AME Workflow (12345-1) shows the process is complete, the notification to the first approver is closed with an Activity of ‘Approve’.

      The main workflow (12345) is blocked and waiting for the response back from the AME workflow. It appears the spawned workflow is not updating the main workflow when it completes.

      Please guide me on this how to resolve.

        • 1. Re: AME APEXP Workflow Issue
          Hi Kumar/All
          I am facing the exactluy similar issue in R12 APEXP workflow.
          In my case also approver has approved the workflow but it got stuck at block activity in the main workflow.

          I tried to debug the issue and found that in the AME approval workflow ,a function AME Complete Approval is called after the approver has taken the action(reject or approve).
          this function in turn calls the wf_engine.completeactivity API......the output of this API should act as the response to main workflow(block) and it should start moving but its not happening.

          result           varchar2(1);
          WF_ENGINE.CompleteActivity(itemtype => 'APEXP',itemkey => XITMKEYW ,activity => 'AME_APPROVAL_BLOCK',result => Null);
          DBMS_OUTPUT.PUT_LINE('result is : '||result);

          WHEN OTHERS
          DBMS_OUTPUT.PUT_LINE('Error message : '||SQLERRM);
          I tried to run the complete activity from outside also and to my suprise i could see time stamp getting changed for the block but it still didnt proceed.

          i think this may be an oracle bug with R12. Please guide.
          • 2. Re: AME APEXP Workflow Issue
            Hi All,

            Any update on this issue...
            We are also facing the same issue.

            • 3. Re: AME APEXP Workflow Issue
              Hi All,
              I'm also facing the same issue with APEXP workflow.

              It just stalls in AME Set Current Approver -> Block.

              Please confirm if a bug has been logged with Oracle and would it be worthwhile to create an SR and follow up.

              • 4. Re: AME APEXP Workflow Issue

                Even we are facing the same issue in 11i APEXP workflow.

                It is getting stuck in Block Mode. Please suggest if already patch is there for issue , I have already raised the Oracle SR but we are not getting any good response from the analyst.

                Please suggest if any solution is there.

                • 5. Re: AME APEXP Workflow Issue

                  We are experiencing this same issue for 11i APEXP as well. We are only seeing it on occasional Expenses as well since the majority go through without a hitch.  I have not opened an SR yet, but maybe I will since this appears to be a reported issue.