11 Replies Latest reply on Nov 10, 2006 7:32 AM by Esther

    FRM -40502

    229159
      What can be the possible causes of the following error:

      "FRM-40502: ORACLE error: unable to read list of values."

      I have an LOV attached to the text item but when i try to open it, i get this error.
        • 1. Re: FRM -40502
          294029
          Hi,

          May be the Table in the record group has been dropped from the Database or its structure has been changed.

          Good Luck
          • 2. Re: FRM -40502
            424410
            Hi
            But man I am facing this problem. The database structure is ok and I make a view on that sql code.
            I call just select from that view in my Record group. but it is not working and returning the same error.
            Farhad
            • 3. Re: FRM -40502
              471016
              I had this problem: I checked access to the table, and sql in lov proper.
              • 4. Re: FRM -40502
                François Degrelle
                Hello,

                In this case, you have to provide the description of the table/view and the record group, else we have not enough element to answer.

                Francois
                • 5. Re: FRM -40502
                  494688
                  I have a customer bug which reports of this error.

                  FRM-40735: ON-ERROR trigger raised unhandled exception ORA-06508
                  FRM-40502 ORACLE error: unable to read list of values

                  Do we have any resolution for this ?
                  • 6. Re: FRM -40502
                    VOHRA Yasir
                    I was having the sample problem -
                    Actually i was populating a group on the field <Field> and then i was generating an loving on the same field - that leads to FRM-40502 ,
                    Check Your Application Guys -
                    May be U have the same problem as i had .

                    Hope it Helps
                    Thanks
                    • 7. Re: FRM -40502
                      VOHRA Yasir
                      Sorry guy that is my mistak that is not "loving" - i mean LOV
                      • 8. Re: FRM -40502
                        528424
                        I've just had this problem. The first column returned from the recordgroup was the result of a substr. This is something I've had before. Be careful with the first column returned in recordgroups as lov's have problems with it and can be fussy - here's what I had

                        SELECT
                        substr('A string of a value from a column in my table',1,22 ) col_1,
                        'Another column' col_2
                        FROM my_table
                        ORDER BY 1,2

                        I added a simple column literal to the front as follows

                        SELECT 'x' col_1,
                        substr('A substring of a value from a column in my table',1,22 ) col_2,
                        'Another column' col_3
                        FROM my_table
                        ORDER BY 2,3

                        You can always set the first columns width to zero in the lov
                        This seemed to do the trick

                        Cheers,

                        Rich
                        • 9. Re: FRM -40502
                          384824
                          Once i remove a single line comment "--" I had in my LOV, this error went away. I had commented out a duplicate join that was not needed.

                          -- Chuck
                          • 10. Re: FRM -40502
                            518928
                            I found this from: http://www.techonthenet.com/oracle/errors/ora06508.php

                            Error: ORA-06508: PL/SQL: could not find program unit being called

                            Cause: You tried to call a stored procedure, but the stored procedure could not be found.

                            Action: The options to resolve this Oracle error are:

                            The stored procedure may have been dropped. Try re-creating the stored procedure.
                            The stored procedure may have compiled with errors. Try fixing the errors and re-compiling.
                            • 11. Re: FRM -40502
                              Esther
                              Hi,

                              I also walked into this problem. I had to change a LOV because the LOV query took to long to execute. For this I set the property 'Filter Before Display' to Yes in order to display a query criteria dialog before executing the LOV query.

                              The record group query looks like this

                              SELECT a.column1
                              , a.column_2||' '||a.column3 column23
                              FROM view

                              The first column in the LOV is COLUMN_23.

                              The Forms Help tells me that the query criteria applies to the first column in the LOV. This is not true: the entered query criteria applies to the first column in the record group query.

                              If I made the concatenated column the first column in the record group I ran into the FRM-40502 error. I added the concatenated column to my view to work around this problem.

                              Greetings

                              Esther