1 2 Previous Next 20 Replies Latest reply on Nov 27, 2011 1:29 AM by __OUTSIDER___

    OEL 6.1 YUM proxy problem

    __OUTSIDER___
      Hi all,
      I have some issue with OEL 6.1 YUM proxy.

      *[root@rac1 tmp]# uname -a*
      Linux rac1.oracle.cloud 2.6.32-100.34.1.el6uek.x86_64 #1 SMP Wed May 25 17:46:45 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux
      *[root@rac1 tmp]# rpm -qa | grep yum*
      yum-metadata-parser-1.1.2-16.el6.x86_64
      yum-3.2.29-17.0.1.el6.noarch
      yum-rhn-plugin-0.9.1-26.0.2.el6.noarch
      yum-utils-1.1.30-6.el6.noarch
      PackageKit-yum-plugin-0.5.8-19.0.1.el6.x86_64
      PackageKit-yum-0.5.8-19.0.1.el6.x86_64
      *[root@rac1 tmp]# cat /etc/yum.repos.d/public-yum-ol6.repo*
      [ol6_ga_base]
      name=Oracle Linux 6 GA - $basearch - base
      baseurl=http://public-yum.oracle.com/repo/OracleLinux/OL6/0/base/$basearch/
      gpgkey=http://public-yum.oracle.com/RPM-GPG-KEY-oracle-ol6
      gpgcheck=0
      enabled=1

      [ol6_u1_base]
      name=Oracle Linux 6 U1 - $basearch - base
      baseurl=http://public-yum.oracle.com/repo/OracleLinux/OL6/1/base/$basearch/
      gpgkey=http://public-yum.oracle.com/RPM-GPG-KEY-oracle-ol6
      gpgcheck=0
      enabled=1
      *[root@rac1 tmp]# cat /etc/yum.conf*
      [main]
      cachedir=/var/cache/yum/$basearch/$releasever
      debuglevel=2
      sslverify=false
      logfile=/var/log/yum.log
      pkgpolicy=newest
      distroverpkg=redhat-release
      tolerant=1
      exactarch=1

      # The proxy server - proxy server:port number
      proxy=http://xxx.xxx.xxx.xxx:3128
      # The account details for yum connections
      proxy_username=xxx
      proxy_password=@$xxx


      *[root@rac1 tmp]# yum update*
      http://public-yum.oracle.com/repo/OracleLinux/OL6/0/base/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 5 - "Couldn't resolve proxy '$xxx@192.168.1.50'"
      Trying other mirror.
      Error: Cannot retrieve repository metadata (repomd.xml) for repository: ol6_ga_base. Please verify its path and try again
      [root@rac1 tmp]#

      In OEL5.7 this works fine without any problem. I think this related to OEL6.1, maybe YUM does not understand proxy, my password for proxy starting with @$ but I changed my password and
      output is changed to

      *[root@rac1 tmp]# yum update*
      http://public-yum.oracle.com/repo/OracleLinux/OL6/0/base/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 407"
      Trying other mirror.
      Error: Cannot retrieve repository metadata (repomd.xml) for repository: ol6_ga_base. Please verify its path and try again
      [root@rac1 tmp]#

      If anyone can help me please reply.

      ./thanks
        • 1. Re: OEL 6.1 YUM proxy problem
          Avi Miller-Oracle
          __OUTSIDER___ wrote:
          I have some issue with OEL 6.1 YUM proxy.
          First, don't enable both those channels -- you want either ol6_ga_base or ol6_u1_base, not both.
          proxy_password=@$xxx
          Does your password really start with an @ symbol? Or @$? I'm confused as to why this is here.
          1 person found this helpful
          • 2. Re: OEL 6.1 YUM proxy problem
            506787
            I agree with Avi: don't enable multiple channels which can contradict. Enable one channel.

            I also agree with Avi about the confusion: what do the '$' and '@' characters mean with 'xxx', or is '$@xxx' truly your password?

            The problem you see is not getting authenticated by the proxy, so yum is unable to retrieve the stuff it wants.

            In order to get the shell from stopping interpreting $ as a variable, simply use a single quote before and after the password.
            so:
            $ export http_password='$@xxx'
            1 person found this helpful
            • 3. Re: OEL 6.1 YUM proxy problem
              __OUTSIDER___
              Avi Miller wrote:
              __OUTSIDER___ wrote:
              I have some issue with OEL 6.1 YUM proxy.
              First, don't enable both those channels -- you want either ol6_ga_base or ol6_u1_base, not both.
              proxy_password=@$xxx
              Does your password really start with an @ symbol? Or @$? I'm confused as to why this is here.
              HI AVI !!!!!!

              thanks for reply , you are everywhere :) :)

              Yes my password start with special characters this is from our company password policy.
              OEL 6.1 YUM doesn't understood this type of password but this ok I change my password but this
              is not solved my problem.
              • 4. Re: OEL 6.1 YUM proxy problem
                __OUTSIDER___
                frits hoogland wrote:
                I agree with Avi: don't enable multiple channels which can contradict. Enable one channel.

                I also agree with Avi about the confusion: what do the '$' and '@' characters mean with 'xxx', or is '$@xxx' truly your password?

                The problem you see is not getting authenticated by the proxy, so yum is unable to retrieve the stuff it wants.

                In order to get the shell from stopping interpreting $ as a variable, simply use a single quote before and after the password.
                so:
                $ export http_password='$@xxx'
                No this will not help. Problem is not related to password I changed it and response is

                [root@rac1 ~]# yum update
                http://public-yum.oracle.com/repo/OracleLinux/OL6/1/base/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 407"
                Trying other mirror.
                Error: Cannot retrieve repository metadata (repomd.xml) for repository: ol6_u1_base. Please verify its path and try again
                [root@rac1 ~]#


                ./thanks
                • 5. Re: OEL 6.1 YUM proxy problem
                  __OUTSIDER___
                  P.S. This is OEL 6.1 problem, OEL5.7 works fine with same conf.
                  • 6. Re: OEL 6.1 YUM proxy problem
                    __OUTSIDER___
                    hey guys no ideas about YUM :(
                    • 7. Re: OEL 6.1 YUM proxy problem
                      Dude!
                      Is there some possible resemblance with this thread?

                      yumdownloader --source; failed to retrieve getPackageSource

                      Have you been upgrading any critical core system files or is this a plain vanilla installation?
                      • 8. Re: OEL 6.1 YUM proxy problem
                        Avi Miller-Oracle
                        __OUTSIDER___ wrote:
                        No this will not help. Problem is not related to password I changed it and response is
                        It might help, it's worth trying. Try this:
                        # export http_proxy='http://proxy.domain.com:3128'
                        # wget --proxy-user="xxx" --proxy-password="xxx" http://public-yum.oracle.com/repo/OracleLinux/OL6/1/base/x86_64/repodata/repomd.xml
                        If that works, it is a yum problem. If it doesn't work, it's a proxy problem.
                        • 9. Re: OEL 6.1 YUM proxy problem
                          __OUTSIDER___
                          Dude wrote:
                          Is there some possible resemblance with this thread?

                          yumdownloader --source; failed to retrieve getPackageSource

                          Have you been upgrading any critical core system files or is this a plain vanilla installation?
                          No unfortunately my problem not connected to this thread and I just want to run yum update command.
                          • 10. Re: OEL 6.1 YUM proxy problem
                            Dude!
                            Ok. Error 407 means: Proxy Authentication Required. The test as Avi outlines should show if the issue is the proxy or yum.

                            Depending on the content of your password you might have to put it in double quotes, e.g.
                            proxy_password="@$xxx"
                            • 11. Re: OEL 6.1 YUM proxy problem
                              __OUTSIDER___
                              Avi Miller wrote:
                              __OUTSIDER___ wrote:
                              No this will not help. Problem is not related to password I changed it and response is
                              It might help, it's worth trying. Try this:
                              # export http_proxy='http://proxy.domain.com:3128'
                              # wget --proxy-user="xxx" --proxy-password="xxx" http://public-yum.oracle.com/repo/OracleLinux/OL6/1/base/x86_64/repodata/repomd.xml
                              If that works, it is a yum problem. If it doesn't work, it's a proxy problem.
                              Yes it works , interesting that user and password parameters not working with double quotes only with single.
                              I also checked this with YUM but YUM is having problem with passwords that starting
                              with "@" symbol. I try to set
                              export http_proxy="http://username:\@$passwd@IP:PORT"

                              for ignoring "@" symbol but no sucess. With OEL5 this is not a problem. In /etc.yum.conf same username and same password.

                              Perhaps I should change my password :)

                              and last one thing in my home network I have OEL6.1 ( where fortunately with no proxy :) ) I try update linux with "yum update" command
                              and it returns that no packages to update , can you tell me why because there are new kernel avalable and I can download and install this new kernel with command "yum install kernel".
                              • 12. Re: OEL 6.1 YUM proxy problem
                                Avi Miller-Oracle
                                __OUTSIDER___ wrote:
                                Yes it works , interesting that user and password parameters not working with double quotes only with single.
                                Correct. Double-quotes (") get expanded on the $ symbol for variable replacement, while single quotes (') do not.
                                I also checked this with YUM but YUM is having problem with passwords that starting
                                with "@" symbol. I try to set
                                export http_proxy="http://username:\@$passwd@IP:PORT"
                                It's likely not the @ symbol that's the problem, but the $ symbol, which is a variable marker.
                                and last one thing in my home network I have OEL6.1 ( where fortunately with no proxy :) ) I try update linux with "yum update" command
                                and it returns that no packages to update , can you tell me why because there are new kernel avalable and I can download and install this new kernel with command "yum install kernel".
                                Try clearing the yum cache and running it again:

                                {code}# yum clean all
                                # yum update {code}
                                • 13. Re: OEL 6.1 YUM proxy problem
                                  __OUTSIDER___
                                  frits hoogland wrote:
                                  I agree with Avi: don't enable multiple channels which can contradict. Enable one channel.

                                  I also agree with Avi about the confusion: what do the '$' and '@' characters mean with 'xxx', or is '$@xxx' truly your password?

                                  The problem you see is not getting authenticated by the proxy, so yum is unable to retrieve the stuff it wants.

                                  In order to get the shell from stopping interpreting $ as a variable, simply use a single quote before and after the password.
                                  so:
                                  $ export http_password='$@xxx'
                                  Sorry :) you are right
                                  Yes problem with '$' and '@' characters but with single quote problem is still exist,
                                  I try to set

                                  export http_proxy='http://XXX:3128'
                                  export http_user='XX'
                                  export http_password='@$XXX'

                                  and


                                  [root@rac1 ~]# wget http://public-yum.oracle.com/repo/OracleLinux/OL6/1/base/x86_64/repodata/repomd.xml --2011-11-27 03:49:18-- http://public-yum.oracle.com/repo/OracleLinux/OL6/1/base/x86_64/repodata/repomd.xml
                                  Connecting to XXX:3128... connected.
                                  Proxy request sent, awaiting response... 407 Proxy Authentication Required
                                  2011-11-27 03:49:18 ERROR 407: Proxy Authentication Required.

                                  this is just wrong password.
                                  but I don't realize why this works with OEL5. Maybe you know ?


                                  thank you for reply
                                  • 14. Re: OEL 6.1 YUM proxy problem
                                    Avi Miller-Oracle
                                    __OUTSIDER___ wrote:
                                    export http_user='XX'
                                    export http_password='@$XXX'
                                    These don't work.
                                    [root@rac1 ~]# wget http://public-yum.oracle.com/repo/OracleLinux/OL6/1/base/x86_64/repodata/repomd.xml
                                    Try:
                                    # wget --proxy=user='username' --proxy-password='password' http://public-yum.oracle.com/repo/OracleLinux/OL6/1/base/x86_64/repodata/repomd.xml
                                    but I don't realize why this works with OEL5. Maybe you know ?
                                    Obviously something changed for yum between 5 and 6. You'll need to experiment with providing that password to yum to determine the working method. Or change your password.
                                    1 2 Previous Next