This discussion is archived
3 Replies Latest reply: Nov 28, 2011 8:56 AM by Steve_Clamage RSS

RPC Programming

902278 Newbie
Currently Being Moderated
I'm trying to run the ONC Netbula RPCGEN with the command "rpcgen file.xe the following error occurs:" cl.exe / C / EP / nologo - DRPC_XDR file.x - denied access. Preprocessing failed with an error. Please check environment settings. Try without CPP - Access Denied. "

Please help me, I've tried looking in books, thoroughly searched by google, I tried to contact the netbula by email (but do not respond). Anyway, I'm trying everything.

Thanks in advance
  • 1. Re: RPC Programming
    Steve_Clamage Pro
    Currently Being Moderated
    Your problem appears to have nothing to do with Studio C++, or with C++ programming in general, but with RPCGEN.

    At a guess, it appears that file "file.x" either does not exist, or has the wrong permissions, or a needed directory path has wrong permissions.

    For example, if file.x is supposed to be created by RPCGEN but the directory path where the file goes either is not accessible, or the final directory does not have write permission, creating that file would fail.

    If tracking down those various possibilities doesn't help, you should look for an RPCGEN forum.
  • 2. Re: RPC Programming
    902278 Newbie
    Currently Being Moderated
    not, "file.x" is an existing file, and and after the command "rpcgen file.x" multiple files should be generated.

    you know of any specific forum on rpcgen?
  • 3. Re: RPC Programming
    Steve_Clamage Pro
    Currently Being Moderated
    I asked my friend Google about "rcpgen forum" and he had quite a few suggestions.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points