4 Replies Latest reply: Jun 26, 2012 2:20 AM by ravibasa RSS

    EM 12c OVM Plugin - VM Creation

    884665
      We have EM 12c running with the OVM Plugin. We've been trying out the provisioning of VM's. One piece that doesn't seem to work, is providing a static IP address to the VM Guest. The VM Guest is created, but the network properties do not get changed, they take the properties of the guest that was cloned. I've tried this both with our own templates, as well as the templates from eDelivery which include the JEOS rpm's for the network changes.

      The EM logs actually tell us that it's going the change, see below:

      applyProductAndNetworkConfiguration: received application call for vm: 0004fb0000060000c641e3100a01edb2
      applyProductAndNetworkConfiguration: path null
      applyProductAndNetworkConfiguration: id null
      applying network properties for vm: 0004fb0000060000c641e3100a01edb2
      applying network property: com.oracle.ovab.network.eth0-netmask value: 255.255.255.128 for vm: 0004fb0000060000c641e3100a01edb2
      applying network property: com.oracle.ovab.network.default-gateway value: 142.174.170.1 for vm: 0004fb0000060000c641e3100a01edb2
      applying network property: com.oracle.ovab.network.eth0-ip_address value: 142.174.170.103 for vm: 0004fb0000060000c641e3100a01edb2
      applying network property: com.oracle.ovab.network.eth0-usedhcp value: false for vm: 0004fb0000060000c641e3100a01edb2
      applying network property: com.oracle.ovab.network.hostname value: btestem for vm: 0004fb0000060000c641e3100a01edb2
      applying network property: com.oracle.ovab.network.dns-servers value: 142.174.171.235 for vm: 0004fb0000060000c641e3100a01edb2
      calling network configure for vm: 0004fb0000060000c641e3100a01edb2
      successfully called network configure for vm: 0004fb0000060000c641e3100a01edb2
      waiting for network configure results for vm: 0004fb0000060000c641e3100a01edb2 for 5 minutes
      waiting for network configure results for vm: 0004fb0000060000c641e3100a01edb2 for 30 seconds
      Attempt 1 to retrieve identity information from VM
      waiting for network configure results for vm: 0004fb0000060000c641e3100a01edb2 for 30 seconds
      Attempt 2 to retrieve identity information from VM
      waiting for network configure results for vm: 0004fb0000060000c641e3100a01edb2 for 30 seconds
      Attempt 3 to retrieve identity information from VM
      waiting for network configure results for vm: 0004fb0000060000c641e3100a01edb2 for 30 seconds
      Attempt 4 to retrieve identity information from VM
      waiting for network configure results for vm: 0004fb0000060000c641e3100a01edb2 for 30 seconds
      Attempt 5 to retrieve identity information from VM
      waiting for network configure results for vm: 0004fb0000060000c641e3100a01edb2 for 30 seconds
      Attempt 6 to retrieve identity information from VM
      waiting for network configure results for vm: 0004fb0000060000c641e3100a01edb2 for 30 seconds
      Attempt 7 to retrieve identity information from VM
      waiting for network configure results for vm: 0004fb0000060000c641e3100a01edb2 for 30 seconds
      Attempt 8 to retrieve identity information from VM

      OVM Job Name: ApplyProductAndNetworkConfiguration_Btest_EM_2011-11-25_10-07-50-568
      OVM Job Status: Done
      OVM Job StartTime: 11/25/2011 10:07:50
      OVM Job EndTime: 11/25/2011 10:07:51
      OVM Job Details Log:


      There's no error. What is required to get this to actually work as documented/intented?

      I've also tried creating a network profile which is supposed to be used for automating IP information for VM's.....but that doesn't work either.

      Any ideas?