1 Reply Latest reply on Dec 22, 2011 3:27 PM by Mike Gerdts-Oracle

    Solaris Branded Zones, Unable to reboot/Halt

      Hi People,

      Hoping someone can help. Im running Solaris 10 on a Sun Workstation Ultra 45. I have two disks. One disk has the default install of solaris 10 all updated to the latest patches.The second disk is mounted as /zones and holds each of the zones on ZFS. I have then downloaded and installed successfully Solaris 8 and Solaris 9 and Solaris 10 zones. So I have 3 zones.

      The problem I am facing is I can boot up all 3 zones fine and they work great, however when I halt or reboot either Solaris 8 or solaris 9, they never come back up. I try and zlogin to them and telnet and ssh and they are totally unresponsive and quite literally dont boot. I have tried to pkill -9 -z zonename ; umount /zonesfilesystem; zpool clear and even rebooted the Global zone. Still will not come up. The only way they will boot after being shutdown is if i shutdown the global zones and turn the server off and back on.

      Solaris 10 Zone boots up and down fine with no isses. I have tried this on both UFS and ZFS thinking it might be a file lock issue. Still unable to reboot or halt a zone and bring it back up.

      Any help please :)

      Thanks in advance.