2 Replies Latest reply: Nov 30, 2011 3:00 PM by user12181130 RSS

    11.1.2.1 HyS9RaFrameworkAgent service is not starting

    user12181130
      I am on system EPM 11.1.2.1
      My HyS9RaFrameworkAgent service starts and is shutdown automatically.

      The message displayed on the agent.log is
      [2011-11-29T10:50:12.588-05:00] [EPMAGENT] [INCIDENT_ERROR] [] [oracle.EPMAGENT.com.oracle.cmc.Agent] [tid: 10] [ecid: 0000JFk1ENADOdw5GFL6if1EpFwo000000,0] ### CURRENT RUNTIME NAME: 6776@W8NYHY04D ###
      [2011-11-29T10:50:12.713-05:00] [EPMAGENT] [INCIDENT_ERROR] [] [oracle.EPMAGENT.com.oracle.cmc.Agent] [tid: 10] [ecid: 0000JFk1ENADOdw5GFL6if1EpFwo000000,0] starting agent process ...
      [2011-11-29T10:50:12.713-05:00] [EPMAGENT] [INCIDENT_ERROR] [] [oracle.EPMAGENT.com.oracle.cmc.Agent] [tid: 10] [ecid: 0000JFk1ENADOdw5GFL6if1EpFwo000000,0] creating instance of HITRegistryUtil ...
      [2011-11-29T10:50:20.073-05:00] [EPMAGENT] [ERROR] [] [oracle.EPMAGENT.com.oracle.cmc.Agent] [tid: 10] [ecid: 0000JFk1ENADOdw5GFL6if1EpFwo000000,0] [[
      java.lang.NullPointerException
      at com.oracle.cmc.registry.HITRegistryUtil.getAgentByLocalHost(HITRegistryUtil.java:1076)
      at com.oracle.cmc.Agent.loadRegistryUtil(Agent.java:321)
      at com.oracle.cmc.Agent.initialize(Agent.java:287)
      at com.oracle.cmc.Agent.start(Agent.java:151)
      at com.oracle.cmc.Agent.main(Agent.java:936)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.brio.one.common.utils.Loader.run(Unknown Source)
      at com.brio.one.common.utils.Loader.main(Unknown Source)

      I verified my database connection and it is working fine.
      Did anyone encountered this issue before? I would appreciate any comments.