13 Replies Latest reply on Dec 6, 2011 10:49 AM by 880312

    Hyperion 11.1.2.1 problems after database failure with native admin user

    Pedro Soares
      Hello,

      After a hardware failure on the database server I needed to reconfigure all the Hyperion 11.1.2.1 suite with some old backups. It seems the the native user admin isn't being recongnized. Any idea on how to solve it or repair the installation?

      After I reconfigured all products I'm having the following messages:

      Workspace
      After inserting username and password:

      Error: The startup document specified does not exist in the repository. Select a new startup document on the General preferences tab.

      Warning: You must supply a valid User Name and Password to log onto the system.
      URI: http://<server>:19000/raframework/browse/dyn

      Code: -3

      Description: An error occurred processing the result from the server.

      Then a blank blue background appears.

      Shared Services

      Error: Loading the module 'cas.containers.tadpole' failed.

      Warning: A 'Not Found' error occurred communicating with the server.

      URI: http://<server>:19000/interop/modules/com/hyperion/hub/cas/web/containers/tadpole/adf.jsp

      Status: 404 - Not Found

      Content: text/html; charset=UTF-8
      <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Draft//EN">
      <HTML>
      <HEAD>
      <TITLE>Error 404--Not Found</TITLE>
      <META NAME="GENERATOR" CONTENT="WebLogic Server">
      </HEAD>
      <BODY bgcolor="white">
      <FONT FACE=Helvetica><BR CLEAR=all>
      <TABLE border=0 cellspacing=5><TR><TD><BR CLEAR=all>
      <FONT FACE="Helvetica" COLOR="black" SIZE="3"><H2>Error 404--Not Found</H2>
      </FONT></TD></TR>
      </TABLE>
      <TABLE border=0 width=100% cellpadding=10><TR><TD VALIGN=top WIDTH=100% BGCOLOR=white><FONT FACE="Courier New"><FONT FACE="Helvetica" SIZE="3"><H3>From RFC 2068 <i>Hypertext Transfer Protocol -- HTTP/1.1</i>:</H3>
      </FONT><FONT FACE="Helvetica" SIZE="3"><H4>10.4.5 404 Not Found</H4>
      </FONT><P><FONT FACE="Courier New">The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.</p><p>If the server does not wish to make this information available to the client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address.</FONT></P>
      </FONT></TD></TR>
      </TABLE>

      </BODY>
      </HTML>

      Then Loading icon stays on screen forever.

      Planning

      After inserting username and password. The error icon appears and I checked logs:

      sys-out:
      [HspCSS:HspCSS] Exception
      [HspCSS:HspCSS] CSSTokenNotAvailableException
      sys-err
      java.lang.NullPointerException
           at com.hyperion.css.sync.impl.CSSMigrationAPIImpl.<init>(CSSMigrationAPIImpl.java:149)
           at com.hyperion.css.facade.impl.CSSAPIImpl.getMigrationAPI(CSSAPIImpl.java:292)
           at com.hyperion.css.facade.CSSAPIFacade.getMigrationAPI(CSSAPIFacade.java:413)
           at com.hyperion.planning.security.HspIdentityMigrator.<init>(Unknown Source)
           at com.hyperion.planning.security.HspCSS.<init>(Unknown Source)
           at com.hyperion.planning.HspJSHomeImpl.createSecurityAPI(Unknown Source)
           at com.hyperion.planning.HspJSHomeImpl.getSecurityAPI(Unknown Source)
           at jsp_servlet.__logon._jspService(__logon.java:1637)
           at weblogic.servlet.jsp.JspBase.service(JspBase.java:34)
           at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:227)
           at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:125)
           at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:300)
           at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:26)
           at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
           at HspValidationFilter.doFilter(Unknown Source)
           at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
           at oracle.security.jps.ee.http.JpsAbsFilter$1.run(JpsAbsFilter.java:111)
           at oracle.security.jps.util.JpsSubject.doAsPrivileged(JpsSubject.java:313)
           at oracle.security.jps.ee.util.JpsPlatformUtil.runJaasMode(JpsPlatformUtil.java:413)
           at oracle.security.jps.ee.http.JpsAbsFilter.runJaasMode(JpsAbsFilter.java:94)
           at oracle.security.jps.ee.http.JpsAbsFilter.doFilter(JpsAbsFilter.java:161)
           at oracle.security.jps.ee.http.JpsFilter.doFilter(JpsFilter.java:71)
           at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
           at oracle.dms.servlet.DMSServletFilter.doFilter(DMSServletFilter.java:136)
           at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
           at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.wrapRun(WebAppServletContext.java:3715)
           at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3681)
           at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
           at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)
           at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2277)
           at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2183)
           at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1454)
           at weblogic.work.ExecuteThread.execute(ExecuteThread.java:207)
           at weblogic.work.ExecuteThread.run(ExecuteThread.java:176)



      Foundation Services log

      <2/Dez/2011 18H39m GMT> <Notice> <WebLogicServer> <BEA-000358> <Started WebLogic Independent Managed Server "FoundationServices0" for domain "EPMSystem" running in Production Mode>
      <2/Dez/2011 18H39m GMT> <Warning> <JMX> <BEA-149510> <Unable to establish JMX Connectivity with the Adminstration Server AdminServer at <JMXServiceURL:null>.>
      <2/Dez/2011 18H39m GMT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to RUNNING>
      <2/Dez/2011 18H39m GMT> <Notice> <WebLogicServer> <BEA-000360> <Server started in RUNNING mode>
      <2/Dez/2011 18H56m GMT> <Error> <HTTP> <BEA-101017> <[ServletContext@11878369[app:SHAREDSERVICES module:interop path:/interop spec-version:2.5 version:11.1.2.0]] Root cause of ServletException.
      EPMCSS-00668: Failed to get user with identity native://DN=cn=911,ou=People,dc=css,dc=hyperion,dc=com?USER. User not available in configured user directories. Verify user details and user directory configuration.
           at com.hyperion.css.facade.impl.CSSAPIImpl.getUserByIdentity(CSSAPIImpl.java:744)
           at com.hyperion.css.facade.impl.CSSAPIImpl.getUserByIdentity(CSSAPIImpl.java:1002)
           at com.hyperion.css.facade.CSSAPIFacade.getUserByIdentity(CSSAPIFacade.java:500)
           at jsp_servlet._modules._com._hyperion._hub._cas._web._containers._tadpole.__adf._jspService(__adf.java:587)
           at weblogic.servlet.jsp.JspBase.service(JspBase.java:35)
           Truncated. see log file for complete stacktrace
        • 1. Re: Hyperion 11.1.2.1 problems after database failure with native admin user
          JohnGoodwin
          Sounds like when foundation is starting up it is checking the CSS_USERS table and the admin account does not exist, has the foundation database definitely been restored correctly.

          Cheers

          John
          http://john-goodwin.blogspot.com/
          • 2. Re: Hyperion 11.1.2.1 problems after database failure with native admin user
            Pedro Soares
            I can't be sure, but the admin account is in the CSS_USERS table, that I checked.
            • 3. Re: Hyperion 11.1.2.1 problems after database failure with native admin user
              Pedro Soares
              John the best option here will be trying to use an old functional database of the Foundation Services, correct?

              I will have some users / groups in Planning and Essbase security that weren't present in this foundation database version. Will it complain? :)
              • 4. Re: Hyperion 11.1.2.1 problems after database failure with native admin user
                JohnGoodwin
                I think you need to worry about essbase/planning after foundation.
                From the logs the foundation web app is not starting up, if you manage to restore and get the foundation up and running then you can move on to the rest of the products.

                Cheers

                John
                http://john-goodwin.blogspot.com/
                • 5. Re: Hyperion 11.1.2.1 problems after database failure with native admin user
                  Pedro Soares
                  Thank you I will see what happens. I was searching the net about this problem and found a blog where some utilities are mentioned. Is there any way this utilities can update the Shared Services database so the admin user is recognized again?

                  •CSSExport.bat
                  •CSSImport.bat
                  •CSSValidate.bat

                  I don't find them in my Hyperion directory.

                  Thank you
                  • 6. Re: Hyperion 11.1.2.1 problems after database failure with native admin user
                    JohnGoodwin
                    Those are utilities for versions prior to 11.1.2.x
                    You won't be able to use any utilities without the admin account and foundation working first.

                    Cheers

                    John
                    http://john-goodwin.blogspot.com/
                    • 7. Re: Hyperion 11.1.2.1 problems after database failure with native admin user
                      Pedro Soares
                      I see, I will try to use the old database backup I have. How can I change the reconfigure the Shared Services database connection? The option is disabled on EPM Configuration Tool. Thank you
                      • 8. Re: Hyperion 11.1.2.1 problems after database failure with native admin user
                        JohnGoodwin
                        It would be easier if you just restore to the same database then you won't have to mess around with the configurator.

                        Cheers

                        John
                        http://john-goodwin.blogspot.com/
                        • 9. Re: Hyperion 11.1.2.1 problems after database failure with native admin user
                          880312
                          Yes the problem is that the server changed names and the DNS isn't the same either :\
                          • 10. Re: Hyperion 11.1.2.1 problems after database failure with native admin user
                            Pedro Soares
                            After using the last backup I managed to start all services with no errors.

                            When I log into Workspace, the browser freezes and there is no error in logs.

                            I tried to log in Planning directly and a error occurs. The error is related to an old EAS database, but there I don't know how to change it. What is the best way to clear the registry? I was thinking in installing all products again and then try to reuse the database from Planning, since I can import Business Rules, Sequences and Variables from XML files into the EAS database.

                            Am I missing something that can go wrong? Thank you
                            • 11. Re: Hyperion 11.1.2.1 problems after database failure with native admin user
                              JohnGoodwin
                              Is EAS starting up without any errors, have you tried reconfiguring EAS first, if that fails then you can always start reconfiguring again, you shouldn't need to install again.

                              Cheers

                              John
                              http://john-goodwin.blogspot.com/
                              • 12. Re: Hyperion 11.1.2.1 problems after database failure with native admin user
                                Pedro Soares
                                Yes , EAS services is starting without errors. The problem is that there are 2 EAS datasources in Registry with different hosts. One has the new host and the other one has the old host, and it seems that Planning is trying to connect with the old connection to get business rules on forms instead of the new connection.

                                What I would like to try is to clean up the registry but I'm not sure if that's possible.

                                Thank you
                                • 13. Re: Hyperion 11.1.2.1 problems after database failure with native admin user
                                  880312
                                  Some more updates:

                                  1 - I can now login into Shared Services which is good :)
                                  2 - Login directly into Planning gives me a SQL connect error: Unable to create JDBC connection. java.sql.SQLNonTransientConnectionException: [FMWGEN][SQLServer JDBC Driver]Error establishing socket to host and port: s3tp10-1a05:50948. Reason: Connection refused: connect
                                  Can not get JDBC connection.

                                  This connection is the old EAS database connection I had. Planning is not trying to use the new connection I set up when reconfiguring EAS Product trough EPM System Configuration. It's being hard to find this connection with the epmsys_registry tool. I can't find it's name or id. Any ideas on how to change this?

                                  3 - I can't login into Workspace. The browser turns unresponsive. There are no errors showing in Foundation Services log, so I thought the problem could be write to the RAFramework logs, which show the following. Is there any problem in recreating this database again? I didn't made any work on it I think, because I didn't create any reports. What does it save besides that? Workspace infrastructure like favorites and user preferences?

                                  <6/Dez/2011 10H20m GMT> <Notice> <Diagnostics> <BEA-320068> <Watch 'StuckThread' with severity 'Notice' on server 'RaFramework0' has triggered at 6/Dez/2011 10H20m GMT. Notification details:
                                  WatchRuleType: Log
                                  WatchRule: (SEVERITY = 'Error') AND ((MSGID = 'WL-000337') OR (MSGID = 'BEA-000337'))
                                  WatchData: DATE = 6/Dez/2011 10H20m GMT SERVER = RaFramework0 MESSAGE = [STUCK] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)' has been busy for "623" seconds working on the request "weblogic.servlet.internal.ServletRequestImpl@e9603d[
                                  POST /raframework/browse/dyn HTTP/1.1
                                  Accept: */*
                                  Accept-Language: pt
                                  Referer: http://s3tp10-1a33.bcpcorp.dev:19000/workspace/index.jsp
                                  Content-Type: application/x-www-form-urlencoded;charset=UTF-8
                                  ora_epm_ctg: bgBVUu%252B5%252FmqkJEC%252BBawJYCx1R7ocYq5u6kD3qJRWJpSrK7Cl1Nuktz2EOD63yfLq
                                  Accept-Encoding: gzip, deflate
                                  User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727)
                                  Content-Length: 525
                                  Cache-Control: no-cache
                                  Cookie: ORA_EPMWS_AccessibilityMode=false; ORA_EPMWS_ThemeSelection=BpmTadpole; ORA_EPMWS_User=admin
                                  Connection: Keep-Alive
                                  Proxy-Client-IP: fe80::847:ca04:592f:1f19
                                  X-Forwarded-For: fe80::847:ca04:592f:1f19
                                  X-WebLogic-KeepAliveSecs: 30
                                  X-WebLogic-Force-JVMID: unset

                                  ]", which is more than the configured time (StuckThreadMaxTime) of "600" seconds. Stack trace:
                                  Thread-229 "[STUCK] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)'" <alive, suspended, waiting, priority=1, DAEMON> {
                                  -- Waiting for notification on: com.iona.corba.giop.GIOPInStream@1395780[fat lock]
                                  java.lang.Object.wait(Object.java:???)
                                  com.iona.common.time.UTCTimedWait.do_wait(Unknown Source)
                                  com.iona.common.time.UTCTimedWait.wait(Unknown Source)
                                  com.iona.common.time.UTCTimedWait.wait(Unknown Source)
                                  com.iona.corba.giop.GIOPInStream.read_header(Unknown Source)
                                  com.iona.corba.giop.GIOPClientStreamRequestInterceptorImpl.stream_invoke(Unknown Source)
                                  com.iona.corba.art.binding.IORProxy.invoke(Unknown Source)
                                  org.omg.CORBA.portable.ObjectImpl._invoke(ObjectImpl.java:457)
                                  com.brio.one.services.publisher.idl._IPortalBrowserStub.getCategory(Unknown Source)
                                  com.brio.one.services.publisher.proxy.PortalBrowserProxy.getCategory(Unknown Source)
                                  com.brio.one.web.util.services.ServiceCache.getFolder(Unknown Source)
                                  com.brio.one.web.util.services.SubjectPropertyUtil.getSubjectDefaultFolder(Unknown Source)
                                  com.brio.one.web.datasource.UserPrefsBean.initDefaultFolder(Unknown Source)
                                  com.brio.one.web.datasource.UserPrefsBean.<init>(Unknown Source)
                                  com.brio.one.web.datasource.AppPrefsBean.<init>(Unknown Source)
                                  com.sqribe.WS.BaseSessionInfo.addConnection(Unknown Source)
                                  com.brio.one.web.browser.servlet.BrowserSessionInfo.addConnection(Unknown Source)
                                  com.sqribe.WS.BrowserProxy.addConnection(Unknown Source)
                                  com.sqribe.WS.WebSQRIBE.addConnection(Unknown Source)
                                  com.sqribe.WS.WebSQRIBE.loginToRepository(Unknown Source)
                                  com.sqribe.WS.WebSQRIBE.newUser(Unknown Source)
                                  com.sqribe.WS.WebSQRIBE.run(Unknown Source)
                                  com.sqribe.WS.WSBaseServlet.executeRequest(Unknown Source)
                                  com.sqribe.WS.WSBaseServlet.service(Unknown Source)
                                  javax.servlet.http.HttpServlet.service(HttpServlet.java:815)
                                  weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:224)
                                  weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:108)
                                  weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:206)
                                  weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:26)
                                  weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:55)
                                  com.hyperion.bpm.LocalizationServletFilter.doFilter(LocalizationServletFilter.java:67)
                                  weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:55)
                                  com.hyperion.i18n.filter.Utf8Filter.doFilter(Unknown Source)
                                  weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:55)
                                  com.brio.one.web.URLSecurityFilter.doFilter(Unknown Source)
                                  weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:55)
                                  oracle.security.jps.ee.http.JpsAbsFilter$1.run(JpsAbsFilter.java:111)
                                  oracle.security.jps.util.JpsSubject.doAsPrivileged(JpsSubject.java:299)
                                  oracle.security.jps.ee.util.JpsPlatformUtil.runJaasMode(JpsPlatformUtil.java:405)
                                  oracle.security.jps.ee.http.JpsAbsFilter.runJaasMode(JpsAbsFilter.java:94)
                                  oracle.security.jps.ee.http.JpsAbsFilter.doFilter(JpsAbsFilter.java:98)
                                  oracle.security.jps.ee.http.JpsFilter.doFilter(JpsFilter.java:70)
                                  weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:55)
                                  oracle.dms.servlet.DMSServletFilter.doFilter(DMSServletFilter.java:86)
                                  weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:55)
                                  weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.wrapRun(WebAppServletContext.java:3687)
                                  weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3681)
                                  weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:308)
                                  weblogic.security.service.SecurityManager.runAs(SecurityManager.java:116)
                                  weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2213)
                                  weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2135)
                                  weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1420)
                                  weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
                                  weblogic.work.ExecuteThread.run(ExecuteThread.java:168)
                                  }

                                  SUBSYSTEM = WebLogicServer USERID = <WLS Kernel> SEVERITY = Error THREAD = [ACTIVE] ExecuteThread: '9' for queue: 'weblogic.kernel.Default (self-tuning)' MSGID = BEA-000337 MACHINE = S3TP10-1A33 TXID = CONTEXTID = TIMESTAMP = 1323166810365
                                  WatchAlarmType: AutomaticReset
                                  WatchAlarmResetPeriod: 600000
                                  >
                                  <6/Dez/2011 10H20m GMT> <Alert> <Diagnostics> <BEA-320016> <Creating diagnostic image in e:\hyperion\user_projects\domains\epmsystem\servers\raframework0\adr\diag\ofm\epmsystem\raframework0\incident\incdir_23 with a lockout minute period of 1.>
                                  <6/Dez/2011 10H20m GMT> <Warning> <JMX> <BEA-149515> <An error was encountered getting the attribute AdminServerListenPort on the MBean com.bea:Name=RaFramework0,Type=ServerRuntime during a call to getAttributes>
                                  <6/Dez/2011 10H20m GMT> <Warning> <JMX> <BEA-149515> <An error was encountered getting the attribute AdminServerHost on the MBean com.bea:Name=RaFramework0,Type=ServerRuntime during a call to getAttributes>
                                  <6/Dez/2011 10H20m GMT> <Error> <Diagnostics> <BEA-320127> <An error occurred while generating Image Source configuration as part of the diagnostic image zip file:
                                  weblogic.diagnostics.image.ImageSourceCreationException: java.lang.NullPointerException
                                       at weblogic.management.provider.internal.ConfigImageSource.createDiagnosticImage(ConfigImageSource.java:105)
                                       at weblogic.diagnostics.image.ImageSourceWork.run(ImageSourceWork.java:111)
                                       at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:528)
                                       at weblogic.work.ExecuteThread.execute(ExecuteThread.java:207)
                                       at weblogic.work.ExecuteThread.run(ExecuteThread.java:176)
                                  Caused By: java.lang.NullPointerException
                                       at weblogic.management.provider.internal.EditAccessImpl.getEditor(EditAccessImpl.java:597)
                                       at weblogic.management.provider.internal.ConfigImageSource.writeEditLockState(ConfigImageSource.java:296)
                                       at weblogic.management.provider.internal.ConfigImageSource.createDiagnosticImage(ConfigImageSource.java:88)
                                       at weblogic.diagnostics.image.ImageSourceWork.run(ImageSourceWork.java:111)
                                       at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:528)
                                       Truncated. see log file for complete stacktrace
                                  >
                                  <6/Dez/2011 10H21m GMT> <Error> <WebLogicServer> <BEA-000337> <[STUCK] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)' has been busy for "683" seconds working on the request "weblogic.servlet.internal.ServletRequestImpl@e9603d[
                                  POST /raframework/browse/dyn HTTP/1.1
                                  Accept: */*
                                  Accept-Language: pt
                                  Referer: http://s3tp10-1a33.bcpcorp.dev:19000/workspace/index.jsp
                                  Content-Type: application/x-www-form-urlencoded;charset=UTF-8
                                  ora_epm_ctg: bgBVUu%252B5%252FmqkJEC%252BBawJYCx1R7ocYq5u6kD3qJRWJpSrK7Cl1Nuktz2EOD63yfLq
                                  Accept-Encoding: gzip, deflate
                                  User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727)
                                  Content-Length: 525
                                  Cache-Control: no-cache
                                  Cookie: ORA_EPMWS_AccessibilityMode=false; ORA_EPMWS_ThemeSelection=BpmTadpole; ORA_EPMWS_User=admin
                                  Connection: Keep-Alive
                                  Proxy-Client-IP: fe80::847:ca04:592f:1f19
                                  X-Forwarded-For: fe80::847:ca04:592f:1f19
                                  X-WebLogic-KeepAliveSecs: 30
                                  X-WebLogic-Force-JVMID: unset

                                  ]", which is more than the configured time (StuckThreadMaxTime) of "600" seconds. Stack trace:
                                  Thread-229 "[STUCK] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)'" <alive, suspended, waiting, priority=1, DAEMON> {
                                  -- Waiting for notification on: com.iona.corba.giop.GIOPInStream@1395780[fat lock]
                                  java.lang.Object.wait(Object.java:???)
                                  com.iona.common.time.UTCTimedWait.do_wait(Unknown Source)
                                  com.iona.common.time.UTCTimedWait.wait(Unknown Source)
                                  com.iona.common.time.UTCTimedWait.wait(Unknown Source)
                                  com.iona.corba.giop.GIOPInStream.read_header(Unknown Source)
                                  com.iona.corba.giop.GIOPClientStreamRequestInterceptorImpl.stream_invoke(Unknown Source)
                                  com.iona.corba.art.binding.IORProxy.invoke(Unknown Source)
                                  org.omg.CORBA.portable.ObjectImpl._invoke(ObjectImpl.java:457)
                                  com.brio.one.services.publisher.idl._IPortalBrowserStub.getCategory(Unknown Source)
                                  com.brio.one.services.publisher.proxy.PortalBrowserProxy.getCategory(Unknown Source)
                                  com.brio.one.web.util.services.ServiceCache.getFolder(Unknown Source)
                                  com.brio.one.web.util.services.SubjectPropertyUtil.getSubjectDefaultFolder(Unknown Source)
                                  com.brio.one.web.datasource.UserPrefsBean.initDefaultFolder(Unknown Source)
                                  com.brio.one.web.datasource.UserPrefsBean.<init>(Unknown Source)
                                  com.brio.one.web.datasource.AppPrefsBean.<init>(Unknown Source)
                                  com.sqribe.WS.BaseSessionInfo.addConnection(Unknown Source)
                                  com.brio.one.web.browser.servlet.BrowserSessionInfo.addConnection(Unknown Source)
                                  com.sqribe.WS.BrowserProxy.addConnection(Unknown Source)
                                  com.sqribe.WS.WebSQRIBE.addConnection(Unknown Source)
                                  com.sqribe.WS.WebSQRIBE.loginToRepository(Unknown Source)
                                  com.sqribe.WS.WebSQRIBE.newUser(Unknown Source)
                                  com.sqribe.WS.WebSQRIBE.run(Unknown Source)
                                  com.sqribe.WS.WSBaseServlet.executeRequest(Unknown Source)
                                  com.sqribe.WS.WSBaseServlet.service(Unknown Source)
                                  javax.servlet.http.HttpServlet.service(HttpServlet.java:815)
                                  weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:224)
                                  weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:108)
                                  weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:206)
                                  weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:26)
                                  weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:55)
                                  com.hyperion.bpm.LocalizationServletFilter.doFilter(LocalizationServletFilter.java:67)
                                  weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:55)
                                  com.hyperion.i18n.filter.Utf8Filter.doFilter(Unknown Source)
                                  weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:55)
                                  com.brio.one.web.URLSecurityFilter.doFilter(Unknown Source)
                                  weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:55)
                                  oracle.security.jps.ee.http.JpsAbsFilter$1.run(JpsAbsFilter.java:111)
                                  oracle.security.jps.util.JpsSubject.doAsPrivileged(JpsSubject.java:299)
                                  oracle.security.jps.ee.util.JpsPlatformUtil.runJaasMode(JpsPlatformUtil.java:405)
                                  oracle.security.jps.ee.http.JpsAbsFilter.runJaasMode(JpsAbsFilter.java:94)
                                  oracle.security.jps.ee.http.JpsAbsFilter.doFilter(JpsAbsFilter.java:98)
                                  oracle.security.jps.ee.http.JpsFilter.doFilter(JpsFilter.java:70)
                                  weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:55)
                                  oracle.dms.servlet.DMSServletFilter.doFilter(DMSServletFilter.java:86)
                                  weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:55)
                                  weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.wrapRun(WebAppServletContext.java:3687)
                                  weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3681)
                                  weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:308)
                                  weblogic.security.service.SecurityManager.runAs(SecurityManager.java:116)
                                  weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2213)
                                  weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2135)
                                  weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1420)
                                  weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
                                  weblogic.work.ExecuteThread.run(ExecuteThread.java:168)
                                  }

                                  >