3 Replies Latest reply on Aug 27, 2012 2:57 PM by marcpaquin

    IBM JDKs and Application Express Listener

    Colm Divilly-Oracle
      have been seeing reports of people having trouble running the Listener on IBM JDKs (typically on AIX, but I believe the problem will occur on any IBM JDK). The problems seem centered on failures to parse the web.xml or apex-config.xml files. I may have a possible workaround so would appreciate if those encountering problems would try this, and report if the fix works.

      There are various incompatibilities between the Oracle XML libraries which are required to enable us to support the XMLType database type and the standard XML libraries which ship with JDKs/JREs. In 1.1 we have implemented a workaround to address this issue on Sun/Oracle JDKs, but unfortunately because IBM JDKs have different XML libraries to Sun/Oracle JDKs the workaround does not work on IBM JDKs.

      The possible (without access to AIX/IBM environments I cannot verify this myself) workaround to this problem is to modify the Oracle XML library jar redistributed with the Listener. Please follow the steps below.

      <li>Remove any temporary or exploded war folders your application server may have created for a previous apex.war deployment</li>
      <li>Undeploy apex.war if it is already deployed</li>

      <li>Locate the original folder where you unzipped the Listener installation. Let's call this ${al.home}</li>
      <li>Unzip ${al.home}/apex.war to a temporary folder </li>
      <li> Locate the file named WEB-INF/lib/xmlparserv2-11.2.0.jar in the above temporary folder </li>
      <li> In this file you will notice a folder named META-INF/services. Remove this folder and its contents </li>
      <li> Rezip the contents of the temporary folder into a new apex.war </li>
      <li> Deploy the modified apex.war</li>

      For those on *ix platforms the following shell commands should perform the above steps
      cd ${al.home}
      mkdir tmp-al
      cd tmp-al
      unzip ../apex.war
      cd WEB-INF/lib
      mkdir tmp-xml
      cd tmp-xml
      unzip ../xmlparserv2-11.2.0.jar
      rm -rf META-INF/services/
      rm ../xmlparserv2-11.2.0.jar
      zip -r ../xmlparserv2-11.2.0.jar .
      cd ../../..
      rm -rf WEB-INF/lib/tmp-xml/
      rm ../apex.war
      zip -r ../apex.war .
      cd ..
      rm -rf tmp-al/
      where ${al.home} is the folder where you Application Express Listener installation is located

      I'd appreciate if those experiencing the above problems would try this workaround and report back on if it alleviates the problem.

      Colm Divilly
        • 1. Re: IBM JDKs and Application Express Listener

          Fantastic !
          Thanks for the fix, it works great on Aix 6.1 Java 6
          java version "1.6.0"
          Java(TM) SE Runtime Environment (build pap6460sr9fp1-20110208_03(SR9 FP1))
          IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 AIX ppc64-64 jvmap6460sr9-20110203_74623 (JIT enabled, AOT enabled)
          J9VM - 20110203_074623
          JIT - r9_20101028_17488ifx3
          GC - 20101027_AA)
          JCL - 20110203_01

          Previously I was getting success messages from my standalone deployment , however when i tried to launch the listenerConfigure dialogue all i got was an hour glass then a failure to load the page
          Now I see these messages at the end of my deploy, and the Apex Listener Administation page launches as it should
          Using config file: /opt/oracle/v11.2.0/Apex4.1/apex_listener/temp_standalone/apex-config.xml
          APEX Listener version :
          APEX Listener server info: Grizzly/1.9.18-o
          Dec 21, 2011 9:43:32 AM com.sun.grizzly.Controller logVersion
          INFO: Starting Grizzly Framework 1.9.18-o - Wed Dec 21 09:43:32 EST 2011
          INFO: Please complete configuration at: http://localhost:8080/apex/listenerConfigure

          Thanks a lot for your Help


          • 2. Re: IBM JDKs and Application Express Listener
            Hello Colin,

            Your workaround also worked for me. It was a great help, THANKS

            With regards,

            • 3. Re: IBM JDKs and Application Express Listener

              Workaround is working for me ...*Great!!!!*

              Thank you so much for your help
              AIX Server IBM Power 595 OS 6.1
              Application Express
              java version "1.6.0"
              Java(TM) SE Runtime Environment (build pap6460sr9fp2-20110627_03(SR9 FP2))
              IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 AIX ppc64-64 jvmap6460sr9-20110624_85526 (JIT enabled, AOT enabled)
              J9VM - 20110624_085526
              JIT - r9_20101028_17488ifx17
              GC - 20101027_AA)
              JCL - 20110530_01