3 Replies Latest reply: Jul 12, 2012 2:50 PM by Catch 22 RSS

    Disable PackageKit Update Applet

    NikosTUC
      Dear all,

      I have installed the latest version of oracle linux. The server is accessed by hundrends of students that do their lab exercises. However, I have a problem with the PackageKit Update Applet. Although I can go the System->Preferences->StartUp applications and disable it for my account, I do not know how to do it for all my users. The problem is that the Authentication dialog asking for the root password to update is continuously popping up while the user is logged in with the gnome environment. Is there a way to disable this feature for all accounts or to work around this issue?

      Thank you,
      Nikos
        • 1. Re: Disable PackageKit Update Applet
          Catch 22
          Please provide more info what about what Linux distribution and version you have installed.
          • 2. Re: Disable PackageKit Update Applet
            NikosTUC
            Hi,

            It is an oracle linux server release 6.1 with kernel 2.6.32-100.34.1.el6uek.x86_64 and GNOME version 2.28.2.

            Thank you,
            Nikos
            • 3. Re: Disable PackageKit Update Applet
              Catch 22
              Apparently PackageKit itself is a system activated daemon called packagekitd, which is managed by gpk-update-icon.

              I seems you can disable it globally by setting System|Preferences|Software Updates to "never".

              Another approach, which I have not tried though, might be following:

              Disable the PackageKit update applet, using the Startup Applications.
              This will create a file named "gpk-update-icon.desktop" containing "X-GNOME-Autostart-enabled=false".
              Copy your "~/.config/autostart/gpk-update-icon.desktop" to the home directory of other users.

              Or as a very last resort, to remove PackageKit from the system: sudo yum remove PackageKit.

              Edited by: Dude on Dec 9, 2011 9:22 AM

              Edited by: Dude on Jul 12, 2012 12:46 PM

              Setting System|Preferences|Software only affects the current user logged in and does not disable auto-update system-wide. More info at: How to disable yum auto-update in OL6