This discussion is archived
0 Replies Latest reply: Dec 24, 2011 2:37 PM by SAMJO078 RSS

Doing Login to WebCenter Spaces after Fresh Install Hangs [ID 976907.1]

SAMJO078 Newbie
Currently Being Moderated
hi
i have an issue with webcenter spaces ,i searched oracle documentation and found a description and a solution but it is still not working .

i have oracle webcenter 11.1.1.5 ,installed on oracle Linux Enterprise 5.5 ,installation is made with 3 physical nodes joined to one domain as described on oracle documentation (ID

the solution is described on document [ID 976907.1]

----------------------------------------------------
Applies to:
Oracle WebCenter - Version: 11.1.1.1.0 to 11.1.1.5.0 - Release: 11g to 11g
Information in this document applies to any platform.

Symptoms

On : WebCenter Spaces.

When attempting to login to WebCenter Spaces, the login hangs.

The WebCenter Spaces diagnostic log (WLS_Spaces_diagnostic.log) shows the following error at the time of login:


[2009-12-07T10:59:04.645-08:00] [WLS_Spaces] [ERROR] [] [oracle.webcenter.webcenterapp.internal.view.webapp] [tid: [ACTIVE].ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: weblogic] [ecid: 0000ILeW_Ss2bMK5qVh8iY1B7KwH00000F,0] [APP: webcenter] [[
oracle.adf.share.security.ADFSecurityRuntimeException: The URL typed by current user is not accessible, so redirecting to the unAuthorized page
at oracle.webcenter.webcenterapp.internal.view.security.WCAuthorizationHandler.handleAuthorizationFailure
(WCAuthorizationHandler.java:62)


STEPS

The issue can be reproduced with the following steps:


1.     Install of WebCenter.
2.     Start the Node Manager and Managed Servers.
3.     Access WebCenter Spaces URL:
http://server:8888/webcenter/spaces
4.     Attempt to login as weblogic user.
Here the login hangs.


Cause

The domain system-jazn-data.xml file is missing all the security information for WebCenter.
The file should have entries like this:

<policy-store>
<applications>
<application>
<name>webcenter</name>
<app-roles>
<app-role>
<name>s8bba98ff_4cbb_40b8_beee_296c916a23ed#-#Administrator</name>
<guid>A03A67D1E43711DEBF8B15EA0015534D</guid>
<class>oracle.security.jps.service.policystore.ApplicationRole</class>
<members>
<member>
<class>weblogic.security.principal.WLSUserImpl</class>
<name>weblogic</name>
</member>
</members>
...


But in this case the file is missing the security entries for WebCenter like the above.

Reviewing more entries in the WebCenter Spaces diagnostic log (WLS_Spaces_diagnostic.log) there was another error in the log that indicated file permission errors:
[2009-12-07T10:53:15.966-08:00] [WLS_Spaces] [WARNING] [JPS-04085] [oracle.jps.deployment] [tid: [ACTIVE].ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'] [ecid: 0000ILeVDiF2bMK5qVh8iY1B7KwH000000,0] [APP: webcenter] [arg: oracle.security.jps.JpsRuntimeException: java.io.FileNotFoundException: /tmp/jazn-data-577128801xml.lck (Permission denied)] Migration of codebase policy failed. Reason: oracle.security.jps.JpsRuntimeException: java.io.FileNotFoundException: /tmp/jazn-data-577128801xml.lck (Permission denied).


While checking the permissions on the /tmp/jazn-data-577128801xml.lck file it was noted that it was owned by root user and oracle user did not have permissions on the file.



Solution


1.     Shutdown the Node Manager and Managed Servers.
2.     Change the ownership of the temporary file in /tmp directory to be owned by the user that was used to install WebCenter and that is being used to start WebCenter:

In this case the file name is: /tmp/jazn-data-577128801xml.lck

But in your system the name can be different. But the name should be like:
/tmp/jazn-data-NNNNNNNNNxml.lck
3.     Ensure the user that was used to install WebCenter has privileges to read, write, and update the above file.
If needed give grants on the file to the user that was used to install WebCenter.
4.     Restart WebCenter.
5.     Re-Test the issue.
-----------------------------------------------------------------------------

the problem is that i applied the solution but it is not working with me .if i grant (oracle) user which is used to install webcenter a privilege on /tmp/ folder,after restart everything become a in a big mass , that's because there is some files which belongs to root and mustn't be granted to oracle (this is as i understand maybe its wrong) .and if i grant and it is already granted full permission to (oracle) user on the file (jazn-data-NNNNNNNNNxml.lck) it is still not working and XML files is zero size .i do this on webcenter server (host2) and also on soa server (host1) which have admin server .

is there any advise ? am i missing something ? it is really a big problem to me as we suppose to go live next week !!!

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points