This discussion is archived
4 Replies Latest reply: Jul 29, 2013 10:08 AM by rukbat RSS

HelloWorld Application

907316 Newbie
Currently Being Moderated
I was getting the android SDK to work from Android3 SDK Programming, but it does not look good for two reasons. The book I purchased few days ago is actually February 2009 version. Maybe it is on bookstore shelf for three years. Secondly, it run with some errors. I am posting with little hope.

First my ACER Windows 7 is 64 bit operating system.
I installed JAVA SDK then Eclipse IDE in 64 bit.
Then installed SDK Android Starter Package. I downloaded all virtual devices.
Then installed ADT plug in for Eclipse by typing https://dl-ssl.google.com/android/eclipse and then click add.

To make it short, I run Hello Android Project in Eclipse as Android Project.
What I got is black screen with no HelloWorld as displayed in the book.

At the bottom of Eclipse in console displayed some errors.
Can you help me correct errors?
It looks like there is not much hope. I think something to do with Android emulator software.


[2011-12-30 00:04:50 - First application] ------------------------------
[2011-12-30 00:04:50 - First application] Android Launch!
[2011-12-30 00:04:50 - First application] adb is running normally.
[2011-12-30 00:04:50 - First application] Performing com.wiley.androidfordummies.HelloAndroid.FirstapplicationActivity activity launch
[2011-12-30 00:04:50 - First application] Automatic Target Mode: launching new emulator with compatible AVD 'android3'
[2011-12-30 00:04:50 - First application] Launching a new emulator with Virtual Device 'android3'
[2011-12-30 00:05:00 - Emulator] emulator: WARNING: Unable to create sensors port: Unknown error
[2011-12-30 00:05:00 - Emulator] emulator: emulator window was out of view and was recentered
[2011-12-30 00:05:00 - Emulator]
[2011-12-30 00:05:00 - First application] New emulator found: emulator-5554
[2011-12-30 00:05:00 - First application] Waiting for HOME ('android.process.acore') to be launched...
[2011-12-30 00:05:06 - First application] emulator-5554 disconnected! Cancelling 'com.wiley.androidfordummies.HelloAndroid.FirstapplicationActivity activity launch'!