1 Reply Latest reply on Jan 1, 2012 9:59 PM by 908362

    Java ME SDK Tools 3.0.5 Integration NetBeans IDE 6.9.1

      I've installed the NetBeans IDE v 6.9.1 and Java ME SDK Tools v 3.0.5 on a Vista (build 6001) SP1 machine and everything worked just fine. I had a system failure, and had to (attempt) uninstall / re-install. After a clean install of the OS (Vista Home Premium), the JavaME SDK folder was left over & I manually deleted it, re-installed the Java ME SDK Tools.

      My first issue was trying to get them to integrate into the Guest account. No luck. Then a standard user. No luck. And finally as an administor. No luck again.

      So basically, there seems to be some stranded registry entry (which I have tried to clean after uninstalls) that signals NetBeans 6.9.1 that the Java ME SDK (3.0.5) is installed (even when I have removed it and deleted to folder). At which point the NetBeans IDE asks continually if I would like to integrate the Java ME SDK Tools. Either way, the tools will no longer integrate.
        • 1. Re: Java ME SDK Tools 3.0.5 Integration NetBeans IDE 6.9.1
          Ok. So I finally got it working. I had to uninstall the Java ME SDK Tools, and NetBeans (again). This time, i received no errors. Then I deleted all of the related dot folders (.nbi, .netbeans, .netbeans-registration) & "javame-sdk" from every user folder.

          For some reason it seems that NetBeans IDE 6.9.1 or Java ME SDK 3.0.5 was still trying to use the old administrator account folder (from the previous, wiped-out Windows installation). I was wondering why the old account re-appeared in the User folder!

          So if your having the same problem: Uninstall NetBeans & Java ME SDK Tools, delete all related folders, run a registry cleaner like CCleaner, reboot, re-install.
          ** If you get errors during either uninstall operation, then you will have to re-install & uninstall again! ** <- Basically, do the above steps twice =)