0 Replies Latest reply: Jan 5, 2012 12:30 AM by 909068 RSS

    cannot start emulator use sun wireless toolkit

    909068
      hi,

      I'm a java developer, i has just develop on j2me environment, I installed netbean 7.1 and sun wireless toolkit 2.5.2 success, but when run project it can not launch simulator? log error here:

      Copying 1 file to /Users/vht-ngoctam/NetBeansProjects/MobileApplication1/dist/nbrun4496988268062024164
      Copying 1 file to /Users/vht-ngoctam/NetBeansProjects/MobileApplication1/dist/nbrun4496988268062024164
      Jad URL for OTA execution: http://localhost:8082/servlet/org.netbeans.modules.mobility.project.jam.JAMServlet//Users/vht-ngoctam/NetBeansProjects/MobileApplication1/dist//MobileApplication1.jad
      Starting emulator in execution mode
      java.lang.UnsatisfiedLinkError: /Users/vht-ngoctam/WTK2.5.2/bin/sublime.so: no suitable image found. Did find: /Users/vht-ngoctam/WTK2.5.2/bin/sublime.so: unknown file type, first eight bytes: 0x7F 0x45 0x4C 0x46 0x01 0x01 0x01 0x00
           at java.lang.ClassLoader$NativeLibrary.load(Native Method)
           at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1827)
           at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1703)
           at java.lang.Runtime.load0(Runtime.java:770)
           at java.lang.System.load(System.java:1020)
           at com.sun.kvem.Sublime.<init>(Unknown Source)
           at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
           at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
           at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
           at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
           at java.lang.Class.newInstance0(Class.java:355)
           at java.lang.Class.newInstance(Class.java:308)
           at com.sun.kvem.Lime.createLime(Unknown Source)
           at com.sun.kvem.KVMBridge.<init>(Unknown Source)
           at com.sun.kvem.KVMBridge.getBridge(Unknown Source)
           at com.sun.kvem.midp.MIDP.run(Unknown Source)
           at com.sun.kvem.environment.EmulatorInvoker.runEmulatorImpl(Unknown Source)
           at com.sun.kvem.environment.EmulatorInvoker.main(Unknown Source)
           at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
           at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
           at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
           at java.lang.reflect.Method.invoke(Method.java:597)
           at com.sun.kvem.environment.JVM.main(Unknown Source)
      /Users/vht-ngoctam/NetBeansProjects/MobileApplication1/nbproject/build-impl.xml:915: Execution failed with error code 1.
      BUILD FAILED (total time: 15 seconds)

      Please me to fix this problem as soon as possible,

      Thanks,