5 Replies Latest reply: Jan 25, 2012 6:55 PM by user380120 RSS

    EPMA server service is not working in EPM 11.1.2.1

    844181
      Hello guys,

      I am facing issue after successful installation and configuration of EPM 11.1.2.1. The "EPMA_Server" service is not starting. When I checked the DimensionServer.log file,
      i get the following error :

      at Hyperion.DimensionServer.Service.Main.Start()
      [2012-01-10T12:47:38.614-05:00] [EPMADIM] [NOTIFICATION:32] [EPMADIM-1] [EPMADIM.Hyperion.NetJNIBridge.Process.Program] [tid: EPMA NetJNIBridge] [ecid: disabled,0] Binding to port: 5255
      [2012-01-10T12:47:38.724-05:00] [EPMADIM] [NOTIFICATION:32] [EPMADIM-1] [EPMADIM.Hyperion.DimensionServer.Utility.ChannelUtility] [tid: EPMA NetJNIBridge] [ecid: disabled,0] Detected mixed IPv4 and IPv6 environment. Using :: binding.
      [2012-01-10T12:48:01.718-05:00] [EPMADIM] [NOTIFICATION:32] [EPMADIM-1] [EPMADIM.Hyperion.DimensionServer.Global] [tid: EPMA Server Startup] [ecid: disabled,0] Dimension Server terminated.
      [2012-01-10T12:48:02.436-05:00] [EPMADIM] [INTERNAL_ERROR:32] [EPMADIM-1] [EPMADIM.Hyperion.CommonServices.Exceptions.BaseException] [tid: EPMA Server Startup] [ecid: disabled,0] SVR_ERR_PROCESSMGR_CANT_INIT_SESSIONMGR:*Cannot initialize the Session Manager*. at Hyperion.DimensionServer.Service.Main.InitializeSessionManager()

      My system configuration is :
      Windows Server 2008 R2 x64
      EPM 11.1.2.1
      Oracle data access client is also installed.

      Please help in this issue.

      Thanks in advance,
      Santosh.
        • 1. Re: EPMA server service is not working in EPM 11.1.2.1
          JohnGoodwin
          This is from an article on Oracle Support which sounds like your issue


          Hyperion Essbase - Version: 11.1.2.1.000 and later [Release: 11.1 and later ]
          Microsoft Windows x64 (64-bit) - Version: 2008 R2
          Symptoms
          EPMA does not start, the Process Manager service fails to start with the following error in the DimensionServer log :

          [2011-04-25T11:44:09.350-05:00] [EPMADIM] [NOTIFICATION:32] [EPMADIM-1] [EPMADIM.Hyperion.DimensionServer.Global] [tid: EPMA Server Startup] [ecid: disabled,0] Dimension Server terminated.
          [2011-04-25T11:44:09.428-05:00] [EPMADIM] [INTERNAL_ERROR:32] [EPMADIM-1] [EPMADIM.Hyperion.CommonServices.Exceptions.BaseException] [tid: EPMA Server Startup] [ecid: disabled,0] SVR_ERR_PROCESSMGR_CANT_INIT_SESSIONMGR:Cannot initialize the Session Manager. at Hyperion.DimensionServer.Service.Main.InitializeSessionManager()
          at Hyperion.DimensionServer.Service.Main.Start()
          [2011-04-25T11:45:02.856-05:00] [EPMADIM] [NOTIFICATION:32] [EPMADIM-1] [EPMADIM.Hyperion.NetJNIBridge.Process.Program] [tid: EPMA NetJNIBridge] [ecid: disabled,0] Binding to port: 5255
          [2011-04-25T11:45:02.883-05:00] [EPMADIM] [NOTIFICATION:32] [EPMADIM-1] [EPMADIM.Hyperion.DimensionServer.Utility.ChannelUtility] [tid: EPMA NetJNIBridge] [ecid: disabled,0] Detected mixed IPv4 and IPv6 environment. Using :: binding.
          Cause
          EPMA does not support mixed IPv4 and IPv6 combination when they are both enabled.

          The hosts file included the line:

          127.0.0.1 localhost loopback

          EPMA uses the ‘localhost’ for URL construction of NETJNIBridge. When constructed with ‘localhost’ it will in turn utilize the mapping in the hosts file.

          Solution
          1. Modify the hosts file on the system where EPMA is installed and comment out this entry:

          127.0.0.1 localhost loopback

          2. Start EPMA.


          Cheers

          John
          http://john-goodwin.blogspot.com/
          • 2. Re: EPMA server service is not working in EPM 11.1.2.1
            844181
            Hi John,

            The machine is Windows server 2008 R2 x64.
            And the host file content(uncommented) is as follows :

            127.0.0.1 localhost
            :: 1

            I tried with commenting the portion as u said, but could not start EPMA server service successfully. Same message i saw in log. Can u suggest what can I do now?
            This issue is because both IPv4 and Ipv6 are enabled.

            Do we need to reconfigure the whole EPM? or any other changes that you can suggest in host file.
            Please help.

            Regards,
            Santosh.
            • 3. Re: EPMA server service is not working in EPM 11.1.2.1
              844181
              Do i need to install Microsoft Loop Back Adapter ?

              Also I observed .NET 2.0 service is not starting/ when started giving error.

              Is this also could have caused the EPMA not to start?

              Thanks in advance,
              Santosh.
              • 4. Re: EPMA server service is not working in EPM 11.1.2.1
                JohnGoodwin
                You could try disabling IPv6 as a test from the properties of the adaptor in network connection.
                If you uncheck "Internet Protocol Version 6 (TCP/IPv6)" then reboot and retry.

                Cheers

                John
                http://john-goodwin.blogspot.com/
                • 5. Re: EPMA server service is not working in EPM 11.1.2.1
                  user380120
                  You need to make sure that the hosts file on the server on which EPMA is running contain a pointer between localhost and the IP-address (IPv4).
                  Then it doesn't matter whether IPv6 is enabled or not.


                  Also you need to make sure that the EPMA-database (if MS SQL server) is configured as:
                  ALTER DATABASE databaseX1
                  SET ALLOW_SNAPSHOT_ISOLATION ON

                  ALTER DATABASE databaseX1
                  SET READ_COMMITTED_SNAPSHOT ON