1 2 3 Previous Next 36 Replies Latest reply on Jan 13, 2012 4:35 AM by 666373

    Oracle Linux4 update5 -- NTFS mounting

    666373
      Hi,
      I am using Oracle Linux4 Update5 and planning to install Oracle R12 on it soon.
      I have an external hard drive that when i plug in with my Linux based laptop gives me an error of - "mount: fs type ntfs not supported by kernel".

      As per my research, i had to do the following steps -
      sudo su -
      wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el4.rf.i386.rpm
      rpm -ivh ./rpmforge-release-0.5.2-2.el4.rf.i386.rpm

      All the above steps were completed successfully but i got an error in the next step. -
      yum install fuse fuse-ntfs-3g

      I got the following error -
      -----------------------------------
      Setting up Install Process
      Setting up repositories
      rpmforge 100% |=========================| 1.1 kB 00:00
      Cannot find a valid baseurl for repo: update
      Error: Cannot find a valid baseurl for repo: update
      ---------------------------------

      After doing some research on this issue, i came to know that i will have to uncomment baseurl command/path in yum.repos.d directory. I did that and then i started getting following error -
      ------------------------------------------
      Setting up Update Process
      Setting up repositories
      http://mirror.oss.oracle.com/Oracle/4/updates/i386/repodata/repomd.xml: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
      Trying other mirror.
      Cannot open/read repomd.xml file for repository: update
      failure: repodata/repomd.xml from update: [Errno 256] No more mirrors to try.
      Error: failure: repodata/repomd.xml from update: [Errno 256] No more mirrors to try.
      ------------------------------------------
      After doing this reaerch on this issue, i came to know that this issue is because - the following url does not work -
      http://mirror.oss.oracle.com/Oracle/4/updates/i386/repodata/repomd.xml

      I got a link that states that Oracle has released a public yum (below link), but that is only valid for Oracle Linux4 and update6 onwards.

      http://public-yum.oracle.com/

      Can some one please help to resolve this issue on update5? I really appreciate your help.

      Thanks,
      Anshul
        • 1. Re: Oracle Linux4 update5 -- NTFS mounting
          Avi Miller-Oracle
          user9959418 wrote:
          Can some one please help to resolve this issue on update5? I really appreciate your help.
          No. You either need to subscribe to ULN or upgrade to Oracle Linux 4 Update 6 or higher first. You can use public-yum.oracle.com to upgrade.
          1 person found this helpful
          • 2. Re: Oracle Linux4 update5 -- NTFS mounting
            666373
            Hi,

            Thanks for your reply. So for upgrade to Linux4 update6, do i have to reinstall the Linux? Could you please give me some insights on how to upgrade the Linux?

            Thanks,
            Anshul

            Edited by: user9959418 on Jan 11, 2012 8:17 AM
            • 3. Re: Oracle Linux4 update5 -- NTFS mounting
              Avi Miller-Oracle
              user9959418 wrote:
              Thanks for your reply. So for upgrade to Linux4 update6, do i have to reinstall the Linux? Could you please give me some insights on how to upgrade the Linux?
              No, you don't. Just enable the OL4U6 channel and do a yum update. It'll upgrade the system. However, this is a very, very old version of Linux. You should look at properly upgrading to a newer version at some stage.
              1 person found this helpful
              • 4. Re: Oracle Linux4 update5 -- NTFS mounting
                666373
                I am sorry if it is a stupid question- how do we enable the OL4U6 channel?

                Thanks so much for your help.

                Thanks,
                Anshul
                • 5. Re: Oracle Linux4 update5 -- NTFS mounting
                  Avi Miller-Oracle
                  user9959418 wrote:
                  I am sorry if it is a stupid question- how do we enable the OL4U6 channel?
                  Change enabled=0 to enabled=1 under [el4_u6_base] -- though, you could upgrade all the way to el4_u9 by enabling that channel instead. Essentially, one of the four base channels in public-yum-el4.repo should be enabled and only one. Then, run yum update and yum will update your system to that version of el4.
                  1 person found this helpful
                  • 6. Re: Oracle Linux4 update5 -- NTFS mounting
                    666373
                    Thanks so much Mr. Miller. I will try doing it today evening (after 2-3 hrs). I will update it directly to the update 9. I will let you know the status then. Your help is very much appreciated.

                    Thanks,
                    Anshul
                    • 7. Re: Oracle Linux4 update5 -- NTFS mounting
                      Dude!
                      ...should be enabled and only one
                      Are you sure? Does it matter? Shouldn't yum find what it requires. What happens if one enables all of them?

                      I remember when I upgraded from 5.5 to 5.6 I had to enable 5.5 and 5.6 in the repository because 5.6 required a software dependency that existed in 5.5. So I enabled both then the upgrade worked. I'm not sure anymore but I think it was yum that required a prior upgrade before moving on to 5.6, or was it 5.7?
                      • 8. Re: Oracle Linux4 update5 -- NTFS mounting
                        Avi Miller-Oracle
                        Dude wrote:
                        Are you sure? Does it matter? Shouldn't yum find what it requires. What happens if one enables all of them?
                        Yum has to do way more work. :) By enabling just the latest, yum doesn't have to compare the repository data from four different versions.
                        I remember when I upgraded from 5.5 to 5.6 I had to enable 5.5 and 5.6 in the repository because 5.6 required a software dependency that existed in 5.5. So I enabled both then the upgrade worked. I'm not sure anymore but I think it was yum that required a prior upgrade before moving on to 5.6, or was it 5.7?
                        From 5.5 to 5.6 you needed both el5_<arch>latest and ol5<arch>latest enabled, as this is when we moved from Oracle Enterprise Linux to Oracle Linux (and the UEK). From 5.6, everything is in ol5<arch>_latest. This is for ULN. The same sort of thing exists on public-yum.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
                        • 9. Re: Oracle Linux4 update5 -- NTFS mounting
                          Dude!
                          Yum has to do way more work.
                          Isn't this what computers are for?! ... just kidding. Thanks!
                          • 10. Re: Oracle Linux4 update5 -- NTFS mounting
                            666373
                            I am sorry to ask you this Mr. Miller, but where does el4_u6_base reside. I thought it would be in etc directory. I checked /etc/yum.repos.d but what all i could see is these files -
                            mirrors-rpmforge
                            mirrors-rpmforge-extras
                            mirrors-rpmforge-testing
                            rpmforge.repo
                            ULN-Base.repo

                            I thought i had to modify the rpmforge.repo file, is that correct? Please help..

                            This is how the rpmforge.repo file looks like -

                            ### Name: RPMforge RPM Repository for RHEL 4 - dag
                            ### URL: http://rpmforge.net/
                            [rpmforge]
                            name = RHEL $releasever - RPMforge.net - dag
                            baseurl = http://apt.sw.be/redhat/el4/en/$basearch/rpmforge
                            mirrorlist = http://apt.sw.be/redhat/el4/en/mirrors-rpmforge
                            #mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge
                            enabled = 1
                            protect = 0
                            gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
                            gpgcheck = 1

                            [rpmforge-extras]
                            name = RHEL $releasever - RPMforge.net - extras
                            baseurl = http://apt.sw.be/redhat/el4/en/$basearch/extras
                            mirrorlist = http://apt.sw.be/redhat/el4/en/mirrors-rpmforge-extras
                            #mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge-extras
                            enabled = 0
                            protect = 0
                            gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
                            gpgcheck = 1

                            [rpmforge-testing]
                            name = RHEL $releasever - RPMforge.net - testing
                            baseurl = http://apt.sw.be/redhat/el4/en/$basearch/testing
                            mirrorlist = http://apt.sw.be/redhat/el4/en/mirrors-rpmforge-testing
                            #mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge-testing
                            enabled = 0
                            protect = 0
                            gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
                            gpgcheck = 1

                            Thanks so much.

                            thanks,
                            Anshul
                            • 11. Re: Oracle Linux4 update5 -- NTFS mounting
                              Avi Miller-Oracle
                              user9959418 wrote:
                              I thought i had to modify the rpmforge.repo file, is that correct? Please help..
                              No, you have to follow the instructions at http://public-yum.oracle.com and remove the ULN-Base.repo file, which no longer works.
                              • 12. Re: Oracle Linux4 update5 -- NTFS mounting
                                666373
                                but those steps are for Oracle Linux 4, Update 6 or Newer. I am still on Oracle Linux4 update5. In order to use those instructions, i will still have to upgrade to update6 atleast.. Isn't it?

                                Thanks,
                                Anshul
                                • 13. Re: Oracle Linux4 update5 -- NTFS mounting
                                  Avi Miller-Oracle
                                  user9959418 wrote:
                                  but those steps are for Oracle Linux 4, Update 6 or Newer. I am still on Oracle Linux4 update5. In order to use those instructions, i will still have to upgrade to update6 atleast.. Isn't it?
                                  No. Follow the steps and it'll upgrade your system to Oracle Linux 4 Update 6 or higher, i.e. whichever one you enable.
                                  • 14. Re: Oracle Linux4 update5 -- NTFS mounting
                                    666373
                                    ahh.. thanks so much.. upgrading it now. it had already downloaded the new repo file but the second command got failed.

                                    mv Oracle-Base.repo Oracle-Base.repo.disabled
                                    mv: cannot stat `Oracle-Base.repo': No such file or directory

                                    Upgrading it now, will update you with the status once done. Thanks again!!

                                    Thanks,
                                    Anshul
                                    1 2 3 Previous Next