This discussion is archived
4 Replies Latest reply: Jan 25, 2012 8:30 AM by 882342 RSS

Finding out which version of jacob dll you need?

882342 Newbie
Currently Being Moderated
Hi,

I have Forms 11.1.1.3 running on 32 bit linux

Is there a check list that I can use to see which version of jacob.dll I need to download to use with webutil please?


Thanks
Tony
  • 1. Re: Finding out which version of jacob dll you need?
    HamidHelal Guru
    Currently Being Moderated
    879339 wrote:
    Hi,

    I have Forms 11.1.1.3 running on 32 bit linux

    Is there a check list that I can use to see which version of jacob.dll I need to download to use with webutil please?
    Check the following link
    1. Re: Webutil 11.1.1.1 - which jacob Version
    2. Re: Regarding jacob_18

    Hope you will get the answer.

    If someone's response is helpful or correct, please mark it accordingly.
  • 2. Re: Finding out which version of jacob dll you need?
    882342 Newbie
    Currently Being Moderated
    Hi

    Thanks for your response, but my question was really is there a document which shows which versions are approriate for the relevant forms version.

    So I knew that 1.10.1 was the correct version for my 11.1.1.3 and 1.14 is the version for 11.1.2 but is there a webutil/jacob compatibility matrix showing this for all versions of forms (and 32/64 bit for 11.1.2) ?

    cheers
    Tony
  • 3. Re: Finding out which version of jacob dll you need?
    Michael Ferrante (Oracle) Guru Moderator
    Currently Being Moderated
    There really is no "matrix" and I don't really know that one would be necessary as there aren't that many versions of which to be concerned. There have been numerous Support authored documents which talk about how to configure WebUtil in a particular Forms environment and each mention which Jacob version to use. However, that said, the proper jacob version for a given Forms version is documented in different places depending on which versions is in question. This is because WebUtil has been an evolving add-on to Forms since Forms version 9.0.2. In the newer releases, you can find the information in the product release notes. However, here is the simple answer to your question:

    Forms 9.0.4 and older with WebUtil 1.0.5 (beta) and older - Jacob 1.0.7

    Forms 9.0.4 and older with WebUtil 1.0.6 (beta) and older - Jacob 1.0.8

    Forms 10.1.2.0.2 - 10.1.2.3.0 with WebUtil 10.1.2.0 - 10.1.2.3 - Jacob 1.0.8

    Forms 10.1.2.3+ (Forms Bundle patch) - 11.1.1.x with WebUtil 10.1.2.3 - 11.1.1.x - Jacob 1.10.1

    Forms 11.1.2 with WebUtil 11.1.2 - Jacob 1.14.3

    I have also added the corresponding WebUtil version above. This is important because it is also often misunderstood. Starting with Forms version 10, the WebUtil version should correspond to the Forms version. So for example if you use Forms 10.1.2.2, your WebUtil version should also be 10.1.2.2.
  • 4. Re: Finding out which version of jacob dll you need?
    882342 Newbie
    Currently Being Moderated
    Thanks Michael,

    It's good to have it all summarised in one place.

    Tony

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points