4 Replies Latest reply: Apr 15, 2013 11:38 PM by 1003238 RSS

    Script Playback: OpenScriptToolbar is disabled in IE browser

    913433
      During script playback, OpenScript launches a browser, but the OpenScript toolbar is always turned 'off' in IE. I must first manually enable the OpenScript toolbar: IE main menu: View-->Toolbars-->Oracle.OATS.OpenScript.IEToolbar.OpenScriptToolbar.

      Otherwise, playback of scripts fails with the timeout error: "Cannot get a connection from helper after 60 seconds."

      I have tried:
      a. running InstallBrowserHelper.bat
      b. running Diagnosis Tool: suggestion to turn off IE Enhanced Security Configuration does not resolve problem
      c. locking/unlocking IE toolbars has no effect

      The browser window is launched by OpenScript. But the toolbar is not enabled. I have to enable it manually, otherwise the script playback will time out.

      In order for script playback to work I do the following:
      1. Click Playback button.
      2. Wait for OpenScript to launch a new browser .
      3. Inside the new browser just launched, select View-->Toolbars-->OpenScriptToolbar
      4. Allow script playback to proceed.

      Why is this? Certainly I cannot have this manual step.
      I cannot find a way to make IE keep the OpenScriptToolbar selected.

      I am running OpenScript version 9.3.0.0 on Windows 2003 Server (32-bit), using IE7.
        • 1. Re: Script Playback: OpenScriptToolbar is disabled in IE browser
          837855
          Hi,

          My OpenScript toolbar in View --> Toolbars is always enabled. That's the correct behaviour.

          Let's try and diagnose if it's an IE problem.

          Can you try the steps below?
          i. Try enabling/disabling another toolbar in your IE.
          Hint: You can test with the menu toolbar. When you disable it, it disappears and it appears when you press"Alt".

          ii. Close IE and Re-open.

          See if the settings have been retained. If they haven't been retained it's an IE problem.

          -Narayan
          • 2. Re: Script Playback: OpenScriptToolbar is disabled in IE browser
            913433
            Hello Narayan,

            Problem solved. I found a related thread and followed the steps below. It resolved my issue, as now the OpenScript toolbar is always enabled for each new browser that opens.

            1) Reinstall BHO helper

            a. CLOSE OpenScript and all browser instances IE & FireFox
            b. Run C:\OracleATS\OpenScript\UninstallBrowserHelpers
            -Open Command Prompt, navigate to the OpenScript Install directory
            (i.e.) cd C:\OracleATS\OpenScript
            -Type: UninstallBrowserHelpers and hit Enter.
            c. DELETE the directory C:\OracleATS\OpenScript\Oracle IE toolBar
            d. Run the script C:\OracleATS\OpenScript\InstallBrowserHelpers
            -In the Command Prompt window,
            -Type: InstallBrowserHelpers and hit Enter.

            2) Check for any other third party BHOs and disable them.

            a. Go to IE menu Tools -> Manage Addons and disable all addons (including ours).
            b. Enable only the following two ATS addons: OpenScript.BHO and Oracle.OATS.OpenScript.IEToolbars.OpenScriptToolbar.
            c. Close the Manage Addon dialog, launch IE and click Tools > Toolbars > make sure OATS IE Toolbar is "checked".
            • 3. Re: Script Playback: OpenScriptToolbar is disabled in IE browser
              983368
              Thank you, this worked for me!
              • 4. Re: Script Playback: OpenScriptToolbar is disabled in IE browser
                1003238
                Thanks ,i had the same issue and its resolved when i uninstall and install the IE toolbar :-)