4 Replies Latest reply on Feb 14, 2012 2:14 PM by DanielF

    Failed to initialize the application 'oim due to error java.security.Access

    DanielF
      Hi all,

      1. WLS domain (wls 10.3 on Linux, Middleware 11.1.1.5.0) is extended with OIM
      2. wls_oim1 is running and listening at port 14000

      oim initialization fails with following error:

      28871198884> <BEA-149205> <Failed to initialize the application 'oim [Version=11.1.1.3.0]' due to error java.security.AccessControlException: access denied (oracle.security.jps.service.credstore.CredentialAccessPermission context=SYSTEM,mapName=oim,keyNam
      =OIMSchemaPassword read).
      java.security.AccessControlException: access denied (oracle.security.jps.service.credstore.CredentialAccessPermission context=SYSTEM,mapName=oim,keyName=OIMSchemaPassword read)
      at java.security.AccessControlContext.checkPermission(AccessControlContext.java:374)

      =======
      I have tried to add following lines to ../Oracle_IAM1/server/apps/oim.ear/META-INF/jazn-data.xml

      <grant>
      <grantee>
      <codesource>
      <url>file:${domain.home}/servers/${weblogic.Name}/tmp/_WL_user/oim_11.1.1.3.0/-</url>
      </codesource>
      </grantee>
      <permissions>
      <permission>
      <class>oracle.security.jps.service.credstore.CredentialAccessPermission</class>
      <name>context=SYSTEM,mapName=oim,keyName=*</name>
      <actions>read,write</actions>
      </permission>
      </permissions>
      </grant>

      But without success.

      Do you have any idea how to solve this issue?

      Another thing which confuses me: I have implemented "Oracle Identity Management 11g Patch Set 4 (11.1.1.5.0) for Linux x86-64", why do I still have oim version 11.1.1.3.0???

      Thanks for support,

      Daniel