6 Replies Latest reply on Feb 18, 2012 2:26 AM by aziz

    Re: I am unable to start the service

    aziz
      Windows 2008
      Oracle 11.2.0.2

      Just completed patch install and when I try to start the service in Windows, I get the following error: "Windows could not start the OracleServiceSID service on <Server or host>" with the error 1053: The servcie did not respond to start or control request in timely fashing.

      My Solution:
      --Check tnsnames and listener
      Listener started without the service name (sid)
      Check listener's log and listener complaint about wrong sid

      --Bounce server
      Not still working.

      Here is a partial view of the listener log:

      Please take note of the Server_name=sid.hrd.webone.com. This service is not what I set as sid, I only made it sid, why is it showing the full string?

      <msg time='2012-02-17T18:55:51.111-05:00' org_id='oracle' comp_id='tnslsnr'
      type='UNKNOWN' level='16' host_id='<SERVER>'
      host_addr='::1'>
      <txt>17-FEB-2012 18:55:51 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=<Server$>))(SERVICE_NAME=sid.hrd.webone.com )) * (ADDRESS=(PROTOCOL=tcp)(HOST=<IP address>)(PORT=63919)) * establish * sid.hrd.webone.com * 12514
      </txt>
      </msg>
      <msg time='2012-02-17T18:55:51.111-05:00' org_id='oracle' comp_id='tnslsnr'
      type='UNKNOWN' level='16' host_id='<SERVER>'
      host_addr='::1'>
      <txt>TNS-12514: TNS:listener does not currently know of service requested in connect descriptor
      </txt>
      </msg>


      Any help will be apprecaited:
        • 1. Re: I am unable to start the service
          sb92075
          868332 wrote:
          Windows 2008
          Oracle 11.2.0.2

          Just completed patch install and when I try to start the service in Windows, I get the following error: "Windows could not start the OracleServiceSID service on <Server or host>" with the error 1053: The servcie did not respond to start or control request in timely fashing.

          My Solution:
          --Check tnsnames and listener
          Listener started without the service name (sid)
          Check listener's log and listener complaint about wrong sid

          --Bounce server
          Not still working.

          Here is a partial view of the listener log:

          Please take note of the Server_name=sid.hrd.webone.com. This service is not what I set as sid, I only made it sid, why is it showing the full string?

          <msg time='2012-02-17T18:55:51.111-05:00' org_id='oracle' comp_id='tnslsnr'
          type='UNKNOWN' level='16' host_id='<SERVER>'
          host_addr='::1'>
          <txt>17-FEB-2012 18:55:51 * (CONNECT_DATA=(CID=(PROGRAM=)(HOST=__jdbc__)(USER=<Server$>))(SERVICE_NAME=sid.hrd.webone.com )) * (ADDRESS=(PROTOCOL=tcp)(HOST=<IP address>)(PORT=63919)) * establish * sid.hrd.webone.com * 12514
          </txt>
          </msg>
          <msg time='2012-02-17T18:55:51.111-05:00' org_id='oracle' comp_id='tnslsnr'
          type='UNKNOWN' level='16' host_id='<SERVER>'
          host_addr='::1'>
          <txt>TNS-12514: TNS:listener does not currently know of service requested in connect descriptor
          </txt>
          </msg>


          Any help will be apprecaited:
          post content of sqlnet.ora
          1 person found this helpful
          • 2. Re: I am unable to start the service
            aziz
            >
            post content of sqlnet.ora
            # This file is actually generated by netca. But if customers choose to
            # install "Software Only", this file wont exist and without the native
            # authentication, they will not be able to connect to the database on NT.
            SQLNET.AUTHENTICATION_SERVICES = (NTS)
            And when I try to start the service, I get this error

            E:\Oracle\product\11.2.0\dbhome_1\bin>oradim -startup -sid <sid> -SYSPWD <pwd>
            DIM-00011: The specified service does not exist.
            O/S-Error: (OS 1053) The service did not respond to the start or control request in a timely fashion.

            Edited by: 868332 on Feb 17, 2012 4:42 PM
            • 3. Re: I am unable to start the service
              sb92075
              http://www.lmgtfy.com/?q=O/S-Error: (OS 1053)
              • 4. Re: I am unable to start the service
                What are the logon propeties for the SID service? Are you using a local system account or a specified account?

                Open services and right-click properties for the SID service. What are the Log On settings?
                • 5. Re: I am unable to start the service
                  aziz
                  Open services and right-click properties for the SID service. What are the Log On settings?
                  I am using local system account
                  • 6. Re: I am unable to start the service
                    aziz
                    Problem resolved:
                    Reinstall service
                    oradim –delete –sid <service_name>
                    oradim -new -sid <service_name>

                    Edited by: 868332 on Feb 17, 2012 6:25 PM