1 Reply Latest reply: Jun 20, 2012 2:08 AM by ErikLoosman RSS

    Logging into BAM server with newly created username throws invalid login

    user86097
      I am on 11.1.1.4, in the console created a new user (default authenticator).
      Assigned this user in the em to the BAM application roles.
      Now when I try to login to BAM console it throws

      'Invalid Login' error.

      Any pointer please ?
        • 1. Re: Logging into BAM server with newly created username throws invalid login
          ErikLoosman
          I encounter the same problem when restarting the bam_server. You may have solved this already, but others may not so here's a workaround for those in despair.

          According to the documentation Bam will retrieve the roles you defined in EM on logon. Clearly this didn't happen because it says 'Invalid Login'. I did not solve the automatic retrieval just now, but it's a development environment and only 1 or 2 users will actually use it. A workaround for this is to log on to the server OS and execute the registerusers utility. This Bam utility explicitly retrieves the bam-roles you registered for a specified user.

          On linux go to ...
          /<path_to_your>/soa/bam/bin
          ... and execute ...
          ./registerusers -adminuser <f.e. Administrator> <name of new user>

          you may need to set the JAVA_HOME parameter before executing the utility:
          export JAVA_HOME=<path to your jdk/jre>

          If the Bam user is your administrator-user but not "Administrator" itself, you have to run makemeanadcadmin.sql in the ORABAM database scheme before running the 'registerutils'.