10 Replies Latest reply: Mar 6, 2012 3:19 AM by sddc RSS

    APEX 4.1.1 patchset bug?

    sddc
      Hello,
      After applying the APEX 4.1.1 patchset, I have strange behaviour in APEX.
      When I try to edit interactive reports, from time to time I get the following error message:


      Error
      Error processing row.

      ORA-02290: check constraint (APEX_040100.WWV_VALID_PLUG_DISPPOINT) violated


      And when I have no error message when editing interactive reports attributes, the section Search Bar displays many checkbox with the following text:
      Exists (SQL query returns at least one row)
      NOT Exists (SQL query returns no rows)
      SQL Expression
      PL/SQL Expression
      PL/SQL Function Body Returning a Boolean
      Request = Expression 1
      Request != Expression 1
      Request Is Contained within Expression 1
      Request Is NOT Contained within Expression 1
      Value of Item / Column in Expression 1 = Expression 2
      Value of Item / Column in Expression 1 != Expression 2
      ...
      There are 60 checkbox with conditions like above.

      Any help or advices would be appreciate.

      Thanks

      SD
        • 1. Re: APEX 4.1.1 patchset bug?
          sddc
          Just to add that the FR language is installed.
          I tried to install the patch set again but still the same issue

          SD
          • 2. Re: APEX 4.1.1 patchset bug?
            sddc
            All the select lists and checkbox in Application Builder are corrupted.
            Please help.

            SD
            • 3. Re: APEX 4.1.1 patchset bug?
              joelkallman-Oracle
              Hi SD,

              1) Are you saying that everything worked properly in APEX 4.1 but when you applied the APEX 4.1.1 patch set, downloaded from My Oracle Support, that you started to encounter these errors?

              2) Were there any errors or warnings in in the patch set installation log?

              3) If you edit an Interactive Report and you get that error, will you get that error consistently, every time?

              4) For an IR where you get this error, can you query the APEX view APEX_APPLICATION_PAGE_REGIONS and report back what are the distinct display_position and display_position_code values in that application?

              5) What version of the database is this? What database character set are you using?

              6) Are you running your application in French when this occurs?

              Joel
              • 4. Re: APEX 4.1.1 patchset bug?
                sddc
                Hi Joel,

                Thanks for your answers.

                1) Yes, everything worked properly in APEX 4.1. When I applied the APEX 4.1.1 patch set downloaded from My Oracle Support I started to encounter these errors.

                2) There were no errors or warnings in the patch set installation log.

                3) No, I don't get that error consistently. Sometime I can edit an IR attributes but all the select list and checkbox are corrupted in Application Buider. For example, instead of having checkbox to select what to include in the search bar for a Interactive Report, I have 60 checkbox with:
                - Exists (SQL query returns at least one row)
                - NOT Exists (SQL query returns no rows)
                - SQL Expression
                - PL/SQL Expression
                - PL/SQL Function Body Returning a Boolean
                - Request = Expression 1
                - Request != Expression 1
                - Request Is Contained within Expression 1
                ...

                We have noticed that all the list of values / checkbox / options are corrupted in the application builder. It is as if they display values from other fields.

                4) For the application:

                display_position display_position_code

                Page Template Region Position 5 REGION_POSITION_05
                Page Template Region Position 2 REGION_POSITION_02
                Page Template Region Position 4 REGION_POSITION_04
                Page Template Region Position 6 REGION_POSITION_06
                Before Footer BEFORE_FOOTER
                After Header AFTER_HEADER
                Page Template Body (2. items below region content) BEFORE_SHOW_ITEMS
                Page Template Body (1. items below region content) BEFORE_BOX_BODY
                Page Template Region Position 1 REGION_POSITION_01
                Page Template Region Position 3 REGION_POSITION_03
                Page Template Body (3. items above region content) AFTER_SHOW_ITEMS
                Page Template Region Position 7 REGION_POSITION_07
                Page Template Region Position 8 REGION_POSITION_08


                5) Version of the database: 11.2.0.1.0 on windows server datacenter service pack 2 64 bits.
                Database character set: WE8MSWIN1252


                6) When the problem occurs I am running Application Builder in English

                Thanks for your help.

                Sébastien
                • 5. Re: APEX 4.1.1 patchset bug?
                  joelkallman-Oracle
                  Sébastien,

                  This is certainly puzzling.

                  Sorry for the continued barrage of questions, but here goes:

                  1) When you say "don't get that error consistently", does that mean that sometimes you can edit IR attributes and all of the select lists and checkboxes are rendered normally? But then other times, you edit the same attributes of the same IR in the same page in the same application, and the display of the select lists and checkboxes appear corrupted?

                  2) Was there any other configuration change / database change / Web server change / environment change done at the same time that you applied the APEX 4.1.1 patch set?

                  3) Are there any suspicious entries in your database alert log?

                  Joel
                  • 6. Re: APEX 4.1.1 patchset bug?
                    sddc
                    Thanks for your reply Joel.

                    1) When I don't get the error message, I can open the page to edit IR attributes but all of the select lists and checkboxes don't render normally. When I can't open the page to edit IR attributes I get an error message.

                    2) Nothing has been changed on the database / web server... at the same time I applied the APEX 4.1.1 patch set

                    3) Nothing suspicious

                    We reproduced that problem on another sever with the following steps:
                    1. New installation of Oracle Database 11g R2
                    2. Installation of APEX 4.1
                    3. Installation of FR language package
                    4. Installation of patch set APEX 4.1.1

                    Thanks

                    Sébastien
                    • 7. Re: APEX 4.1.1 patchset bug?
                      joelkallman-Oracle
                      Hi Sébastien,

                      I recommend you contact Oracle Support for further assistance on this issue.

                      I followed your steps exactly (DB 11gR2, APEX 4.1, installed French, applied APEX 4.1.1 patch set). The only difference I can see is my DB character set is AL32UTF8. But I do not encounter any errors when editing an Interactive Report. If Oracle Support can reproduce this, then hopefully we can diagnose it further. My suspicion is that this is an underlying database bug with pipelined table functions - we'll see.

                      Joel
                      • 8. Re: APEX 4.1.1 patchset bug?
                        Patrick Wolf-Oracle
                        Hi Sébastien,

                        I have a few additional questions if you don't mind.

                        1) what is your preferred language of your browser? Is it set to English [en] or to Frensh [fr]? In Firefox you can find that in the Settings/Content/Languages.
                        2) If I didn't miss read your your postings, you are running the APEX Builder in English. I assume you just need the FR language package for your application during runtime. What happens on your test system if the FR language package is uninstalled. Are you still able to reproduce the issue?
                        3) Can you post or mail us screen captures if the problem occurs. You can send them to oracle-application-express_ww@oracle.com

                        Regards
                        Patrick
                        -----------
                        My Blog: http://www.inside-oracle-apex.com
                        APEX Plug-Ins: http://apex.oracle.com/plugins
                        Twitter: http://www.twitter.com/patrickwolf
                        • 9. Re: APEX 4.1.1 patchset bug?
                          sddc
                          Joel, we will try to reinstall all with the same character set you used to see if the problem still occurs.

                          Patrick,

                          1) The prefered language of my browser is [en-US]

                          2) Yes I am running APEX builder in English. We just need FR language package for uour application during runtime. When the FR language package is uninstalled, we reproduce the issue

                          3) I mail you screen captures right now

                          Thanks to both of you

                          Sébastien
                          • 10. Re: APEX 4.1.1 patchset bug?
                            sddc
                            Just to give a new feedback.

                            On a test server we have reinstalled all the components but this time with AL32UTF8 for the character set of the database.
                            With this character set, all seems to work correctly and we didn't reproduce the bug we had with the other character set.
                            So it seems that there is a bug with some character set in the database and APEX 4.1.1

                            Sébastien