8 Replies Latest reply: Mar 2, 2012 6:46 AM by 826583 RSS

    JPD Upgrade issue

    Rishi Aggarwal
      We are upgrading from WLI 8.1 to Oracle WLI 10.3 - We are facing problem when we are trying to Upgrade 8.1 JPD's to 10.3 and getting the following error -

      Failed to create upgrader instance for com.bea.wli.ide.upgrade.JPDDocumentUpgrade.

      We have installed patches which should have resolved the above ..but we are seeing the above error again. Can give us some pointers on where we might be going wrong , whether it is Patch activation issue or additional patches need to be applied ? The following are the patches we have applied -

      T4EH.jar;EB3S.jar;7SSV.jar;PS4V.jar;2P2M.jar;4DRC.jar,RT9X.jar using smart update software.

      Can you also share information whether we can achieve upgrade in alternative ways without using the JPDupgrader?

      Please do the needful
        • 1. Re: JPD Upgrade issue
          Hi All,

          The Solution for this issue is:

          1) Please activate the patch by referring to http://blog.csdn.net/woohooli/article/details/5728698. Please note to close your Weblogic workshop beforing implementing this steps.
          2) Open the Weblogic workshop and follow the below steps:
          File - Import - Other - Workshop 8.1 Application - Browse and get your 8.1 workshop.exe - Click Next

          Now you can view JPD Document Upgrader options. Click on the check box and then Finish. ALL THE JPD'S WILL BE CONVERTED INTO .JAVA FILES AND YOU WILL BE ABLE TO VIEW IT.

          • 2. Re: JPD Upgrade issue
            Rishi Aggarwal
            Hey Finally i got the answer :

            After applying tha patches using smart update, we have to activate those patches and that we can do via simple command

            goto : Command Prompt --> goto BEA directory
            for example in my case

            execute --> D:\bea10\workshop_10.3>workshop.exe -clean -intialize

            Hurry ! all your patches are now activated. All your JPD files are now JAVA files.

            patch required "EB3S".

            • 3. Re: JPD Upgrade issue

              We need to upgrade from weblogic integration 8.1.4 to weblogic integration 10.3.1
              I can access the smart update but do not know how to apply patches:
              T4EH.jar;EB3S.jar;7SSV.jar;PS4V.jar;2P2M.jar;4DRC.jar,RT9X.jar using smart update software.

              What selection do I need to to apply the above patch.

              Your help is greatly appreciated.


              • 4. Re: JPD Upgrade issue
                Rishi Aggarwal
                Hi Sanjana,

                You have to put all the JAR files, in MW_HOME \utils\bsu directory

                in mine case

                c:\\bea\utils\bsu directory

                After pasting patches, start Smart Update. Now you will be able to see them in the list. Click on "Green" UP arrow to validate and install those patches.

                After Installation, you won't be able to see the changes as, further you have to activate those patches.

                you can activate those patches using following command on command prompt.

                c:\bea\workshop_10.3>workshop.exe -clean -initialize

                It will automatically restart the WLI10.X. and now you are all set to go.

                Edited by: Rishi Aggarwal on Feb 29, 2012 8:44 PM
                • 5. Re: JPD Upgrade issue
                  Rishi Aggarwal
                  @sanjana : I understood the steps that you sent me. But I do not know how to get the jar files.
                  I searched for them in oracle site but could not find them.

                  answer : All those pathes to have to find from https://support.oracle.com/ .
                  can you clarify me few things ?

                  1) Do you have below mentioned jar files with you?, because these jar files are nothig but the patches itself.

                  2) Do you have Oracle License, because with that you will get Customer Support Identifier (or CSI) or Sun Contract Number. With this number/identifier you can contact oracle support for patches or other related things.

                  @sanjana : Did you have to apply the patch of all jar files (T4EH.jar;EB3S.jar;7SSV.jar;PS4V.jar;2P2M.jar;4DRC.jar,RT9X.jar)
                  answer : each jar file/ patch has specific purpose, you may or may not need it for your project. For Example : EB3S.jar is required to Convert your JPDs to JAVA files. without this patch you wont be able to convert your application JPDs.

                  • 6. Re: JPD Upgrade issue
                    thanks Rishi for your reply with all the important steps.
                    I searched the installation folder of weblogic 10.3.1 and found some jar files under folder EB3S:

                    there is a jar file called weblogic_patch.jar in folder E:\bea10.3.1\patch_wls1030\profiles\EB3S\sys_manifest_classpath,
                    there are some more jar files in folder E:\bea10.3.1\patch_wls1030\profiles\EB3S\modules

                    Should weblogic_patch.jar be used to apply the patch for EB3S? We do not have licence for weblogic integration 10.3.1 yet.
                    • 7. Re: JPD Upgrade issue
                      Rishi Aggarwal

                      I think you are using wrong directory path : as per you case i am talking about following directory.


                      Put all your jar files example (T4EH.jar;EB3S.jar;7SSV.jar;PS4V.jar;2P2M.jar;4DRC.jar,RT9X.jar)
                      in this folder and then your will be able to see them in smart update console.

                      • 8. Re: JPD Upgrade issue

                        I will follow the steps that you have mentioned. The first thing that I need to do is contact oracle support for the patch with license identifier number.
                        Thanks so much for your help.