11 Replies Latest reply on Oct 8, 2012 10:02 AM by User232026

    Surrogate-Key Error

    785296
      In production we have:
      Portal 11g
      Webcenter 11g
      SSO
      OAM

      We are experiencing a continuing error when accessing portal. Instead of our Home page we are getting a Surrogate-Key error.

      OHS logs: FAILOVER_REQUIRED [line 581 of ap_proxy.cpp]: Service Unavailable

      Portal logs: ERROR: Repository Gateway error: Database Error: ORA=20001 ORA-20001: Unable to obtain session information from the cookie.

      Restarting the webcache fixes the problem. Any ides as to why we are getting this error and a possible solution?

      Thanks
        • 1. Re: Surrogate-Key Error
          rvanderhoorn
          Weird, exactly today we face the same problem..... can it be there's something wrong with tomorrow being feb 29 ?

          (edit) Just checked our logs, problems seem to have been there all month, but were only reported by users today.

          Edited by: rvanderhoorn on Feb 28, 2012 2:05 PM
          • 2. Re: Surrogate-Key Error
            785296
            I logged a call with oracle (December) to resolve this problem. Still awaiting a successful solution.

            Anyone else experienced this error and what was the fix?

            Grateful for any help!
            • 3. Re: Surrogate-Key Error
              rvanderhoorn
              In our situation we think we solved it; problem is not occurring right now. In our case it was when a certain portal page was called; we made sure it was not cached by webcache. It is a bit different than in your situation, I think. Do you use multiple portal servers in your network? In your case it looks like that after a failover the second server does not accept cookies from the original server. Just a guess...
              1 person found this helpful
              • 4. Re: Surrogate-Key Error
                785296
                How did you come to the conclusion that the error was generated by a certain page?

                We currently have 2 portal servers. Both servers show the same error. Even before we added a second portal server we were still getting the surrogate-key error.

                Thanks
                • 5. Re: Surrogate-Key Error
                  rvanderhoorn
                  The error occurred when starting that page, leaving it blank. In the source of the page (IE: viiew source) we noticed a "user defined exception". After examining the logs we found out the cookie got lost. We get this error when a page on a different Portal server (different server, different version) called this page by url.
                  • 6. Re: Surrogate-Key Error
                    785296
                    What you have posted sounds different from my issue.

                    What logs did you check when you noticed the cookie error and what was the error?
                    • 7. Re: Surrogate-Key Error
                      rvanderhoorn
                      Portal log

                      ERROR: Repository Gateway error: Database Error: ORA=20001 ORA-20001: Unable to obtain session information from the cookie.

                      That's exactly how I found this thread ...

                      Edited by: rvanderhoorn on Feb 29, 2012 5:49 PM
                      • 8. Re: Surrogate-Key Error
                        785296
                        Interesting. Did you also get the surrogate-key error when trying to access portal?

                        i.e (Content-type: image/gif Surrogate-Key: search-key=("si33" "pa33,1" "pp33,1") Location: http://'portal home page')

                        If you did. Was it the page contained in the error that you removed from webcache?
                        Thanks
                        • 9. Re: Surrogate-Key Error
                          rvanderhoorn
                          Unfortunately, we did not get that error, just a blank page, but that may be because our page has an exception handler (it's inPl.sql).
                          Did you ever rename your server? (hostname.abcdef.com) In that case you may have to revise your cookie-domain
                          • 10. Re: Surrogate-Key Error
                            785296
                            I am still experiencing this problem. Can anyone please offer any advice!

                            Portal Logs 1&2

                            30-May-2012 09:54:39
                            Message Level 1
                            URI /portal/pls/portal/PRD_PORTAL.wwpob_home.redirect_to_home_page or wwsec_app_priv.login

                            Relationship ID 0:1
                            Component WLS_PORTAL
                            Module oracle.portal

                            Host MySite
                            Host IP Address
                            User <anonymous>
                            Thread ID [ACTIVE].ExecuteThread: '8' for queue: 'weblogic.kernel.Default (self-tuning)'
                            ECID 004kJoPxvc89tXl_wtc9yW0005iE000HuL


                            Message ERROR: Repository Gateway error: Database Error: ORA=20001 ORA-20001: Unable to obtain session information from the cookie.

                            Supplemental Detail ORA-06512: at "PRD_PORTAL.WPG_SESSION", line 174
                            ORA-06512: at line 32

                            OHS Logs

                            30-May-2012 09:54:39
                            Message ID OHS-9999
                            Message Level 32
                            VirtualHost main
                            Relationship ID 0
                            Component OHS
                            Module core.c

                            Host MySite
                            Host IP Address
                            User owcprd
                            Thread ID 1682389344
                            ECID 004kJoPxvc89tXl_wtc9yW0005iE000HuL


                            Message FAILOVER_REQUIRED [line 581 of ap_proxy.cpp]: Service Unavailable
                            • 11. Re: Surrogate-Key Error
                              User232026
                              Hi,

                              Did you in the end find a solution to this problem. We are experiencing the same problem: Content-type: image/gif Surrogate-Key: search-key=("si33" "pa33,1" "pp33,1")

                              Thanks,
                              Torsten