3 Replies Latest reply: Mar 4, 2012 8:37 AM by Udo RSS

    Blank screen with APEX Listener and TOMCAT7

    683199
      Hi,

      I have read lots of post but haven't find a solution to my problem.
      I'm trying to access APEX4 using APEX Listener and Tomcat7. I have follow the instructions, define the image folder, .... But when I try to go to http://my_server:8080/apex, the system rewrite the URL like http://my_server:8080/apex/f?p=4550:1:2073200239877831 and give me a blank screen.

      I haven't see any error message. Do you have an idea of the problem ?

      Regards,
        • 1. Re: Blank screen with APEX Listener and TOMCAT7
          Udo
          Hi Olivier,
          I'm trying to access APEX4 using APEX Listener and Tomcat7.
          This scenario is not supported officialy but know to work.
          I have follow the instructions, define the image folder, ....
          Since these can't be taken from the Installation Guide, could you give some more details on that part, i.e. which instructions did you follow? Especially, how did you define the image folder?
          Please also describe which operating systems you use, where your database is located, which database version and edition your APEX resides in, which exact JDK you use, etc.

          On a standard Tomcat, you could put the static contents ("images") into the ROOT webapp. Make sure you have the ones that fit to the APEX version you're pointing your APEX Listener to, and that the whole directory is readable for the user on whose behalf your Tomcat is running.
          [...] give me a blank screen.
          Do you see any error in catalina.out?
          What's the page contents of that blank screen? A common problem would actually be the images not being in the right place or not having the right version, as mentioned before...

          -Udo
          • 2. Re: Blank screen with APEX Listener and TOMCAT7
            683199
            Thanks for you help.

            I have already try to copy the images folder of my APEX, create a symbolic link with no result. But if I copy the images folder of ZIP that cotain the APEX install, all is Ok.
            • 3. Re: Blank screen with APEX Listener and TOMCAT7
              Udo
              Great to hear you've got it working.
              I have already try to copy the images folder of my APEX, create a symbolic link with no result. But if I copy the images folder of ZIP that cotain the APEX install, all is Ok.
              Where else did you get the images folder for your APEX if not from the ZIP file that contains the installation package? The latter is definetly the recommended source for it.
              As for symbolic links: Tomcat doesn't follow any symlink by default. You could configure a certain context to do that or even create a new context to point at a linked directory, but it seems you didn't do that. Anyway, I wouldn't recommend this unless you really have a reason to do this instead of using the ROOT context...

              -Udo