7 Replies Latest reply on Feb 29, 2012 6:12 PM by 918007

    non-global zone in "shutting_down" state.. Hung in this state

      Hi.. My server is running in Sol10. It has got two non-global zones hosted in it in which the database is running.
      There was some complain from the database team that they were not able to login to the server. When I checked, it the status of the local zones were fine. But when tried to "# zlogin" to them, it got hung. So i tried to " # zlogin -S <zone_name>" and i was able to login in the failsafe mode but not able to execute any command in it. Any command from "uptime", "zfs list", gets hung and i had to forcefully logout.

      So I tried to halt the non-global zones first and then boot it. But here, it got stuck in "shutting_down" state.
      When tried to kill the processes of the non-global zones using "kill -9", it failed to kill the processes.

      so I rebooted the global zone which fixed the issue. But then, 10 days later, the same issue came up.
      I followed the same steps to fix the issue but i'm afraid this issue might come up again since i think rebooting the global zone server is a temporary fix.

      I logged a call with Oracle Support for this, but the server looks fine from the explorer output that was provided.

      Has anyone faced this same problem? What can i do to fix this issue permanantly?