7 Replies Latest reply: Apr 17, 2012 3:37 PM by 709422 RSS

    Exceeded configured maximum number of allowed input records.

    864099
      Hi Every One,


      I am using OBIEE 11.1.16.

      when I am trying to create a graph view(stacked vertical) it is displaying an error "Exceeded configured maximum number of allowed input records"

      It is working fine in table view

      In my request there are 944104 records.

      Any suggestions will be really helpfull for me.

      Thank you very much.
        • 1. Re: Exceeded configured maximum number of allowed input records.
          JV123
          Hi,

          Hi,

          Chang Default Rows Displayed count in instance config file. add below code within server instance tag.

          <Views>
          <pivot table>
          <DefaultRowsDisplayed>100000</DefaultRowsDisplayed>
          <pivot table>
          </Views>


          restart presentation server.

          Thanks
          Jay.
          • 2. Re: Exceeded configured maximum number of allowed input records.
            864099
            Hi Jay,

            Even after modifying the instance config file .

            It is giving the same error.
            • 3. Re: Exceeded configured maximum number of allowed input records.
              Amith Y
              You need to bounce the presentation services after making any changes to the instanceconfig.xml file.
              • 4. Re: Exceeded configured maximum number of allowed input records.
                user248025
                Hi,
                Its Analytical tool.while u r creating Answres report set it filters in the criteria and test it. no ther option u need to have manual cell calculation like let say one pivot table (Rows * Col ) based on u r request columns u have to define like this in u r instance config.xml file after making this changes u mustart BI Services.

                <Views>
                <Pivot>
                <MaxCells>1920000</MaxCells>
                <MaxVisibleColumns>30</MaxVisibleColumns>
                <MaxVisiblePages>1000</MaxVisiblePages>
                <MaxVisibleRows>64000</MaxVisibleRows>
                <MaxVisibleSections>25</MaxVisibleSections>
                <DefaultRowsDisplayed>500</DefaultRowsDisplayed>
                <!--This Configuration setting is managed by Oracle Business Intelligence Enterprise Manager--><DefaultRowsDisplayedInDelivery>75</DefaultRowsDisplayedInDelivery>
                <!--This Configuration setting is managed by Oracle Business Intelligence Enterprise Manager--><DefaultRowsDisplayedInDownload>2500</DefaultRowsDisplayedInDownload>
                <!--This Configuration setting is managed by Oracle Business Intelligence Enterprise Manager--><DisableAutoPreview>false</DisableAutoPreview>
                </Pivot>
                <Table>
                <MaxCells>1920000</MaxCells>
                <MaxVisiblePages>1000</MaxVisiblePages>
                <MaxVisibleRows>64000</MaxVisibleRows>
                <MaxVisibleSections>25</MaxVisibleSections>
                <DefaultRowsDisplayed>500</DefaultRowsDisplayed>
                <!--This Configuration setting is managed by Oracle Business Intelligence Enterprise Manager--><DefaultRowsDisplayedInDelivery>75</DefaultRowsDisplayedInDelivery>
                <!--This Configuration setting is managed by Oracle Business Intelligence Enterprise Manager--><DefaultRowsDisplayedInDownload>2500</DefaultRowsDisplayedInDownload>
                </Table>
                </Views>

                Thanks

                Deva
                • 5. Re: Exceeded configured maximum number of allowed input records.
                  864099
                  Hi Devarasu,

                  I have changed the instance config file as you said by calucalating the number of cells.

                  and restarted the BI services

                  But even after that when creating graph it giving the same error

                  " exceeded the maximum number of allowed input records'
                  • 6. Re: Exceeded configured maximum number of allowed input records.
                    SumanBusireddy
                    Think other way,
                    Does it makes Sense, to create a chart using that many rows, Who would you conclude from that...

                    May be chart engine is not capable of accommodating that many rows (944014)... the number you mentioned is too long... Think again...


                    -Suman
                    • 7. Re: Exceeded configured maximum number of allowed input records.
                      709422
                      See http://docs.oracle.com/cd/E21764_01/bi.1111/e10541/answersconfigset.htm#CIHJDHGI

                      You want to add it to a new <Charts></Charts> child member of the <Views> node.