9 Replies Latest reply: Mar 2, 2012 8:30 AM by 807928 RSS

    This node is not in cluster mode (3.3) x86

    862454
      Brand new install (single node)

      clnode show
      clnode (C152734) This node is not in cluster mode

      scinstall isn't further sucessfully enabling me to configure the cluster in order to put the node in cluster mode
      it's not even in installation mode (it's not in anything)

      I did edit grub multiboot -x and reboot in order to follow the instructions for uninstalling cluster software to fix
      installation problems /usr/cluster/bin/clnode remove

      clnode remove error
      You cannot uninstall Oracle Solaris Cluster from active cluster members

      Can't configure it, can't remove it. I'm stuck!
        • 1. Re: This node is not in cluster mode (3.3) x86
          807928
          I think the clnode step is only for clusters with >1 node. Have you tried running "scinstall -r"

          Tim
          ---
          • 2. Re: This node is not in cluster mode (3.3) x86
            862454
            I have just tried scinstall -r with the following error

            You cannot uninstall Oracle Solaris Cluster from active cluster members.
            • 3. Re: This node is not in cluster mode (3.3) x86
              862454
              The configuration is corrupt I think because

              scsetup gives the following error

              scconf -a -T node=.
              scconf: This node is not currently in the cluster.

              Command failed.


              So I'm getting errors that the node is both an active cluster member and is not in the cluster both at the same time!

              I'm guessing that I'm going to have to remove the cluster software manually and reinstall it.

              Has anyone ever done this?
              • 4. Re: This node is not in cluster mode (3.3) x86
                807928
                If you boot it in cluster mode, are there services that don't start? (svcs -x)

                Tim
                ---
                • 5. Re: This node is not in cluster mode (3.3) x86
                  862454
                  svc:/system/cluster/cl-svc-enable:default (Enabling the cluster userland services)
                  State: disabled since 1 March 2012 11:42:53 GMT
                  Reason: Disabled by an administrator.
                  See: http://sun.com/msg/SMF-8000-05
                  Impact: 1 dependent service is not running. (Use -v for list.)

                  svc:/system/cluster/bootcluster:default (Oracle Solaris Cluster bootcluster service)
                  State: disabled since 1 March 2012 11:42:52 GMT
                  Reason: Disabled by an administrator.
                  See: http://sun.com/msg/SMF-8000-05
                  Impact: 1 dependent service is not running. (Use -v for list.)

                  svc:/system/cluster/rgm-starter:default (Resource Group Manager Daemon)
                  State: disabled since 1 March 2012 11:43:17 GMT
                  Reason: Disabled by an administrator.
                  See: http://sun.com/msg/SMF-8000-05
                  Impact: 1 dependent service is not running. (Use -v for list.)

                  svc:/system/cluster/cl-svc-cluster-milestone:default (Synchronizing the cluster userland services)
                  State: disabled since 1 March 2012 11:43:18 GMT
                  Reason: Disabled by an administrator.
                  See: http://sun.com/msg/SMF-8000-05
                  Impact: 1 dependent service is not running. (Use -v for list.)
                  • 6. Re: This node is not in cluster mode (3.3) x86
                    862454
                    I enabled those four and the machine halted with the error


                    Cluster Boot

                    module not found cl_comm

                    boot -x and repair
                    • 7. Re: This node is not in cluster mode (3.3) x86
                      807928
                      Is this a real 64 bit x86 server and not some VM guest? If it is a 32 bit system then that might explain the problems as this wouldn't be supported.

                      Otherwise, I don't really have any suggestion as to why this isn't working.

                      Tim
                      ---
                      • 8. Re: This node is not in cluster mode (3.3) x86
                        862454
                        The download is for x86 (not x86-64)
                        x86 runs 32bit i386 binaries and 64 bit AMD binaries
                        and cl_comm is an and binary /kernel/misc/amd64/cl_comm

                        isainfo -v
                        64-bit amd64 applications
                        cx16 mon sse3 sse2 sse fxsr mmx cmov amd_sysc cx8 tsc fpu
                        32-bit i386 applications
                        cx16 mon sse3 sse2 sse fxsr mmx cmov sep cx8 tsc fpu

                        I think it's supposed to run on straightforward x86 it's just my particular installation which is messed up.
                        Incidentally I've seen but reports for cl_comm undefined symbol compiler errors. At boot time I receive
                        tons and tone of compiler errors for cl_comm undefined symbol (I have no idea why because it's a binary
                        file.)

                        Truth is I'm going to have to reinstall this. If the worst comes to the worst I'll have to reinstall the OS. I really
                        don't want to do that and unless I figure out what's going on here, when I do the reinstalls and put cluster
                        back on, I'll be in exactly the same situation in one day's time!
                        • 9. Re: This node is not in cluster mode (3.3) x86
                          807928
                          But it is a kernel module. Oracle Solaris Cluster drivers for 32 bit x86 processors were never publicly released. You have to run on a 64bit x64 processor. I'm pretty sure that is stated in the documentation. You can check the archives for this forum where several others have run into the same issue.

                          Regards,

                          Tim
                          ---