4 Replies Latest reply on Apr 30, 2012 4:37 PM by 817614

    Invalid characters displayed in java-based tool

      I'm having problems with a java applet that works fine on the vast majority of PCs, with 1 exception. The one in question runs Windows 7 32 bit professional, IE8. Java versions 27,29, and 31 have been tried, with the same results.

      There are several fields, each of which has a title and a default value. On a working PC, the field names are:

      Mortgage amount:
      Interest rate:
      Monthly payment (PI):
      Annual property taxes:
      Annual home insurance:
      Monthly payment (PITI):

      On a PC that its not working:
      Kn` mHmendl `shmm9
      Lnqsf` fd `l nt ms9
      Hmsdqdrsq` sd9
      Lnmaglx o` xl dms` OH(9
      @mt ` koqnodqsx s wdr 9
      @mt ` kgnl d hmtq` mbd9
      L nmaglx o`xl dms ' OHSH(9#371-1/

      There are more fields, but that's an example. it may not be exactly correct, since the spacing and character overlap makes it hard to differentiate some characters.

      All the browser troubleshooting has been done (reset, cleared temps, deleted active X objects etc.)
      Cleared all local cache, java cache and ran ccleaner
      Checked Windows region, language, currency etc settings
      Tried to reinstall java, tried 3 different versions (27, 29, 31)
      Tried the local Admin profile and problem persists across multiple profiles.

      If anyone has any ideas about which settings could possibly cause this character translation, I would be very appreciative. There appers to be a 1:1 correlation of characters, for example:

      # = $
      / = 0
      : = 9
      R = S

      Could it be some kind of java / unicode setting?
        • 1. Re: Invalid characters displayed in java-based tool
          So basically the language of that machine is set to Klingon :/
          Could it be some kind of java / unicode setting?
          It happens on one machine you say. It is more likely there is a problem with that one machine that is influencing Java from outside. But WHAT exactly... I am stumped. How do those "fields" end up in the applet? Where are the values for the fields coming from? Just hard coded? From a properties file? Some other data source?
          • 2. Re: Invalid characters displayed in java-based tool
            If I could post a picture it might help explain...


            Uploaded, hopefully you can view it.

            We've reset the browser, even tried IE9, with the same result. There's no toolbars installed and machine tested clean for adware. With no java installed, the webpage displays sans mortgage calculator. What seems strange is that some of the text displays properly, as you can see in the picture, so that's why I wonder if its just one particular font that's not being displayed properly? The entire rest of the web page, and everything else that uses java works fine, it seems like it's just this one particular calculator.

            It's at the point where the OS may just need to be reinstalled, though it seems like a small, petty thing to reinstall the OS for... but without a solution i don't really have any other options.
            • 3. Re: Invalid characters displayed in java-based tool
              I have same issue

              I tried versions 1.5.xx - and characters are ok. But because security I need to work on 1.6. - Any idea?
              • 4. Re: Invalid characters displayed in java-based tool
                It would be interesting to see if the problem still happen if you could isolate the UI code and run the applet as stand-alone java app. This would tell if the plugin environment contribute to the wrong characters being displayed.