2 Replies Latest reply: Aug 8, 2012 3:43 PM by joelkallman-Oracle RSS

    Bug in 4.1.1: Region Title translations is lost

    832555
      Hello, apex team and Joel Kallman.

      This is my second bug report with translations today.

      REGION TITLE TRANSLATIONS IS LOST WITH APEXexport AND APEX_APPLICATION_INSTALL COMBINATION.

      My environment:
      Oracle XE 11g Linux 64bit.
      Apex 4.1.1.

      Development app 110.
      Production app 111.

      en-us - primary lang
      es - secondary
      ru - secondary

      How to reproduce:

      Export app 110 with bash command:
      $ java oracle.apex.APEXExprt -db xxx.private:1521:XE -user apex_040100 -password `cat secret.txt` -applicationid 110 -skipExportDate -expTranslations

      Import with this script (as apex_040100 user)
      declare
      l_workspace_id number;
      begin
      select workspace_id into l_workspace_id
      from apex_workspaces
      where workspace = 'PROD';
      --
      apex_application_install.set_workspace_id( l_workspace_id );
      apex_application_install.set_application_id(111);
      apex_application_install.generate_offset;
      apex_application_install.set_schema( 'PROD' );
      apex_application_install.set_application_alias( 'FPROD_APP' );
      end;
      /

      @../f110.sql

      Then SEED and PUBLISH in Apex Builder.

      At this point Region Title translations is lost for every region in app.

      Workaround:
      I use blog post "Moving your XLIFF files" by Joel Kallman on YABAOAE from the very first day it was published.
      http://joelkallman.blogspot.com/2010/07/moving-your-xliff-files.html

      It is only way to use DEV and TEST/UAT env. on the same database with translated apps. Thanks to Joel.

      If it is not a bug, please, explain me better way to workaround it for me.

      Vladimir