3 Replies Latest reply on Mar 6, 2012 10:25 PM by Kosta-Oracle

    Application that worked in 11g has errors in 12c

      I am not a developer, and do not have access to the source. So what I am looking for is some configuration change or JVM argument that can be used to bypass the error, if one exists...

      Here is the exception I am seeing (not the whole stack trace, but the caused by):

      Caused by: org.springframework.beans.factory.BeanDefinitionStoreException: Failed to parse JAXB element: javax.xml.bind.JAXBException: Provider org.eclipse.persistence.jaxb.JAXBContextFactory could not be instantiated: javax.xml.bind.JAXBException:
      Exception Description: Duplicate Property named [interceptor] found on class [org.apache.camel.model.InterceptorRef]
      - with linked exception:
      [Exception [EclipseLink-50072] (Eclipse Persistence Services - 2.3.2.v20111125-r10461): org.eclipse.persistence.exceptions.JAXBException

      Any ideas would be appreciated.

      Clint Cone
        • 1. Re: Application that worked in 11g has errors in 12c
          Ram V-Oracle
          Hi Clint,

          It would be helpful if you can provide additional information about your application:

          - project | Properties | Project Facets, list all the facets & associated version

          - project | properties | Project Facets | Spring Facet, the type of library

          - project | Properties | Targeted Runtimes, WLS version

          Please also mention the full version of 11g on which the application worked fine and did you migrate the app to 12c RT or run the app as-is on 12c.

          • 2. Re: Application that worked in 11g has errors in 12c
            I'm not sure what Project Facets or Spring Facets are. I am sure that the Spring framework being used is horribly back-version as this is an application that has been used for several years without an update to the plumbing.

            The system specifics for the application server are:
            Windows based - JDK 1.6 64-bit.

            The application started as a WebLogic 9.2.3 domain.

            I upgraded it to WebLogic 11g (10.3.5) using the domain migration tool, and was able to run it with some tweaking to the JVM flags:
            Added the following: -Dcom.sun.management.jmxremote

            Then upgraded it to WebLogic 12c (12.1.1) using the domain migration tool. The errors I am seeing are in a small service mix deployment that gets generated/deployed automatically the first time the main application gets started.

            From the looks of it, I may need to get a developer to look into it. They could find the answers to your questions. I was hoping there was some magic bullet setting that would force back-level compatability, but I don't even lnow exactly which part of WL I am having issues with. That would make this a bit of a wild-goose chase until I come up with something more specific.

            Sorry for the bother.
            • 3. Re: Application that worked in 11g has errors in 12c
              If you are simply trying to migrate an existing domain with an application to a newer version of the server, then this isn't a tooling question. You will get better support by asking your question on the WLS forum.

              WebLogic Server - General

              - Konstantin