4 Replies Latest reply: Apr 13, 2012 5:05 AM by Greig RSS

    Selective Mode Pubshing (See it but NOT Try it, etc.)

    925591
      I am trying to publish player content for my partner organization. They would like the "SEE IT" and "PRINT IT" but not the other modes. When I publish, I always get ALL the player modes.

      Looking at the topic properties, it appears as though you can check some rather than all modes. But when I publish, all modes are published regardless.

      I tried to provide a link to only the "SEE IT" content but it required a player package. I tried this out on a machine and ran the installer for the player package. It still brought me to a page with all the other modes on there.

      Surely there must be a way to selectively publish. Cannot find in any resolution in my UPK documentation.

      es

      Edited by: 922588 on Mar 21, 2012 2:59 PM
        • 1. Re: Selective Mode Pubshing (See it but NOT Try it, etc.)
          925368
          Hello,

          I think you use UPK 11, in the properties panel you can select the playback modes you want for a topic in the player using the menu : PlayBack modes. Be carefull, before this option you select the mode using sound and after that one modes for the LMS output.

          Kind regards,

          Alex
          • 2. Re: Selective Mode Pubshing (See it but NOT Try it, etc.)
            925591
            Thanks for your reply, Alex. As stated I DID select the playback modes in the property panel and my choices were ignored upon publishing.

            I thought I might have artifacts in my publishing directory, so I deleted all content and re-published (with just "SEE IT" selected in the properties panel).

            Still, ALL playback modes were published once again.

            Am I doing something wrong? Please advise.

            es
            • 4. Re: Selective Mode Pubshing (See it but NOT Try it, etc.)
              Greig
              Hi es,

              I managed to get my UPK 11 to only show "See It", "Try it" and "Print it". It seems like 'Try it" is hand-in-hand with "See it", so I could therefore not get rid of "Try it".
              As you have done, ensure that "See It/Try it" is selected as the mode for EACH frame within the topic - this is changed in the "Show in" block under the Frame Properties.

              Then, when you publish, you must change some options too. Get to the stage of the publishing wizard where you have the tick boxes available to you to choose what and how to deploy content. Select the "Player and LMS" option, and look at the properties on the right. Under Player Preferences, ensure that the default mode is "See It". On the same properties, further down, there is a section called "Print It" - ensure that the Text Mode "See It/Try It" is selected here.

              Then, on the left again, choose the option that says "Standalone Topic Files" - preview the properties, and again, ensure that the Text Mode under "Print It" is set to "See It/Try It".

              Go ahead and publish - you may get errors as I did, stating that there is no "Do It" mode etc. This is fine.
              Preview the play.exe and then see if that is what you want?

              Best I could come up with - hope it helps somewhat!

              Regards,
              Greig