5 Replies Latest reply: Aug 6, 2012 2:20 PM by 946723 RSS

    Common Array Manager on linux 64

    Bjoern Rost
      Hi,

      I tried to install CAM (both 6.9 and 6.8.1) on OEL6 64bit today. I downloaded the 64 bit version and checked the md5 sums. But when trying to install CAM, I get an error saying that the bundled jre cannot be installed. I suspect this is because the jre comes in a 32bit binary. Has anyone else come across this issue?
      Bundled JRE is not binary compatible with host OS/Arch or it is corrupt.  Testing bundled JRE failed.
      Thanks
      bjoern
        • 1. Re: Common Array Manager on linux 64
          Bjoern Rost
          Ok, I found my mistake. I forgot to install ksh which is a requirement for the cam installer. After having installed the ksh rpm, things are looking much better.
          • 2. Re: Common Array Manager on linux 64
            946723
            Hi,

            Were did you find the list of requirements? I'm getting the same Java error on CentOS 6.2. I've installed ksh and also tried running the installer in ksh, same error. I even downloaded the Linux 32 bit, which is the as the 64bit, for latest CAM. Thank you for your time.

            Best,
            Pedro
            • 3. Re: Common Array Manager on linux 64
              user469
              http://docs.oracle.com/cd/E24008_01/pdf/E24012.pdf

              ■ libXtst-1.0.99.2-3.el6.i686.rpm and its dependent rpm (InstallShield
              requirement)
              ■ libselinux-2.0.94-2.el6.i686.rpm
              ■ audit-libs-2.0.4-1.el6.i686.rpm
              ■ cracklib-2.8.16-2.el6.i686.rpm
              ■ db4-4.7.25-16.el6.i686.rpm
              ■ pam-1.1.1-4.el6.i686.rpm
              ■ libstdc++-4.4.4-13.el6.i686.rpm
              ■ zlib-1.2.3-25.el6.i686.rpm
              ■ ksh-20100621-2.el6.x86_64.rpm
              • 4. Re: Common Array Manager on linux 64
                946723
                Thank you for the reply. I already had those packages installed. I even installed the devel packages, like libstdc++-devel, same error. Fortunatly the 32 bit version of the installer runs fine on CentOS 5.8. I'd rather not use CentOS 5 but happy it works. We have the StorageTek 2530 up and running. We also have a lot of systems running CentOS 5, for somewhat similar reasons. : /

                Best,
                Pedro
                • 5. Re: Common Array Manager on linux 64
                  946723
                  It turns out I had not installed the 32bit dependencies.

                  I had run:
                  yum install libXtst libselinux audit-libs cracklib db4 pam libstdc++ zlib ksh -y

                  That command will only install the 64bit versions. The correct command is:
                  yum install libXtst.i686 libselinux.i686 audit-libs.i686 cracklib.i686 db4.i686 pam.i686 libstdc++.i686 zlib.i686 ksh -y

                  The installer ran properly after that, on CentOS 6.3.

                  Best,
                  Pedro