3 Replies Latest reply on Jun 27, 2012 7:26 PM by 946242

    Windows 2003 VM & winlogon.exe error

    Thomas Martin
      Hello,

      I've just migrated a Windows 2003 machine from VMWare to OVM 3.0.3, using OVF export/import.
      I've also installed para-virtualised drivers.

      Now, I get an error after the boot :

      szAppName : winlogon.exe
      szAppVer : 0.0.0.0
      szModName : VMUpgradeAtShutdownWXP.dll
      szModVer : 8.3.7.3827

      And the VM don't shutdown properly, I get a blue screen showing an error about Windows Logon Process (c000021a).

      Does anyone have this problem ?

      Thanks.
      TM
        • 1. Re: Windows 2003 VM & winlogon.exe error
          user639270
          Hi,
          I am having an almost identical issue . After importing a Windows 2003 EE Vmware template in OVA format into Oracle OVM 3.0.3 , the vm would not start up and instantly crash with blue screen . However with fixes in note 754071.1 (and microsoft kb314082) , got the VM to start up . However upon starting the vm there is a winlogon.exe error and when shutting down the VM there is a blue screen STOP 0xC000021A error. The vm machine doesn't stop either , I have to kill it .I also have PV drivers installed.
          I presume it is an issue with OS driver, hardware incompatibility issues from vmware to OVM .
          So far I am having issues with p2v (with SAN disks) and v2v with Oracle VM 3.0.3.

          Let me know if you find a solution.

          Thanks,
          Shahab.
          • 2. Re: Windows 2003 VM & winlogon.exe error
            946242
            If you migrated from VMware, probably you still have the VMtools and some remaining DLLs.

            For this error on winlogon.exe rename VMUpgradeAtShutdownWXP.dll file, to VMUpgradeAtShutdownWXP.OLD or just remove it.

            Your server should be turned off fine now.
            • 3. Re: Windows 2003 VM & winlogon.exe error
              946242
              One more thing, if you try to remove VM tools, it will send an error:
              "Setup Failed to detemine which VM product this virtual machine is running on. Click OK to cancel the installation"

              You will need to follow this steps, read:

              [VMtools: "Setup Failed to detemine which VM product..." |http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/6a441588-24fd-4f39-9cbc-5d028fec7c41]