7 Replies Latest reply: Jun 22, 2012 5:14 PM by petrop RSS

    Asynchronous BPEL 2.0 Issue - Transaction rolled back

    779112
      Hi,

      The Asynchronous BPEL flow is getting rolled back after 5 minutes; How can I extend this from “5 minutes” to “10 minutes”
      Appreciate any help.

      Regards,
      Ebrahim Badusha
        • 1. Re: Asynchronous BPEL 2.0 Issue - Transaction rolled back
          Arik
          Ebrahim,

          Go to weblogic console -> JTA
          change the transaction timout to 600

          Arik
          • 2. Re: Asynchronous BPEL 2.0 Issue - Transaction rolled back
            929418
            Thank you for your time, Arik.

            I couldn't see anything with value "5" or "500" or "5000" in the JTA page.

            Below are the items what I can see in JTA console. Do you know which field needs to be updated?


            Timeout Seconds: 30
            Abandon Timeout Seconds: 86400
            Before Completion Iteration Limit: 10
            Max Transactions: 10000
            Max Unique Name Statistics: 1000
            Checkpoint Interval Seconds: 300
            Forget Heuristics: true

            Unregister Resource Grace Period: 30
            Execute XA Calls In Parallel: true
            Enable Two Phase Commit: true

            Security Interoperability Mode: default

            Completion Timeout: 0
            Maximum Duration of XA Calls: 120000
            Maximum Duration XA Resource Unavailable: 1800000

            Maximum Resource Requests on a Server: 50
            Web Service Transactions Transport Security Mode: SSL
            • 3. Re: Asynchronous BPEL 2.0 Issue - Transaction rolled back
              Arik
              Ok...I will write the complete explanation according to Oracle.

              Please follow the next steps, you should change it in 3 places:

              1. syncMaxWaitTime
              Login into EM
              Expand SOA and right click on "soa-infra" and select: SOA Administration -> BPEL Properties
              Click on "More BPEL Configuration Properties..." link
              Change syncMaxWaitTime value

              2. BPEL EJB's transaction timeout (first shutdown SOA managed server)
              Log into Oracle WebLogic Administration Console.
              Click Deployments.
              Expand soa-infra -> EJBs.
              Following EJBs need to be updated:
              BPELActivityManagerBean
              BPELDeliveryBean
              BPELDispatcherBean
              BPELEngineBean
              BPELFinderBean
              BPELInstanceManagerBean
              BPELProcessManagerBean
              BPELSensorValuesBean
              BPELServerManagerBean
              You can change the parameter in the Configuration tab for the Transaction Timeout setting.
              Click Save.
              Save the Plan.xml to some known location - Ensure no other file is named Plan.xml -.
              Update soa-infra deployment.
              Start SOA Managed Server

              3. Global Transaction Timeout
              Log into Oracle WebLogic Administration Console.
              Click Services -> JTA.
              Change the value of Timeout Seconds (the default is 30).
              Click Save.
              Restart Oracle WebLogic Server

              Keep the following relation between the parameters:
              syncMaxWaitTime < BPEL EJB's transaction timeout < Global Transaction Timeout

              Arik
              • 4. Re: Asynchronous BPEL 2.0 Issue - Transaction rolled back
                929418
                Thank you Arik, It helps
                • 5. Re: Asynchronous BPEL 2.0 Issue - Transaction rolled back
                  Arik
                  Glad to help.
                  Please mark the post as answered....
                  • 7. Re: Asynchronous BPEL 2.0 Issue - Transaction rolled back
                    petrop
                    Hi Arik,

                    In my case, BPEL calls a Web Service and service takes about an hour to complete the job.

                    I following the steps mentioned below.

                    Before making the changes I used to get Timeout error, but now even though I am not getting timeout any error in BPEL EM, transaction still gets rolled back.

                    Only other option I can see is to call the service Asynchronously, but, before that option, just wanted to make sure this is not working.

                    -Petro