This discussion is archived
2 Replies Latest reply: Dec 6, 2012 9:31 AM by Barcellos RSS

ProductLookup not finding product siteId

Barcellos Newbie
Currently Being Moderated
Hi!

I did a import of products using startSQLRepository. In BCC it's all Ok. The products are in the catalog, category and has a related site id. But using ProductLookup to show the product info at product's detail page, the component's debug shows:
** debug   /atg/commerce/catalog/ProductLookup     Find item: id=030497; type=product
** debug   /atg/commerce/catalog/ProductLookup     Item Found: product:030497
** debug   /atg/commerce/catalog/ProductLookup     The item belongs to sites []
** debug   /atg/commerce/catalog/ProductLookup     Item is not part of the correct site.
I already executed CMS a infinite number of times but the debug is still the same. Searching the productId at ProductCatalogOutputConfig shows no catalog and siteId to the referred product. Searching at the databases, Switch A and B, Staging and Publishing doesn't have references on dcs_prd_catalogs and dcs_product_sites to the provided item id but Production database has.

These two tables has references to some products that are showed ok at the product's detail page.

I would appreciate any help.

Thanks in advance.
  • 1. Re: ProductLookup not finding product siteId
    Praveer.Rai Journeyer
    Currently Being Moderated
    Hi ,

    If you are using CompositeProfileRepository , then you need a patch from ATG to resolve your issue.
    There is an issue in atg that LookUp droplets are not able to find items when using compositeprofilerepository.

    You should request the patch using MOS.


    ~ Praveer
  • 2. Re: ProductLookup not finding product siteId
    Barcellos Newbie
    Currently Being Moderated
    Hi

    This problem was solved and was related to a database issue. Some productids started with a numeric value and other started with letter value. This made a logic problem when the AncestorCatalogService searched a range of products to process ( productids > '..." and productids < '...' ). After the ids were normalized (all ids starts with a numeric value now) the problem was solved.

    Thanks!

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points