2 Replies Latest reply: Apr 12, 2012 9:21 AM by 873774 RSS

    runcluvfy.sh pre crsinst fails after 11.2.0.2 install with .oui cannot exe

    873774
      New install 11.2.0.2

      Downloaded from otn:

      zLinux64

      Oracle Database 11g Release 2 (11.2.0.2.0) for zLinux64
                linux.zseries64_11gR2_database_1of2.zip

                linux.zseries64_11gR2_database_2of2.zip



      Oracle Database 11g Release 2 Grid Infrastructure (11.2.0.2.0) for zLinux64
                linux.zseries64_11gR2_grid.zip


      After installing/configuring elinux on two nodes (included oracle_validated package in the install):


      uname -a

      Linux test1.localhost.localdomain 2.6.32-300.10.1.el5uek #1 SMP Wed Feb 22 17:37:40 EST 2012 x86_64 x86_64 x86_64 GNU/Linux


      I did the following:


      unzip linux.zseries64_11gR2_grid.zip


      chown -R oracle:oinstall /install


      su - oracle


      /install/grid/runcluvfy.sh stage -pre crsinst -n test1,test2 -verbose


      And received this error:


      /install/grid/runcluvfy.sh: line 129: /install/grid/install/.oui: cannot execute binary file




      Other things I've tried/noted:


      - I downloaded an older release of the grid infrastructure (11.2.0.1, linux.x64_11gR2_grid.zip) and runcluvy.sh worked fine although the check report
      showed a failure on unixodbc* since the releases didn't match.


      - File is executable (even chmod'd 777)


      - Read one case where a guy had a soft-link to the mount point and got this error, this is not the case.


      - Ran cksum on downloaded file and it matched otn download


      Any suggestions would be greatly appreciated.


      Thanks!