8 Replies Latest reply: Apr 15, 2012 1:22 AM by 930089 RSS

    Slow startup


      I had installed Oracle 11g in windows 7, it is running good but problem is when i start or ON the computer it is taking about 3 minutes to get desktop screen and after that i could not open any applications (like MS word, Adobe reader,etc because it is hanging completely) for 10 minutes after getting desktop. This is really frustrating me every time i put on the computer. In frustration these are the questions firing in my mind....

      Why this is Happening?
      Is my system really working good?
      Oh, this is may be because of oracle as i just installed the previous day?
      Wow, Oracle is really working great, but why it is killing my computer as well as me?
      Did Oracle support my computer or the configuration i have?
      Should i go to the computer service center for tuning my computer performance?
      Do i really want this heavier version of Oracle 11g rather than having older version of Oracle 10g Express edition?
      and more...

      So someone please tell me what will be the issue in it. Before i was using Oracle 10g XE, no issues i had with it. After that i formatted my system and installed the same OS and then Oracle 11g.
      I don't have any other heavier application or any application that start at windows startup. I disabled all small startup programs that i have. Still no use.

      These are the versions and configurations i have...

      Oracle version:
      Personal Oracle Database 11g Release - Production
      PL/SQL Release - Production
      CORE Production
      TNS for 32-bit Windows: Version - Production
      NLSRTL Version - Production

      Operating System:
      Windows 7 Ultimate
      32-bit OS
      1.8GHz Core 2 Duo
      1GB RAM

      This is the main question i want to ask...Is there any option to no auto startup the database along with the OS startup? So that i can start database manually when i want to work on Oracle.

      Please Help!!!
        • 1. Re: Slow startup
          change OS Service for Oracle to MANUAL
          • 2. Re: Slow startup
            ....and open eventvwr to see if theres anything logging in there.
            • 3. Re: Slow startup
              My friend,

              The problem is yor RAM, Need to get at least 3GB for windows 7, else the startup usually will be slow... also you can disable the unwanted applications that start during the startup which will improve your startup time.

              Also, do consider using Paging memeory from your local drive insted of Ram that improves your performance... this can be found in ... Control panel, system settings, advanced settings , performance and there in virtual memeory... search in google if you have doubts....

              • 4. Re: Slow startup
                I agree with V, you just don't have enough memory. However, you might be able to ameliorate some of the problems by setting the [url http://www.orafaq.com/wiki/Memory_target]memory_max lower, or disabling that and using the older manual settings - the details are in the manuals, but you'd be better off just getting more memory.

                Show us the output of this from the sql command line, as sysdba:

                Show parameter mem
                • 5. Re: Slow startup
                  For windows 7 Ultimate also, 1gb RAM is less, let alone running 11.2 on it. Besides making the database startup to be manual, do make the other services like of EM, Listener to be manually started too. Also, as soon as possible, get the RAM upgrade to at least 4gb.

                  • 6. Re: Slow startup
                    Thank you all for your valuable responses.

                    It may be right about RAM i have....but upgrading to 3 or 4 GB will not work presently as i have other plan like bringing new laptop.

                    Besides, how can i change Oracle services to manual?

                    Meanwhile, i'll search for it in this forum or do googling...

                    Once again Thanks
                    • 7. Re: Slow startup
                      Shivananda Rao
                      Besides, how can i change Oracle services to manual?

                      You would find the Oracle Services, stop the service, right click the service and Properties and select the Startup Type to be Manual.

                      Hope this helps and if your issue is resolved consider closing the thread. :)
                      • 8. Re: Slow startup
                        Thank You Shiva