1 Reply Latest reply on Sep 30, 2013 2:31 PM by Saqib Riaz

    Problem configuring inbound - Validation error and ConcurrentModificationEx

      Hallo ,
      I have just started to implement simple Web service call in Oracle Enterprise Gateway.
      I registered web service but I have issue with deployment - got error:
      ERROR 2012/04/16 08:47:58.158 WSFilter(Service Handler for 'ClinicalB2BService')[DEFAULT_PRIMARY_OracleGateway_6.3.1:1977] Problem configuring inbound operation chain filter:
           at com.vordel.circuit.ws.OperationProcessor.doSchemaValidation(OperationProcessor.java:292)

      I think this is because some schemas are not part of wsdl and default service handler is generated with Validation option->Use WSDL schema.
      I tried to delegate the validation to policy->Imported schemas in Resource part and created Start-End policy with "Schema Validation"
      but it didn't help.

      Next I tried to put all schemas in the imported wsdl but got error :
           at org.eclipse.emf.common.util.BasicEList$EIterator.checkModCount(BasicEList.java:1378)
           at org.eclipse.emf.common.util.BasicEList$EIterator.doNext(BasicEList.java:1326)
           at org.eclipse.emf.common.util.BasicEList$EIterator.next(BasicEList.java:1312)
           at com.vordel.wsdl.Operation.getOperationNameAndNamespace(Operation.java:250)
           at com.vordel.wsdl.Operation.<init>(Operation.java:57)
      I deployed the configuration,closed all OEG processes and rebooted the computer but still got java.util.ConcurrentModificationException.

      What is wrong? Can anybody help me on it?

      Thx in advance for your help.