14 Replies Latest reply: Jul 9, 2012 12:59 PM by Hussein Sawwan-Oracle RSS

    adcfgclone.pl fails at 50% on dbtier

    864808
      erp-12.1.3
      db-11.2.0.2
      os- windows 2003R2


      logfile of adcfgclone.pl

      Creating the control file for DEV database ...
      ECHO is off.

      SQL*Plus: Release 11.2.0.2.0 Production on Mon Apr 16 16:07:22 2012

      Copyright (c) 1982, 2010, Oracle. All rights reserved.

      ERROR:
      ORA-12560: TNS:protocol adapter error


      Instance deleted.
      Instance created.
      DIM-00019: create service error
      O/S-Error: (OS 2) The system cannot find the file specified.

      SQL*Plus: Release 11.2.0.2.0 Production on Mon Apr 16 16:08:04 2012

      Copyright (c) 1982, 2010, Oracle. All rights reserved.

      ERROR:
      ORA-12560: TNS:protocol adapter error


      ORA-12560: TNS:protocol adapter error
      ERROR:
      ORA-12560: TNS:protocol adapter error


      ORA-12560: TNS:protocol adapter error
      SP2-0640: Not connected
      SP2-0640: Not connected
      SP2-0640: Not connected
      SP2-0640: Not connected
      ORA-12560: TNS:protocol adapter error
      ERROR:
      ORA-12560: TNS:protocol adapter error


      ORA-12560: TNS:protocol adapter error
      SP2-0640: Not connected
      SP2-0641: "EXECUTE" requires connection to server
      ORA-12560: TNS:protocol adapter error
      ERROR:
      ORA-12560: TNS:protocol adapter error


      ORA-12560: TNS:protocol adapter error
      SP2-0640: Not connected
      SP2-0640: Not connected
      SP2-0640: Not connected
      SP2-0640: Not connected
      SP2-0640: Not connected
      ECHO is off.
      Checking for errors ...
      ECHO is off.
      The database has not been successfully created. Shutting down the instance...

      SQL*Plus: Release 11.2.0.2.0 Production on Mon Apr 16 16:08:14 2012

      Copyright (c) 1982, 2010, Oracle. All rights reserved.

      ERROR:
      ORA-12560: TNS:protocol adapter error


      adcrdb.cmd exiting with status 1

      .end std out.

      .end err out.


      ---------------------------------------------------------------
      ADX Database Utility
      ---------------------------------------------------------------

      getConnectionUsingAppsJDBCConnector() -->
      APPS_JDBC_URL='null'
      Trying to get connection using SID based connect descriptor
      getConnection() -->
      sDbHost : appsuser
      sDbDomain : usa.com
      sDbPort : 1526
      sDbSid : DEV
      sDbUser : apps
      Trying to connect using SID...
      getConnectionUsingSID() -->
      JDBC URL: jdbc:oracle:thin:@appsuser.usa.com:1526:DEV
      Exception occurred: java.sql.SQLException: Listener refused the connection with the following error:
      ORA-12518, TNS:listener could not hand off client connection

      Trying to connect using SID as ServiceName
      getConnectionUsingServiceName() -->
      JDBC URL: jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=appsuser.usa.com)(PORT=1526))(CONNECT_DATA=(SERVICE_NAME=DEV)))
      Exception occurred: java.sql.SQLException: Listener refused the connection with the following error:
      ORA-12518, TNS:listener could not hand off client connection

      Trying to connect using SID as ServiceName.DomainName
      getConnectionUsingServiceName() -->
      JDBC URL: jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=appsuser.usa.com)(PORT=1526))(CONNECT_DATA=(SERVICE_NAME=appsuser.usa.com)))
      Exception occurred: java.sql.SQLException: Listener refused the connection with the following error:
      ORA-12514, TNS:listener does not currently know of service requested in connect descriptor

      Connection could not be obtained; returning null

      -------------------ADX Database Utility Finished---------------

      RC-00118: Error occurred during creation of database
      Raised by oracle.apps.ad.clone.ApplyDatabase


      StackTrace:
      java.lang.Exception: Control file creation failed
           at oracle.apps.ad.clone.ApplyDatabase.doConf(ApplyDatabase.java:635)
           at oracle.apps.ad.clone.ApplyDatabase.doApply(ApplyDatabase.java:473)
           at oracle.apps.ad.clone.ApplyDatabase.<init>(ApplyDatabase.java:366)
           at oracle.apps.ad.clone.ApplyDBTier.<init>(ApplyDBTier.java:110)
           at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
           at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
           at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
           at java.lang.reflect.Constructor.newInstance(Unknown Source)
           at oracle.apps.ad.clone.util.CloneProcessor.run(CloneProcessor.java:67)
           at java.lang.Thread.run(Unknown Source)

      Netservicehandler.log

           Classpath : ;D:\oracle\devdb11g\11.2.0\jdbc\lib\ojdbc5.jar;D:\oracle\devdb11g\11.2.0\appsutil\java\xmlparserv2.jar;D:\oracle\devdb11g\11.2.0\appsutil\java;D:\oracle\devdb11g\11.2.0\jlib\netcfg.jar;D:\oracle\devdb11g\11.2.0\jlib\ldapjclnt11.jar

      ===============================================================================
      NetServiceHandler 120.19.12010000.6 started for appsuser at Mon Apr 16 15:51:55 GMT+03:00 2012
      ===============================================================================

      [ Context Information ]
      Host : appsuser
      Domain : usa.com
      Out Dir : D:\oracle\devdb11g\11.2.0/appsutil/out/DEV_appsuser/04161551
      Tier Type : DATABASE TIER
      Getting connection...

      ---------------------------------------------------------------
      ADX Database Utility
      ---------------------------------------------------------------

      getConnectionUsingAppsJDBCConnector() -->
      APPS_JDBC_URL='null'
      Trying to get connection using SID based connect descriptor
      getConnection() -->
      sDbHost : appsuser
      sDbDomain : usa.com
      sDbPort : 1526
      sDbSid : DEV
      sDbUser : apps
      Trying to connect using SID...
      getConnectionUsingSID() -->
      JDBC URL: jdbc:oracle:thin:@appsuser.usa.com:1526:DEV
      Exception occurred: java.sql.SQLException: IO Error: The Network Adapter could not establish the connection
      Trying to connect using SID as ServiceName
      getConnectionUsingServiceName() -->
      JDBC URL: jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=appsuser.usa.com)(PORT=1526))(CONNECT_DATA=(SERVICE_NAME=DEV)))
      Exception occurred: java.sql.SQLException: IO Error: The Network Adapter could not establish the connection
      Trying to connect using SID as ServiceName.DomainName
      getConnectionUsingServiceName() -->
      JDBC URL: jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=appsuser.usa.com)(PORT=1526))(CONNECT_DATA=(SERVICE_NAME=DEV.usa.com)))
      Exception occurred: java.sql.SQLException: IO Error: The Network Adapter could not establish the connection
      Connection could not be obtained; returning null

      -------------------ADX Database Utility Finished---------------

      Could not get connection to the database.
      Exiting with status 100 to instantiate the tnsnames.ora template
      Creation of Directory - D:\oracle\devdb11g\11.2.0\NETWORK\ADMIN\DEV_appsuser Succeeded.
      instantiate file:
      source : D:\oracle\devdb11g\11.2.0\appsutil\template\ad8itns.ora
      dest : D:\oracle\devdb11g\11.2.0\network\admin\DEV_appsuser\tnsnames.ora


      AutoConfig is exiting with status 0

      instantiate file:
      source : D:\oracle\devdb11g\11.2.0\appsutil\template\ad8ilsnr.ora
      dest : D:\oracle\devdb11g\11.2.0\network\admin\DEV_appsuser\listener.ora


      AutoConfig is exiting with status 0


      adgentns.pl exiting with status 0
      ERRORCODE = 0 ERRORCODE_END
           Classpath : ;D:\oracle\devdb11g\11.2.0\jdbc\lib\ojdbc5.jar;D:\oracle\devdb11g\11.2.0\appsutil\java\xmlparserv2.jar;D:\oracle\devdb11g\11.2.0\appsutil\java;D:\oracle\devdb11g\11.2.0\jlib\netcfg.jar;D:\oracle\devdb11g\11.2.0\jlib\ldapjclnt11.jar

      ===============================================================================
      NetServiceHandler 120.19.12010000.6 started for appsuser at Mon Apr 16 16:06:30 GMT+03:00 2012
      ===============================================================================

      [ Context Information ]
      Host : appsuser
      Domain : usa.com
      Out Dir : D:\oracle\devdb11g\11.2.0/appsutil/out/DEV_appsuser/04161606
      Tier Type : DATABASE TIER
      Getting connection...

      ---------------------------------------------------------------
      ADX Database Utility
      ---------------------------------------------------------------

      getConnectionUsingAppsJDBCConnector() -->
      APPS_JDBC_URL='null'
      Trying to get connection using SID based connect descriptor
      getConnection() -->
      sDbHost : appsuser
      sDbDomain : usa.com
      sDbPort : 1526
      sDbSid : DEV
      sDbUser : apps
      Trying to connect using SID...
      getConnectionUsingSID() -->
      JDBC URL: jdbc:oracle:thin:@appsuser.usa.com:1526:DEV
      Exception occurred: java.sql.SQLException: IO Error: The Network Adapter could not establish the connection
      Trying to connect using SID as ServiceName
      getConnectionUsingServiceName() -->
      JDBC URL: jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=appsuser.usa.com)(PORT=1526))(CONNECT_DATA=(SERVICE_NAME=DEV)))
      Exception occurred: java.sql.SQLException: IO Error: The Network Adapter could not establish the connection
      Trying to connect using SID as ServiceName.DomainName
      getConnectionUsingServiceName() -->
      JDBC URL: jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=appsuser.usa.com)(PORT=1526))(CONNECT_DATA=(SERVICE_NAME=DEV.usa.com)))
      Exception occurred: java.sql.SQLException: IO Error: The Network Adapter could not establish the connection
      Connection could not be obtained; returning null

      -------------------ADX Database Utility Finished---------------

      Could not get connection to the database.
      Exiting with status 100 to instantiate the tnsnames.ora template
      instantiate file:
      source : D:\oracle\devdb11g\11.2.0\appsutil\template\ad8itns.ora
      dest : D:\oracle\devdb11g\11.2.0\network\admin\DEV_appsuser\tnsnames.ora


      AutoConfig is exiting with status 0

      instantiate file:
      source : D:\oracle\devdb11g\11.2.0\appsutil\template\ad8ilsnr.ora
      dest : D:\oracle\devdb11g\11.2.0\network\admin\DEV_appsuser\listener.ora


      AutoConfig is exiting with status 0


      adgentns.pl exiting with status 0
      ERRORCODE = 0 ERRORCODE_END


      i have followed the documents mention in related post but no use still the issue exist


      Please suggest


      SHariN is CAring! :(
        • 1. Re: adcfgclone.pl fails at 50% on dbtier
          Hussein Sawwan-Oracle
          DIM-00019: create service error
          O/S-Error: (OS 2) The system cannot find the file specified.
          Please see these docs.

          DIM-00019 ERROR WHILE CREATING A SERVICE USING ORADIM [ID 110758.1]
          Database creation using DBCA on WIN 2003 PDC fails with DIM-19 [ID 271569.1]
          DBCA Fails With ORA-12560 (OS 1376) On Windows AD Controller [ID 1396185.1]

          Thanks,
          Hussein
          • 2. Re: adcfgclone.pl fails at 50% on dbtier
            864808
            thanks hussein for reply

            the service has been created but it doesnt start
            when i try to start is manually
            it says

            Cannot find the path specified oraceServiceDEV
            • 3. Re: adcfgclone.pl fails at 50% on dbtier
              Hussein Sawwan-Oracle
              ApPsMasTi wrote:
              thanks hussein for reply

              the service has been created but it doesnt start
              when i try to start is manually
              it says

              Cannot find the path specified oraceServiceDEV
              This indicates that the service was not created (most probably in the registry) properly. Please make sure that the OS user has enough privileges (admin) to create services and write to the registry as mentioned in the docs.

              Thanks,
              Hussein
              • 4. Re: adcfgclone.pl fails at 50% on dbtier
                864808
                yes the user is member of administrator group and it hold admin rights
                :(
                • 5. Re: adcfgclone.pl fails at 50% on dbtier
                  Hussein Sawwan-Oracle
                  In this case, please check the database alert_<SID>.log for details about the error and find out why the database was not created successfully.

                  Thanks,
                  Hussein
                  • 6. Re: adcfgclone.pl fails at 50% on dbtier
                    864808
                    no alert log file found
                    i have checked in all destination but i did not found
                    :(
                    • 7. Re: adcfgclone.pl fails at 50% on dbtier
                      864808
                      adcfgclone.pl logfile

                      #############################################################
                      Started ApplyDBTechStack at Wed Apr 18 12:25:12 GMT+03:00 2012
                      Version:
                           ApplyDBTechStack.java     :      120.22.12010000.4
                      #############################################################
                      Executing runInstallDriver...
                      Started unzipping files...
                      Completed runInstallDriver.


                      Executing home registration for s_db_oh...


                      LSNRCTL for 32-bit Windows: Version 11.2.0.2.0 - Production on 18-APR-2012 12:25:48

                      Copyright (c) 1991, 2010, Oracle. All rights reserved.

                      Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=appsusa.usa.com)(PORT=1526)))
                      TNS-12541: TNS:no listener
                      TNS-12560: TNS:protocol adapter error
                      TNS-00511: No listener
                      32-bit Windows Error: 61: Unknown error

                      LSNRCTL for 32-bit Windows: Version 11.2.0.2.0 - Production on 18-APR-2012 12:25:49

                      Copyright (c) 1991, 2010, Oracle. All rights reserved.

                      Starting tnslsnr: please wait...

                      Failed to open service <OracleTNSListenerDEV>, error 1060.
                      TNSLSNR for 32-bit Windows: Version 11.2.0.2.0 - Production
                      Message 459 not found; No message file for product=NETWORK, facility=NL
                      Message 279 not found; No message file for product=NETWORK, facility=NL
                      Message 1073 not found; No message file for product=NETWORK, facility=TNS
                      Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=appsusa.usa.com)(PORT=1526)))
                      STATUS of the LISTENER
                      ------------------------
                      Alias DEV
                      Version TNSLSNR for 32-bit Windows: Version 11.2.0.2.0 - Production
                      Start Date 18-APR-2012 12:25:57
                      Uptime 0 days 0 hr. 0 min. 5 sec
                      Trace Level off
                      Security ON: Local OS Authentication
                      SNMP OFF
                      Listener Parameter File D:\erpclone\oracle\devdb11g\11.2.0\network\admin\DEV_appsusa\listener.ora
                      Listener Log File D:\erpclone\oracle\devdb11g\11.2.0\admin\DEV_appsusa\diag\tnslsnr\appsusa\dev\alert\log.xml
                      Listening Endpoints Summary...
                      (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=appsusa.usa.com)(PORT=1526)))
                      Services Summary...
                      Service "DEV" has 1 instance(s).
                      Instance "DEV", status UNKNOWN, has 1 handler(s) for this service...
                      The command completed successfully
                      addlnctl.cmd exiting with status 0
                      [SC] OpenService FAILED 1060:

                      The specified service does not exist as an installed service.

                      adsvdlsn.cmd exiting with status 0
                      ERRORCODE = 0 ERRORCODE_END
                      .end std out.

                      .end err out.
                      ****************************************************


                      AutoConfig Setup Phase
                      Running Setup Process 5 of 7 for AppsUtil
                      Executing script in InstantiateFile:
                      D:\erpclone\oracle\devdb11g\11.2.0\perl\bin\perl.exe -I D:\erpclone\oracle\devdb11g\11.2.0\perl\lib -I D:\erpclone\oracle\devdb11g\11.2.0\perl\site\lib -I D:\erpclone\oracle\devdb11g\11.2.0\appsutil\perl D:\erpclone\oracle\devdb11g\11.2.0\appsutil\bin\txkDBSecUserAuditActionBanner.pl

                      script returned:
                      ****************************************************


                      Script Name : txkDBSecUserAuditActionBanner.pl
                      Banner file D:\erpclone\oracle\devdb11g\11.2.0\appsutil\template\txkDBSecUserAuditActionBanner.txt already exists
                      Successfully Completed the script
                      ERRORCODE = 0 ERRORCODE_END
                      .end std out.

                      .end err out.
                      ****************************************************


                      AutoConfig Setup Phase
                      Running Setup Process 6 of 7 for AppsUtil
                      Executing script in InstantiateFile:
                      D:\erpclone\oracle\devdb11g\11.2.0\appsutil\install\DEV_appsusa\afmkinit_inst.cmd

                      script returned:
                      ****************************************************
                      Wed 04/18/2012
                      12:26 PM
                      "afmkinit_inst.cmd exiting with status 0"
                      ERRORCODE = 0 ERRORCODE_END
                      .end std out.

                      .end err out.
                      ****************************************************


                      AutoConfig Setup Phase
                      Running Setup Process 7 of 7 for AppsUtil
                      Executing script in InstantiateFile:
                      D:\erpclone\oracle\devdb11g\11.2.0\appsutil\install\DEV_appsusa\afmkinit.cmd

                      script returned:
                      ****************************************************
                      Wed 04/18/2012
                      12:26 PM
                      1 file(s) copied.
                      1 file(s) copied.
                      1 file(s) copied.
                      "afmkinit.cmd exiting with status 0"
                      ERRORCODE = 0 ERRORCODE_END
                      .end std out.

                      .end err out.
                      ****************************************************


                      Skipping Profile Phase
                      Skipping Apply Phase
                      Completed runAutoConfig...


                      ApplyDBTechStack Completed Successfully.



                      any one can help me on this
                      i got the some issue on new machine
                      • 8. Re: adcfgclone.pl fails at 50% on dbtier
                        Hussein Sawwan-Oracle
                        Do you have proper entry in the hosts file?

                        Were the database and the database listener created successfully?

                        Thanks,
                        Hussein
                        • 9. Re: adcfgclone.pl fails at 50% on dbtier
                          864808
                          yes i have

                          ipaddress appsusa.usa.com appsusa
                          im able to ping it successfully
                          • 10. Re: adcfgclone.pl fails at 50% on dbtier
                            Hussein Sawwan-Oracle
                            [SC] OpenService FAILED 1060:
                            Windows Autoconifg on dbTier fails on adcrobj.cmd & adsvdlsn.cmd [ID 356927.1]
                            adsvdlsn.cmd exiting with status 1007 [ID 785847.1]

                            Thanks,
                            Hussein
                            • 11. Re: adcfgclone.pl fails at 50% on dbtier
                              864808
                              the issue has been solve by applying a patch on source rdbms oracle home      ORACLE 11G 11.2.0.2 PATCH 13 BUG FOR WINDOWS 32BIT Patch 13247522

                              thanks hussein


                              APpSMaSTi
                              SHARIng Is CarinG
                              • 12. Re: adcfgclone.pl fails at 50% on dbtier
                                Hussein Sawwan-Oracle
                                Thanks for the update.

                                Hussein
                                • 13. Re: adcfgclone.pl fails at 50% on dbtier
                                  user13257141
                                  Hi,

                                  We are also facing similar issue while cloning r12.1.3 in win 2003 server, but our database version is 11.2.0.3. Is the patch required for this version also?
                                  Kindly help us out.

                                  Thanks,
                                  Srini
                                  • 14. Re: adcfgclone.pl fails at 50% on dbtier
                                    Hussein Sawwan-Oracle
                                    We are also facing similar issue while cloning r12.1.3 in win 2003 server, but our database version is 11.2.0.3. Is the patch required for this version also?
                                    Kindly help us out.
                                    This patch is only applicable to 11.2.0.2

                                    If none of the docs in this thread helps, then please log a SR.

                                    Thanks,
                                    Hussein