1 Reply Latest reply: Apr 19, 2012 5:14 AM by Sebastian Solbach -Dba Community-Oracle RSS

    rpm -Uvh error

    915922
      Hi experts

      OS
      --------
      Linux dhcp-152-144-220-9 2.6.18-274.el5 #1 SMP Mon Jul 25 13:17:49 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

      http://www.oracle.com/technetwork/server-storage/linux/downloads/rhel5-084877.html

      Drivers for kernel 2.6.18-274.el5
      ----------------------------------------
      oracleasm-2.6.18-274.el5-2.0.5-1.el5.x86_64.rpm
      oracleasm-2.6.18-274.el5debug-2.0.5-1.el5.x86_64.rpm
      oracleasm-2.6.18-274.el5-debuginfo-2.0.5-1.el5.x86_64.rpm
      oracleasm-2.6.18-274.el5xen-2.0.5-1.el5.x86_64.rpm
      oracleasm-support-2.1.3-1.el5.i386.rpm

      [root@dhcp-152-144-220-9 asmlib]# rpm -qa | grep oracleasm
      oracleasm-2.6.18-274.el5-debuginfo-2.0.5-1.el5
      oracleasm-support-2.1.3-1.el5
      oracleasm-2.6.18-274.el5-2.0.5-1.el5

      [root@dhcp-152-144-220-9 asmlib]# rpm -Uvh oracleasm-2.6.18-274.el5xen-2.0.5-1.el5.x86_64.rpm
      warning: oracleasm-2.6.18-274.el5xen-2.0.5-1.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 1e5e0159
      error: Failed dependencies:
      kernel-xen = 2.6.18-274.el5 is needed by oracleasm-2.6.18-274.el5xen-2.0.5-1.el5.x86_64


      [root@dhcp-152-144-220-9 asmlib]# rpm -Uvh oracleasm-2.6.18-274.el5debug-2.0.5-1.el5.x86_64.rpm
      warning: oracleasm-2.6.18-274.el5debug-2.0.5-1.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 1e5e0159
      error: Failed dependencies:
      kernel-debug = 2.6.18-274.el5 is needed by oracleasm-2.6.18-274.el5debug-2.0.5-1.el5.x86_64

      What lib is missing for above error

      thanx
        • 1. Re: rpm -Uvh error
          Sebastian Solbach -Dba Community-Oracle
          Hi,

          the package you are missing to install these are the kernels.
          However you only need oracleasm which fits your kernel (uname -a).

          So you cannot install the debug/xen oracleasm if you don't use the debug kernel resp. the xen kernel.

          So actually from these packages you are fine, but you are missing another package that asmlib will work:
          The

          oracleasmlib.i386

          package.

          Regards
          Sebastian