4 Replies Latest reply on Jan 27, 2013 11:16 PM by 732311

    Problem while reconfiguring OIM 11g with existing Database

    Rahul Shah
      Hello,
      I had some issues with my OIM 11g instance, so i reconfigured it by deleting user_projects folder,before deleting i took backup of config folder as i wanted to
      configure with existing database.
      Following steps were performed for reconfiguring OIM11g:-
      1)Ran config.sh from <Middleware>/Oracle_IDM1/common/bin
      2) Copied .xldatabasekey file to newly created domain
      3)Ran config.sh from <Middleware>/Oracle_IDM1/bin

      Then tried to start AdminServer, it showed status as running but with errors like
      java.lang.NoClassDefFoundError: Could not initialize class oracle.dfw.impl.common.TempFileManager
      at oracle.dfw.spi.portable.PortableDiagnosticsFrameworkProvider.init(PortableDiagnosticsFrameworkProvider.java:120)

      Then tried to start OIM server , it showed status as running but with error as
      oracle.iam.platform.utils.OIMAppInitializationException:
      OIM application intialization failed because of the following reasons:
      Password for .xldatabasekey is not seeded in CSF.

      Then i tried to cofigure domain again & this time i didnt select Oracle Identity Manager from Select domain source & checked AdminServer & it was running without any errors, but when i select Oracle Identity Manager from Select domain source then i get above problems.

      Can anyone provide pointers about how to resolve this issue .

      Thank-You
      Rahul Shah
        • 1. Re: Problem while reconfiguring OIM 11g with existing Database
          idm731
          Refer to the following metalink doc:

          "oim-config.xml was not found in MDS Repository" Error While Starting the OIM Server of OIM 11g Version. [ID 1253864.1]
          • 2. Re: Problem while reconfiguring OIM 11g with existing Database
            Rahul Shah
            Issue resolved by
            1)deleting contents from/tmp folder
            2)ran ./config.sh from <Middleware>\Oracle_IDM\common\bin
            3)Copied .xldatabasekey to newly created domain /OIM11g/Oracle/Middleware/user_projects/domains/base_domain/config/fmwconfig/
            4)Started weblogic server
            5)Ran ./config.sh from <Middleware>\Oracle_IDM\bin
            6)Copied cwallet.so,default-keystore.jks & xlserver.cert in /OIM11g/Oracle/Middleware/user_projects/domains/base_domain/config/fmwconfig/
            7)Restarted weblogic server, OIM server & i can see OIM Admin console.

            But could not login to xelsysadm & also tried with other users but it didnt work & gives following error
            <Error> <OIM Authenticator> <BEA-000000> <Authentication of user xelsysadm failed because of invalid password>

            Thanks
            Rahul Shah
            • 3. Re: Problem while reconfiguring OIM 11g with existing Database
              idm731
              Open the OIM USR table and copy the password of any user who's password is known to you and paste it in the password field of xelsysadm user. Now try to login with the user xelsysadm and the password you justed copy pasted.
              • 4. Re: Problem while reconfiguring OIM 11g with existing Database
                732311
                Dear Rahul,
                I got the same errors:
                ./admin/IDMDomain/mserver/IDMDomain/servers/wls_oim1/logs/wls_oim1.log
                
                ####<Jan 27, 2013 10:58:09 PM CET> <Error> <Deployer> <server02> <wls_oim1> <[ACTIVE] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <aa66ef4907f1903f:4c6a3b0:13c7e03232f:-8000-0000000000000003> <1359323889050> <BEA-149205> <Failed to initialize the application 'oim [Version=11.1.1.3.0]' due to error oracle.iam.platform.utils.OIMAppInitializationException:
                OIM application intialization failed because of the following reasons:
                oim-config.xml was not found in MDS Repository.
                .
                oracle.iam.platform.utils.OIMAppInitializationException:
                OIM application intialization failed because of the following reasons:
                oim-config.xml was not found in MDS Repository.
                could you explain, how did you sort out it, please? For example point 2 did you create one more domain?
                Best regards,
                Lain