7 Replies Latest reply: Feb 14, 2013 7:31 AM by oracledigger RSS

    AIA Foundation Pack installation - Failed

    Vikash Kumar
      I have installed Oracle SOA suite 11.1.1.5 successfully. On top of that, I wanted to install AIA 2.5. (I am new to AIA)

      Also, while installing AIA foundation pack, I was able to complete till 10th step(i.e. installation progress). But, in 11th step(Configuration progress), Deploy Application Configuration is getting failed. While checking into the log file at "C:\Program Files\Oracle\Inventory\logs\" location, I found the below error in oraInstall2012-04-21_06-59-58PM.err file:


      java.io.FileNotFoundException: C:\Users\vikmaar\AppData\Local\Temp\OraInstall2012-04-21_06-59-58PM\ext\jlib\WindowsFolders.jar (The system cannot find the file specified)
           at java.util.zip.ZipFile.open(Native Method)
           at java.util.zip.ZipFile.<init>(ZipFile.java:127)
           at java.util.jar.JarFile.<init>(JarFile.java:135)
           at java.util.jar.JarFile.<init>(JarFile.java:99)
           at oracle.as.install.engine.modules.util.shortcututil.ShortcutUtilities.extractNativeLibToBootstrapDir(ShortcutUtilities.java:890)
           at oracle.as.install.engine.modules.util.shortcututil.ShortcutUtilities.processShortcutList(ShortcutUtilities.java:206)
           at oracle.as.install.engine.modules.util.installaction.EngineGenericInstallActions.modifyCommonHomeShortcut(EngineGenericInstallActions.java:395)
           at oracle.as.install.engine.modules.util.installaction.EngineGenericInstallActions.executeAfterCopy(EngineGenericInstallActions.java:174)
           at oracle.as.install.engine.modules.util.installaction.InstallActionProviderUtility.invokeExecuteAfterCopy(InstallActionProviderUtility.java:89)
           at oracle.as.install.engine.modules.presentation.ui.common.wizard.ModifiedDWizard.executeEvent(ModifiedDWizard.java:2948)
           at oracle.as.install.engine.modules.presentation.PresentationModule.processModuleEvent(PresentationModule.java:655)
           at oracle.as.install.engine.modules.util.PartnerModuleImpl.processEvent(PartnerModuleImpl.java:118)
           at oracle.as.install.engine.InstallEngine.notifyListeners(InstallEngine.java:626)
           at oracle.as.install.engine.InstallEngine.processEvent(InstallEngine.java:584)
           at oracle.as.install.engine.modules.util.PartnerModuleImpl.notifyAllEventListenersHelper(PartnerModuleImpl.java:227)
           at oracle.as.install.engine.modules.util.PartnerModuleImpl.notifyListeners(PartnerModuleImpl.java:158)
           at oracle.as.install.engine.modules.install.InstallModule.onSuccess(InstallModule.java:478)
           at oracle.as.install.engine.modules.install.action.InstallManager.notifySuccess(InstallManager.java:321)
           at oracle.as.install.engine.modules.install.command.InstallSuccessCommand.execute(InstallSuccessCommand.java:42)
           at oracle.as.install.engine.modules.install.action.InstallManager.onInstallEvent(InstallManager.java:333)
           at oracle.as.install.engine.modules.install.action.AbstractOUIHandler.fireInstallEvent(AbstractOUIHandler.java:147)
           at oracle.as.install.engine.modules.install.action.OUIInstaller.succeed(OUIInstaller.java:542)
           at oracle.as.install.engine.modules.install.action.OUIInstaller.start(OUIInstaller.java:480)
           at oracle.as.install.engine.modules.install.action.InstallManager.launchOUI(InstallManager.java:211)
           at oracle.as.install.engine.modules.install.InstallModule.launchOUI(InstallModule.java:155)
           at oracle.as.install.engine.modules.install.InstallModule$1.run(InstallModule.java:246)
      Apr 21, 2012 7:39:44 PM oracle.as.install.soawl.aiaconfig.actions.AIAConfigAction getResponse
      INFO: User Selected ABORT
      Apr 21, 2012 7:55:23 PM oracle.as.install.soawl.aiaconfig.actions.AIAConfigAction getResponse
      INFO: User Selected CONTINUE


      And the another file with extension as .out is having below logs:

      [exec]
      [exec] Initializing WebLogic Scripting Tool (WLST) ...
      [exec]
      [exec] Welcome to WebLogic Server Administration Scripting Shell
      [exec]
      [exec] Type help() for help on available commands
      [exec]
      [exec] Connecting to t3://localhost:7001 with userid weblogic ...
      [exec] Successfully connected to Admin Server 'AdminServer' that belongs to domain 'base_domain'.
      [exec]
      [exec] Warning: An insecure protocol was used to connect to the
      [exec] server. To ensure on-the-wire security, the SSL port or
      [exec] Admin port should be used instead.
      [exec]
      [exec] AdminServer
      [exec] Location changed to domainRuntime tree. This is a read-only tree with DomainMBean as the root.
      [exec] For more help, use help(domainRuntime)
      [exec]
      [exec] Metadata transfer operation started
      [exec] Uploading metadata to server . .
      [exec] Importing metadata into repository . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
      [exec] Metadata tranfer operation failed
      [exec]
      [exec] This Exception occurred at .
      [exec] javax.management.MBeanException:
      [exec] MDS-00001: exception in Metadata Services layer
      [exec] MDS-00522: failure to save document /apps/AIAMetaData/AIAComponents/EnterpriseObjectLibrary/Industry/Utilities/EBO/EngineeringChangeOrder/V1/EngineeringChangeOrderEBM.xsd to the metadata repository
      [exec] ORA-01654: unable to extend index DEV_MDS.MDS_ATTRIBUTES_U2 by 1024 in tablespace DEV_MDS
      [exec]
      [exec] ORA-01654: unable to extend index DEV_MDS.MDS_ATTRIBUTES_U2 by 1024 in tablespace DEV_MDS
      [exec]


      Please let me know if we have any solution to resolve this.

      Thanks in advance,
      Vikas
        • 1. Re: AIA Foundation Pack installation - Failed
          Gerhard Drasch-Oracle
          Your database has an issue:  

          [exec] ORA-01654: unable to extend index DEV_MDS.MDS_ATTRIBUTES_U2 by 1024 in tablespace DEV_MDS

          Make sure your tablespaces are properly sized an then try again.

          Gerhard
          • 2. Re: AIA Foundation Pack installation - Failed
            Vikash Kumar
            Thanks much Gerhard !!!

            Could you please let me know how can we do that. I just followed the steps given in the guide but not able to make out how we can re-size the table space.

            Not sure if my Oracle XE is having an issue because before installing Oracle SOA, we need to set the processes to 300 or more (I did with 700 initially). Is it something to be done with "increasing the processes" or Oracle XE has to be replaced with Oracle 10g/11g database(if XE doesn't support for AIA)?

            Waiting for your response on this :-) ...
            • 3. Re: AIA Foundation Pack installation - Failed
              Gerhard Drasch-Oracle
              This has nothing to do with database processes. This purely a matter of the database running out of space in the tablespace with name DEV_MDS.

              Check the Oracle database documentation on how to alter tablespaces / increase data files: http://docs.oracle.com/cd/B19306_01/server.102/b14231/dfiles.htm#i1006333

              Gerhard
              • 4. Re: AIA Foundation Pack installation - Failed
                Vikash Kumar
                Thanks a lot Gerhard. I did as you said and I believe I have been able to fix the issue but while end of "Deploy Application Configurations" build gets failed. Log says:


                *************************************************************************************************************************
                [wlst] Saving all your changes ...
                [wlst] Saved all your changes successfully.
                [wlst] Saving all your changes ...
                [wlst] Saved all your changes successfully.
                [wlst] No stack trace available.
                [wlst] Activating all your changes, this may take a while ...
                [wlst] The edit lock associated with this edit session is released
                [wlst] once the activation is completed.
                [wlst] Traceback (innermost last):
                [wlst] File "C:\OracleFusion\Middleware\AIAPSHOME\Infrastructure\Install\AID\lib\py\deployApplication.py", line 49, in ?
                [wlst] File "<iostream>", line 376, in activate
                [wlst] File "<iostream>", line 1848, in raiseWLSTException
                [wlst] WLSTException: Error occured while performing activate : Error while Activating changes. : [1] The ra.xml <connection-interface> class 'oracle.tip.adapter.apps.IAppsConnection' was not found in the resource adapter archive/application.
                [wlst] [2] The ra.xml <connection-impl-class> class 'oracle.tip.adapter.apps.AppsConnection' was not found in the resource adapter archive/application.
                [wlst] [3] The ra.xml <managedconnectionfactory-class> class 'oracle.tip.adapter.apps.AppsManagedConnectionFactory' was not found in the resource adapter archive/application.
                [wlst] [4] The ra.xml <connectionfactory-impl-class> class 'oracle.tip.adapter.apps.AppsConnectionFactory' was not found in the resource adapter archive/application.
                [wlst] Use dumpStack() to view the full stacktrace
                [wlst]
                [wlst] Exception in thread "main" java.lang.IllegalStateException: Traceback (innermost last):
                [wlst] File "C:\OracleFusion\Middleware\AIAPSHOME\Infrastructure\Install\AID\lib\py\deployApplication.py", line 49, in ?
                [wlst] File "<iostream>", line 376, in activate
                [wlst] File "<iostream>", line 1848, in raiseWLSTException
                [wlst] WLSTException: Error occured while performing activate : Error while Activating changes. : [1] The ra.xml <connection-interface> class 'oracle.tip.adapter.apps.IAppsConnection' was not found in the resource adapter archive/application.
                [wlst] [2] The ra.xml <connection-impl-class> class 'oracle.tip.adapter.apps.AppsConnection' was not found in the resource adapter archive/application.
                [wlst] [3] The ra.xml <managedconnectionfactory-class> class 'oracle.tip.adapter.apps.AppsManagedConnectionFactory' was not found in the resource adapter archive/application.
                [wlst] [4] The ra.xml <connectionfactory-impl-class> class 'oracle.tip.adapter.apps.AppsConnectionFactory' was not found in the resource adapter archive/application.
                [wlst] Use dumpStack() to view the full stacktrace
                [wlst]
                [wlst]      at weblogic.management.scripting.WLSTInterpreterInvoker.printError(WLSTInterpreterInvoker.java:110)
                [wlst]      at weblogic.management.scripting.WLSTInterpreterInvoker.executePyScript(WLSTInterpreterInvoker.java:103)
                [wlst]      at weblogic.management.scripting.WLSTInterpreterInvoker.main(WLSTInterpreterInvoker.java:27)
                [wlst] <Apr 24, 2012 1:28:37 AM IST> <Warning> <JNDI> <BEA-050001> <WLContext.close() was called in a different thread than the one in which it was created.>

                BUILD FAILED
                C:\OracleFusion\Middleware\AIAPSHOME\Infrastructure\Install\AID\AIAExecuteDriver.xml:221: The following error occurred while executing this line:
                C:\OracleFusion\Middleware\AIAPSHOME\Infrastructure\Install\AID\AIAExecuteDriver.xml:64: The following error occurred while executing this line:
                C:\OracleFusion\Middleware\AIAPSHOME\aia_instances\INSTAIA\tmp\AIDExecuteDP_temp_218243274.xml:179: The following error occurred while executing this line:
                C:\OracleFusion\Middleware\AIAPSHOME\Infrastructure\Install\AID\lib\AIDDeploymentLibraryTasks.xml:107: Java returned: 1

                Total time: 25 minutes 40 seconds
                'choice' is not recognized as an internal or external command,
                operable program or batch file.
                Deployment Command Return Value Configuration: 255
                ***************************************************************************************************************************

                Could you please help me again in addressing the fix to it?

                Thanks a ton in advance for giving your precious time to me.
                • 5. Re: AIA Foundation Pack installation - Failed
                  Gerhard Drasch-Oracle
                  This is another, not related issue.

                  This typically happens fs the JCA adapter for Oracle applications is not deployed properly in SOA suite. Use Weblogic console to make sure this is the case (Deployments -> OracleAppsAdapter), otherwise the AIA deployment will never succeed.

                  Gerhard
                  • 6. Re: AIA Foundation Pack installation - Failed
                    729777
                    Hi, I am new to AIA and busy installing AIA foundation pack in my local computer. The steps from 1 to 10 has been completed success fully, but during 11th step i am getting the following error.

                    [wlst]
                    [wlst] Warning: An insecure protocol was used to connect to the
                    [wlst] server. To ensure on-the-wire security, the SSL port or
                    [wlst] Admin port should be used instead.
                    [wlst]
                    [wlst] Location changed to edit tree. This is a writable tree with
                    [wlst] DomainMBean as the root. To make changes you will need to start
                    [wlst] an edit session via startEdit().
                    [wlst]
                    [wlst] For more help, use help(edit)
                    [wlst]
                    [wlst] Edit session is cancelled successfully
                    [wlst] Already in Edit Tree
                    [wlst]
                    [wlst] Starting an edit session ...
                    [wlst] Started edit session, please be sure to save and activate your
                    [wlst] changes once you are done.
                    [wlst] attempting to delete data source with name -LifeCycleDataSource
                    [wlst] Data source deleted !!
                    [wlst] Validating changes ...
                    [wlst] Validated the changes successfully
                    [wlst] Saving all your changes ...
                    [wlst] Saved all your changes successfully.
                    [wlst] Activating all your changes, this may take a while ...
                    [wlst] The edit lock associated with this edit session is released
                    [wlst] once the activation is completed.
                    [wlst] Activation completed
                    [wlst] No stack trace available.
                    [wlst] Disconnected from weblogic server: AdminServer
                    [wlst] @@@ Starting the script ...
                    [wlst] Connecting to t3://localhost:7001 with userid weblogic ...
                    [wlst] Successfully connected to Admin Server 'AdminServer' that belongs to domain 'developer_domain'.
                    [wlst]
                    [wlst] Warning: An insecure protocol was used to connect to the
                    [wlst] server. To ensure on-the-wire security, the SSL port or
                    [wlst] Admin port should be used instead.
                    [wlst]
                    [wlst] Location changed to edit tree. This is a writable tree with
                    [wlst] DomainMBean as the root. To make changes you will need to start
                    [wlst] an edit session via startEdit().
                    [wlst]
                    [wlst] For more help, use help(edit)
                    [wlst]
                    [wlst] Edit session is cancelled successfully
                    [wlst] Already in Edit Tree
                    [wlst]
                    [wlst] Starting an edit session ...
                    [wlst] Started edit session, please be sure to save and activate your
                    [wlst] changes once you are done.
                    [wlst] attempting to delete data source with name -AIAJMSDS
                    [wlst] Data source deleted !!
                    [wlst] Validating changes ...
                    [wlst] Validated the changes successfully
                    [wlst] Saving all your changes ...
                    [wlst] Saved all your changes successfully.
                    [wlst] Activating all your changes, this may take a while ...
                    [wlst] The edit lock associated with this edit session is released
                    [wlst] once the activation is completed.
                    [wlst] Activation completed
                    [wlst] No stack trace available.
                    [wlst] Disconnected from weblogic server: AdminServer

                    BUILD FAILED
                    E:\Middleware\AIAHome\Infrastructure\Install\AID\AIAExecuteDriver.xml:222: The following error occurred while executing this line:
                    E:\Middleware\AIAHome\Infrastructure\Install\AID\AIAExecuteDriver.xml:65: The following error occurred while executing this line:
                    E:\Middleware\AIAHome\aia_instances\AIAFP1\tmp\AIDExecuteDP_temp_1922697963.xml:24: The following error occurred while executing this line:
                    E:\Middleware\AIAHome\Infrastructure\Install\AID\lib\AIDConfigurationLibraryTasks.xml:431: java.sql.SQLException: ORA-00604: error occurred at recursive SQL level 1
                    ORA-01882: timezone region not found


                    Total time: 1 minute 34 seconds
                    'choice' is not recognized as an internal or external command

                    Please assist regarding this.
                    • 7. Re: AIA Foundation Pack installation - Failed
                      oracledigger
                      You should check the prerequisites : Operating system compatibility etc... Before trying to install.